summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-06-26 09:53:30 +0200
committerRemi Collet <remi@remirepo.net>2017-06-26 09:53:30 +0200
commitedcbdd5185732720098144de0f9d7650096face4 (patch)
treeeaaa5cace62b996085a835e551e169aba159b70a
parent2dacf9e15758be10401be825556bef0d63f23a7b (diff)
v6.3.0 (backported from Fedora)
-rw-r--r--.gitignore12
-rw-r--r--composer.json7
-rw-r--r--php-guzzlehttp-guzzle6-upstream-pull-1792.patch36
-rw-r--r--php-guzzlehttp-guzzle6.spec28
4 files changed, 25 insertions, 58 deletions
diff --git a/.gitignore b/.gitignore
index 13c9439..1ab5c4f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
-/php-guzzlehttp-guzzle6-6.1.1-c6851d6e48f63b69357cbfa55bca116448140e0c.tar.gz
-/php-guzzlehttp-guzzle6-6.2.0-d094e337976dff9d8e2424e8485872194e768662.tar.gz
-/php-guzzlehttp-guzzle6-6.2.1-3f808fba627f2c5b69e2501217bf31af349c1427.tar.gz
-/php-guzzlehttp-guzzle6-6.2.2-ebf29dee597f02f09f4d5bbecc68230ea9b08f60.tar.gz
-/php-guzzlehttp-guzzle6-6.2.3-8d6c6cc55186db87b7dc5009827429ba4e9dc006.tar.gz
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index 218c247..65687a5 100644
--- a/composer.json
+++ b/composer.json
@@ -14,12 +14,12 @@
],
"require": {
"php": ">=5.5",
- "guzzlehttp/psr7": "^1.3.1",
+ "guzzlehttp/psr7": "^1.4",
"guzzlehttp/promises": "^1.0"
},
"require-dev": {
"ext-curl": "*",
- "phpunit/phpunit": "^4.0",
+ "phpunit/phpunit": "^4.0 || ^5.0",
"psr/log": "^1.0"
},
"autoload": {
@@ -33,6 +33,9 @@
"GuzzleHttp\\Tests\\": "tests/"
}
},
+ "suggest": {
+ "psr/log": "Required for using the Log middleware"
+ },
"extra": {
"branch-alias": {
"dev-master": "6.2-dev"
diff --git a/php-guzzlehttp-guzzle6-upstream-pull-1792.patch b/php-guzzlehttp-guzzle6-upstream-pull-1792.patch
deleted file mode 100644
index dbf6168..0000000
--- a/php-guzzlehttp-guzzle6-upstream-pull-1792.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 60f134a2cd7149fa063bc797bc9db1d8ccdb4031 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Thu, 30 Mar 2017 08:59:56 +0200
-Subject: [PATCH] Fix #1790 proxy should not end with /
-
----
- src/Handler/StreamHandler.php | 2 +-
- tests/Handler/StreamHandlerTest.php | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/Handler/StreamHandler.php b/src/Handler/StreamHandler.php
-index d36787a..1f868b8 100644
---- a/src/Handler/StreamHandler.php
-+++ b/src/Handler/StreamHandler.php
-@@ -381,7 +381,7 @@ private function add_proxy(RequestInterface $request, &$options, $value, &$param
- $value['no']
- )
- ) {
-- $options['http']['proxy'] = $value[$scheme];
-+ $options['http']['proxy'] = rtrim($value[$scheme], '/');
- }
- }
- }
-diff --git a/tests/Handler/StreamHandlerTest.php b/tests/Handler/StreamHandlerTest.php
-index c04a824..8449549 100644
---- a/tests/Handler/StreamHandlerTest.php
-+++ b/tests/Handler/StreamHandlerTest.php
-@@ -272,7 +272,7 @@ public function testAddsProxyByProtocol()
- $url = str_replace('http', 'tcp', Server::$url);
- $res = $this->getSendResult(['proxy' => ['http' => $url]]);
- $opts = stream_context_get_options($res->getBody()->detach());
-- $this->assertEquals($url, $opts['http']['proxy']);
-+ $this->assertEquals(rtrim($url, '/'), $opts['http']['proxy']);
- }
-
- public function testAddsProxyButHonorsNoProxy()
diff --git a/php-guzzlehttp-guzzle6.spec b/php-guzzlehttp-guzzle6.spec
index 2b437ab..e4c82c1 100644
--- a/php-guzzlehttp-guzzle6.spec
+++ b/php-guzzlehttp-guzzle6.spec
@@ -12,8 +12,8 @@
%global github_owner guzzle
%global github_name guzzle
-%global github_version 6.2.3
-%global github_commit 8d6c6cc55186db87b7dc5009827429ba4e9dc006
+%global github_version 6.3.0
+%global github_commit f4db5a78a5ea468d4831de7f0bf9d9415e348699
%global composer_vendor guzzlehttp
%global composer_project guzzle
@@ -51,11 +51,6 @@ URL: http://guzzlephp.org
Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
Source1: %{name}-get-source.sh
-# Proxy should not end with /
-# https://github.com/guzzle/guzzle/pull/1792
-# https://github.com/guzzle/guzzle/pull/1792.patch
-Patch0: %{name}-upstream-pull-1792.patch
-
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -69,7 +64,7 @@ BuildRequires: php-composer(guzzlehttp/psr7) < %{psr7_max_ver}
BuildRequires: php-composer(phpunit/phpunit)
BuildRequires: php-composer(psr/log) >= %{psr_log_min_ver}
BuildRequires: php-composer(psr/log) < %{psr_log_max_ver}
-## phpcompatinfo (computed from version 6.2.3)
+## phpcompatinfo (computed from version 6.3.0)
BuildRequires: php-curl
BuildRequires: php-date
BuildRequires: php-filter
@@ -90,9 +85,10 @@ Requires: php-composer(guzzlehttp/promises) >= %{promises_min_ver}
Requires: php-composer(guzzlehttp/promises) < %{promises_max_ver}
Requires: php-composer(guzzlehttp/psr7) >= %{psr7_min_ver}
Requires: php-composer(guzzlehttp/psr7) < %{psr7_max_ver}
+# composer.json: optional
Requires: php-composer(psr/log) >= %{psr_log_min_ver}
Requires: php-composer(psr/log) < %{psr_log_max_ver}
-# phpcompatinfo (computed from version 6.2.3)
+# phpcompatinfo (computed from version 6.3.0)
Requires: php-curl
Requires: php-date
Requires: php-filter
@@ -126,9 +122,6 @@ Autoloader: %{phpdir}/GuzzleHttp6/autoload.php
%prep
%setup -qn %{github_name}-%{github_commit}
-# Proxy should not end with /
-%patch0 -p1
-
%build
: Create common autoloader
@@ -172,9 +165,10 @@ sed 's/function testDescribesType/function SKIP_testDescribesType/' \
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in php php56 php70 php71; do
- if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC %{_bindir}/phpunit --verbose
+PHPUNIT=$(which phpunit)
+for PHP_EXEC in "" php56 php70 php71 php72; do
+ if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
+ $PHP_EXEC $PHPUNIT --verbose
fi
done
exit $RETURN_CODE
@@ -192,6 +186,10 @@ exit $RETURN_CODE
%changelog
+* Fri Jun 23 2017 Shawn Iwinski <shawn@iwin.ski> - 6.3.0-1
+- Update to 6.3.0 (RHBZ #1464283)
+- Remove patch
+
* Fri Apr 07 2017 Shawn Iwinski <shawn@iwin.ski> - 6.2.3-1
- Update to 6.2.3
- Fix rawhide (F27) FTBS