summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-06-19 14:57:55 +0200
committerRemi Collet <remi@remirepo.net>2019-06-19 14:57:55 +0200
commit60c672ae38f97eb4381a2a6c5db6597f346184bb (patch)
treefbeec0fa16d3a9edd05a040a11955df168aa2ae4
parentf53ac90e2cd7ab568e71c6cbbdc92f0c16e92895 (diff)
add backport stuff
-rw-r--r--.gitignore8
-rw-r--r--Makefile4
-rw-r--r--php-google-auth.spec6
3 files changed, 17 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-google-auth.spec b/php-google-auth.spec
index 4dae28a..a9a2b0f 100644
--- a/php-google-auth.spec
+++ b/php-google-auth.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-google-auth
#
# Fedora spec file for php-google-auth
#
@@ -130,7 +131,9 @@ Requires: php-composer(fedora/autoloader)
# Weak dependencies
## composer.json: optional
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Suggests: php-composer(phpseclib/phpseclib)
+%endif
Conflicts: php-composer(phpseclib/phpseclib) < 2
Conflicts: php-composer(phpseclib/phpseclib) >= 3
@@ -200,9 +203,10 @@ sed 's/function testMakeHttpClient/function SKIP_testMakeHttpClient/'\
-i tests/FetchAuthTokenTest.php
: Upstream tests
+# TODO 7.4: There were 41 errors: Function ReflectionType::__toString() is deprecated
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in php %{?rhel:php55} php56 php70 php71 php72 php73 php74; do
+for PHP_EXEC in php %{?rhel:php55 php56 php70} php71 php72 php73; do
if which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose || RETURN_CODE=1
fi