summaryrefslogtreecommitdiffstats
path: root/php-google-auth.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-google-auth.spec')
-rw-r--r--php-google-auth.spec6
1 files changed, 5 insertions, 1 deletions
diff --git a/php-google-auth.spec b/php-google-auth.spec
index 4dae28a..a9a2b0f 100644
--- a/php-google-auth.spec
+++ b/php-google-auth.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-google-auth
#
# Fedora spec file for php-google-auth
#
@@ -130,7 +131,9 @@ Requires: php-composer(fedora/autoloader)
# Weak dependencies
## composer.json: optional
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Suggests: php-composer(phpseclib/phpseclib)
+%endif
Conflicts: php-composer(phpseclib/phpseclib) < 2
Conflicts: php-composer(phpseclib/phpseclib) >= 3
@@ -200,9 +203,10 @@ sed 's/function testMakeHttpClient/function SKIP_testMakeHttpClient/'\
-i tests/FetchAuthTokenTest.php
: Upstream tests
+# TODO 7.4: There were 41 errors: Function ReflectionType::__toString() is deprecated
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in php %{?rhel:php55} php56 php70 php71 php72 php73 php74; do
+for PHP_EXEC in php %{?rhel:php55 php56 php70} php71 php72 php73; do
if which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose || RETURN_CODE=1
fi