summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-02-06 09:19:18 +0100
committerRemi Collet <remi@remirepo.net>2018-02-06 09:19:18 +0100
commitc65d942479581cade73cb7d6a9a8a4e5998b9543 (patch)
tree66ebd2509904e24563d111bc0f62ae16082a9390
parentd0a27a0ac21493975d1b8972e0fad4c75a8bbf8d (diff)
-rw-r--r--composer.json5
-rw-r--r--php-gecko-packages-gecko-php-unit.spec11
2 files changed, 11 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index febdd23..e4b235f 100644
--- a/composer.json
+++ b/composer.json
@@ -8,6 +8,9 @@
"require": {
"php": "^5.3.6 || ^7.0"
},
+ "conflict": {
+ "phpunit/phpunit": ">=6.0"
+ },
"require-dev": {
"phpunit/phpunit": "^4.8.35 || ^5.4.3"
},
@@ -23,6 +26,6 @@
"suggest": {
"ext-dom": "When testing with xml.",
"ext-libxml": "When testing with xml.",
- "phpunit/phpunit" : "This is an extension for it so make sure you have it some way."
+ "phpunit/phpunit" : "This is an extension for PHPUnit so make sure you have that in some way."
}
}
diff --git a/php-gecko-packages-gecko-php-unit.spec b/php-gecko-packages-gecko-php-unit.spec
index 226f949..dd3a28d 100644
--- a/php-gecko-packages-gecko-php-unit.spec
+++ b/php-gecko-packages-gecko-php-unit.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-gecko-packages-gecko-php-unit
#
-# Copyright (c) 2016-2017 Remi Collet
+# Copyright (c) 2016-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit ab525fac9a9ffea219687f261b02008b18ebf2d1
+%global gh_commit a06beb80f63645140c251cfd757ba94a4a540be5
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner GeckoPackages
@@ -17,7 +17,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{pk_owner}-%{pk_project}
-Version: 2.2
+Version: 2.2.1
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: Additional PHPUnit asserts and constraints
@@ -37,7 +37,7 @@ BuildRequires: php-libxml
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "4.0"
+# "phpunit/phpunit": "^4.8.35 || ^5.4.3"
BuildRequires: php-composer(phpunit/phpunit)
# Autoloader
BuildRequires: php-composer(fedora/autoloader)
@@ -120,6 +120,9 @@ exit $ret
%changelog
+* Tue Feb 6 2018 Remi Collet <remi@remirepo.net> - 2.2.1-1
+- Update to 2.2.1
+
* Thu Aug 24 2017 Remi Collet <remi@remirepo.net> - 2.2-1
- Update to 2.2