summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-24 09:57:00 +0200
committerRemi Collet <remi@remirepo.net>2017-08-24 09:57:00 +0200
commitd0a27a0ac21493975d1b8972e0fad4c75a8bbf8d (patch)
treeb06892e61c43983bd8e73f4615180a5ac118b71f
parentf72fc44bd6c18a8822a6d50e48669ef1faca34e7 (diff)
v2.2
-rw-r--r--composer.json13
-rw-r--r--php-gecko-packages-gecko-php-unit.spec14
2 files changed, 19 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index aca3d6f..febdd23 100644
--- a/composer.json
+++ b/composer.json
@@ -2,7 +2,7 @@
"name": "gecko-packages/gecko-php-unit",
"type": "library",
"homepage": "https://github.com/GeckoPackages",
- "description": "Additional PHPUnit tests.",
+ "description": "Additional PHPUnit asserts and constraints.",
"license": "MIT",
"keywords": ["PHPUnit", "Extension", "FileSystem"],
"require": {
@@ -13,7 +13,16 @@
},
"autoload": {
"psr-4": {
- "GeckoPackages\\PHPUnit\\": "src\\PHPUnit"
+ "GeckoPackages\\PHPUnit\\": "src/PHPUnit"
}
+ },
+ "config": {
+ "optimize-autoloader": true,
+ "sort-packages": true
+ },
+ "suggest": {
+ "ext-dom": "When testing with xml.",
+ "ext-libxml": "When testing with xml.",
+ "phpunit/phpunit" : "This is an extension for it so make sure you have it some way."
}
}
diff --git a/php-gecko-packages-gecko-php-unit.spec b/php-gecko-packages-gecko-php-unit.spec
index c0cc844..226f949 100644
--- a/php-gecko-packages-gecko-php-unit.spec
+++ b/php-gecko-packages-gecko-php-unit.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 5b9e9622c7efd3b22655270b80c03f9e52878a6e
+%global gh_commit ab525fac9a9ffea219687f261b02008b18ebf2d1
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner GeckoPackages
@@ -17,9 +17,9 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{pk_owner}-%{pk_project}
-Version: 2.1
+Version: 2.2
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
-Summary: Additional PHPUnit tests
+Summary: Additional PHPUnit asserts and constraints
Group: Development/Tools
License: MIT
@@ -32,7 +32,6 @@ BuildArch: noarch
%if %{with_tests}
# For tests
BuildRequires: php(language) >= 5.3.6
-BuildRequires: php-ctype
BuildRequires: php-dom
BuildRequires: php-libxml
BuildRequires: php-pcre
@@ -47,8 +46,7 @@ BuildRequires: php-composer(fedora/autoloader)
# From composer.json, "require": {
# "php": "^5.3.6 || ^7.0"
Requires: php(language) >= 5.3.6
-# From phpcompatinfo report for version 2.0.0
-Requires: php-ctype
+# From phpcompatinfo report for version 2.2
Requires: php-dom
Requires: php-libxml
Requires: php-pcre
@@ -66,6 +64,7 @@ in the hierarchy of test classes.
Autoloader: %{php_home}/GeckoPackages/PHPUnit/autoload.php
+
%prep
%setup -q -n %{gh_project}-%{gh_commit}
@@ -121,6 +120,9 @@ exit $ret
%changelog
+* Thu Aug 24 2017 Remi Collet <remi@remirepo.net> - 2.2-1
+- Update to 2.2
+
* Wed Jun 28 2017 Remi Collet <remi@remirepo.net> - 2.1-1
- Update to 2.1