summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-04-03 07:55:45 +0200
committerRemi Collet <fedora@famillecollet.com>2017-04-03 07:55:45 +0200
commit40b9564b05d65b26a4b891108832e3d21310a219 (patch)
treeccbad1da08e0f71c4d3c480eb8ac181d85fde827
parent9f7fd9ab970cfc759f55571285c2e7f64cc7e9c8 (diff)
backport
-rw-r--r--Makefile4
-rw-r--r--composer.json27
-rwxr-xr-xphp-firebase-php-jwt-get-source.sh4
-rw-r--r--php-firebase-php-jwt.spec4
4 files changed, 38 insertions, 1 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..1a5e93b
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,27 @@
+{
+ "name": "firebase/php-jwt",
+ "description": "A simple library to encode and decode JSON Web Tokens (JWT) in PHP. Should conform to the current spec.",
+ "homepage": "https://github.com/firebase/php-jwt",
+ "authors": [
+ {
+ "name": "Neuman Vong",
+ "email": "neuman+pear@twilio.com",
+ "role": "Developer"
+ },
+ {
+ "name": "Anant Narayanan",
+ "email": "anant@php.net",
+ "role": "Developer"
+ }
+ ],
+ "license": "BSD-3-Clause",
+ "require": {
+ "php": ">=5.3.0"
+ },
+ "autoload": {
+ "psr-4": {
+ "Firebase\\JWT\\": "src"
+ }
+ },
+ "minimum-stability": "dev"
+}
diff --git a/php-firebase-php-jwt-get-source.sh b/php-firebase-php-jwt-get-source.sh
index ba71f5d..4ad1051 100755
--- a/php-firebase-php-jwt-get-source.sh
+++ b/php-firebase-php-jwt-get-source.sh
@@ -43,6 +43,8 @@ print "GIT_REPO = $GIT_REPO"
print "GIT_DIR = $GIT_DIR"
TEMP_DIR=$(mktemp --dir)
+TAR_FILE=$PWD/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
+CMP_FILE=$PWD/composer.json
pushd $TEMP_DIR
print "Cloning git repo..."
@@ -51,6 +53,7 @@ pushd $TEMP_DIR
pushd $GIT_DIR
print "Checking out commit..."
$GIT checkout $GIT_COMMIT
+ cp composer.json $CMP_FILE
popd
TAR_DIR=${GIT_NAME}-${GIT_COMMIT}
@@ -58,7 +61,6 @@ pushd $TEMP_DIR
mv $GIT_DIR $TAR_DIR
- TAR_FILE=`$RPM --eval='%{_sourcedir}'`/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
print "TAR_FILE = $TAR_FILE"
[ -e $TAR_FILE ] && rm -f $TAR_FILE
diff --git a/php-firebase-php-jwt.spec b/php-firebase-php-jwt.spec
index 86e680c..f2965bc 100644
--- a/php-firebase-php-jwt.spec
+++ b/php-firebase-php-jwt.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-firebase-php-jwt, from:
#
# Fedora spec file for php-firebase-php-jwt
#
@@ -134,5 +135,8 @@ exit $RETURN_CODE
%changelog
+* Mon Apr 3 2017 Remi Collet <remi@remirepo.net> - 4.0.0-1
+- backport to to remi's repository
+
* Sat Mar 11 2017 Shawn Iwinski <shawn@iwin.ski> - 4.0.0-1
- Initial package