summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-05-27 13:33:42 +0200
committerRemi Collet <remi@remirepo.net>2019-05-27 13:33:42 +0200
commit5d857f66388874e037cbcc398d03a302cf1b0510 (patch)
tree23ee3bc7e223b6fe534e0192d0ca5de1c6a6e044
parent40b9564b05d65b26a4b891108832e3d21310a219 (diff)
v5.0.0 from FedoraHEADmaster
-rw-r--r--composer.json4
l---------makesrc.sh1
-rw-r--r--php-firebase-php-jwt.spec16
3 files changed, 13 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 1a5e93b..b76ffd1 100644
--- a/composer.json
+++ b/composer.json
@@ -23,5 +23,7 @@
"Firebase\\JWT\\": "src"
}
},
- "minimum-stability": "dev"
+ "require-dev": {
+ "phpunit/phpunit": " 4.8.35"
+ }
}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 120000
index 0000000..355a1b6
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1 @@
+php-firebase-php-jwt-get-source.sh \ No newline at end of file
diff --git a/php-firebase-php-jwt.spec b/php-firebase-php-jwt.spec
index f2965bc..952bc84 100644
--- a/php-firebase-php-jwt.spec
+++ b/php-firebase-php-jwt.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-firebase-php-jwt
#
-# Copyright (c) 2017 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2017-2019 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner firebase
%global github_name php-jwt
-%global github_version 4.0.0
-%global github_commit dccf163dc8ed7ed6a00afc06c51ee5186a428d35
+%global github_version 5.0.0
+%global github_commit 9984a4d3a32ae7673d6971ea00bae9d0a1abba0e
%global composer_vendor firebase
%global composer_project php-jwt
@@ -31,7 +31,6 @@ Version: %{github_version}
Release: 1%{?github_release}%{?dist}
Summary: A simple library to encode and decode JSON Web Tokens (JWT)
-Group: Development/Libraries
License: BSD
URL: https://github.com/%{github_owner}/%{github_name}
@@ -46,7 +45,7 @@ BuildArch: noarch
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
-## phpcompatinfo (computed from version 4.0.0)
+## phpcompatinfo (computed from version 5.0.0)
BuildRequires: php-date
BuildRequires: php-hash
BuildRequires: php-json
@@ -60,7 +59,7 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 4.0.0)
+# phpcompatinfo (computed from version 5.0.0)
Requires: php-date
Requires: php-hash
Requires: php-json
@@ -112,7 +111,7 @@ BOOTSTRAP=%{buildroot}%{phpdir}/Firebase/JWT/autoload.php
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in php %{?rhel:php54 php55} php56 php70 php71; do
+for PHP_EXEC in php %{?rhel:php54 php55 php56 php70} php71 php72 php73 php74; do
if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC %{_bindir}/phpunit \
--bootstrap %{buildroot}%{phpdir}/Firebase/JWT/autoload.php \
@@ -135,6 +134,9 @@ exit $RETURN_CODE
%changelog
+* Fri May 24 2019 Shawn Iwinski <shawn@iwin.ski> - 5.0.0-1
+- Update to 5.0.0 (RHBZ #1465699)
+
* Mon Apr 3 2017 Remi Collet <remi@remirepo.net> - 4.0.0-1
- backport to to remi's repository