summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-06-02 07:59:25 +0200
committerRemi Collet <remi@remirepo.net>2020-06-02 07:59:25 +0200
commit9e2f18fd6838f8b411099425dc1d8b5d9162373b (patch)
tree5bb5ff1276c3204332838537dfdabab5b16a4c4d
parentb3b02c6bca2ffba9e91d1b4504b46be274b4b23b (diff)
downgrade to 1.1.0
-rw-r--r--composer.json10
-rw-r--r--php-doctrine-sql-formatter.spec20
2 files changed, 11 insertions, 19 deletions
diff --git a/composer.json b/composer.json
index 496ee8e..27c7524 100644
--- a/composer.json
+++ b/composer.json
@@ -6,14 +6,10 @@
"license": "MIT",
"type": "library",
"require": {
- "php": "^7.2"
+ "php": "^7.1 || ^8.0"
},
"require-dev": {
- "doctrine/coding-standard": "^7.0",
- "phpstan/phpstan": "^0.12.18",
- "phpunit/phpunit": "^8.0",
- "psalm/plugin-phpunit": "^0.10.0",
- "vimeo/psalm": "^3.10"
+ "bamarni/composer-bin-plugin": "^1.4"
},
"authors": [
{
@@ -35,7 +31,7 @@
"config": {
"sort-packages": true,
"platform": {
- "php": "7.2.0"
+ "php": "7.1.0"
}
},
"extra": {
diff --git a/php-doctrine-sql-formatter.spec b/php-doctrine-sql-formatter.spec
index 729c963..97550ee 100644
--- a/php-doctrine-sql-formatter.spec
+++ b/php-doctrine-sql-formatter.spec
@@ -8,7 +8,7 @@
#
%global bootstrap 0
-%global gh_commit 1ad4f97f10cd0eef7ca7d3f5b7b1cf7e5806786f
+%global gh_commit 5458bdcf176f6a53292e3f0cc73f292d6302fb0f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner doctrine
%global gh_project sql-formatter
@@ -26,7 +26,7 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 1.1.1
+Version: 1.1.0
Release: 1%{?dist}
Summary: SQL highlighting library
@@ -38,21 +38,17 @@ Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel
%if %{with_tests}
-BuildRequires: php(language) >= 7.2
+BuildRequires: php(language) >= 7.1
BuildRequires: php-pcre
# From composer.json
-# "doctrine/coding-standard": "^7.0",
-# "phpstan/phpstan": "^0.12.18",
-# "phpunit/phpunit": "^8.0",
-# "psalm/plugin-phpunit": "^0.10.0",
-# "vimeo/psalm": "^3.10"
+# "bamarni/composer-bin-plugin": "^1.4"
BuildRequires: phpunit8
%endif
# From composer.json
-# "php": "^7.2"
-Requires: php(language) >= 7.2
-# From phpcompatinfo report for version 1.1.1
+# "php": "^7.1 || ^8.0"
+Requires: php(language) >= 7.1
+# From phpcompatinfo report for version 1.1.0
Requires: php-pcre
# Autoloader
@@ -128,5 +124,5 @@ exit $ret
%changelog
-* Tue May 26 2020 Remi Collet <remi@remirepo.net> - 1.1.1-1
+* Tue May 26 2020 Remi Collet <remi@remirepo.net> - 1.1.0-1
- initial package