summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-05-26 08:44:46 +0200
committerRemi Collet <remi@remirepo.net>2020-05-26 08:44:46 +0200
commitb3b02c6bca2ffba9e91d1b4504b46be274b4b23b (patch)
tree7f3ede13016a80fea0bfaabebe69ebf85cab1dce
parent579954b77755b9d8c3d3cf057fa6dce6202a1968 (diff)
v1.1.1
-rw-r--r--composer.json10
-rw-r--r--php-doctrine-sql-formatter.spec19
2 files changed, 17 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index 0e6ccb1..496ee8e 100644
--- a/composer.json
+++ b/composer.json
@@ -6,10 +6,14 @@
"license": "MIT",
"type": "library",
"require": {
- "php": "^7.1"
+ "php": "^7.2"
},
"require-dev": {
- "bamarni/composer-bin-plugin": "^1.4"
+ "doctrine/coding-standard": "^7.0",
+ "phpstan/phpstan": "^0.12.18",
+ "phpunit/phpunit": "^8.0",
+ "psalm/plugin-phpunit": "^0.10.0",
+ "vimeo/psalm": "^3.10"
},
"authors": [
{
@@ -31,7 +35,7 @@
"config": {
"sort-packages": true,
"platform": {
- "php": "7.1.0"
+ "php": "7.2.0"
}
},
"extra": {
diff --git a/php-doctrine-sql-formatter.spec b/php-doctrine-sql-formatter.spec
index f5ed1c3..729c963 100644
--- a/php-doctrine-sql-formatter.spec
+++ b/php-doctrine-sql-formatter.spec
@@ -38,17 +38,21 @@ Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel
%if %{with_tests}
-BuildRequires: php(language) >= 7.1
+BuildRequires: php(language) >= 7.2
BuildRequires: php-pcre
# From composer.json
-# "bamarni/composer-bin-plugin": "^1.4"
+# "doctrine/coding-standard": "^7.0",
+# "phpstan/phpstan": "^0.12.18",
+# "phpunit/phpunit": "^8.0",
+# "psalm/plugin-phpunit": "^0.10.0",
+# "vimeo/psalm": "^3.10"
BuildRequires: phpunit8
%endif
# From composer.json
-# "php": "^7.1"
-Requires: php(language) >= 7.1
-# From phpcompatinfo report for version 1.0.1
+# "php": "^7.2"
+Requires: php(language) >= 7.2
+# From phpcompatinfo report for version 1.1.1
Requires: php-pcre
# Autoloader
@@ -125,7 +129,4 @@ exit $ret
%changelog
* Tue May 26 2020 Remi Collet <remi@remirepo.net> - 1.1.1-1
-- update to 1.1.1
-
-* Tue May 26 2020 Remi Collet <remi@remirepo.net> - 1.0.1-1
-- initial package, version 1.0.1
+- initial package