summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-08-11 15:29:56 +0200
committerRemi Collet <remi@remirepo.net>2020-08-11 15:29:56 +0200
commit1852f4845439c78047056358b46cf28c1f836d1b (patch)
tree7d65fc7a2f74ab8f6599e2a46df85e43a5025a0c
parentc52aeb1fe2267dd57520fff7888c209a0005f7ae (diff)
update to 1.3.8HEADmaster
switch to phpunit9
-rw-r--r--composer.json5
-rw-r--r--php-doctrine-persistence.spec25
2 files changed, 20 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index d750c30..c7c79f2 100644
--- a/composer.json
+++ b/composer.json
@@ -20,7 +20,7 @@
{"name": "Marco Pivetta", "email": "ocramius@gmail.com"}
],
"require": {
- "php": "^7.1",
+ "php": "^7.1 || ^8.0",
"doctrine/annotations": "^1.0",
"doctrine/cache": "^1.0",
"doctrine/collections": "^1.0",
@@ -30,7 +30,8 @@
"require-dev": {
"phpstan/phpstan": "^0.11",
"doctrine/coding-standard": "^6.0",
- "phpunit/phpunit": "^7.0"
+ "phpunit/phpunit": "^7.0 || ^8.0 || ^9.0",
+ "vimeo/psalm": "^3.11"
},
"conflict": {
"doctrine/common": "<2.10@dev"
diff --git a/php-doctrine-persistence.spec b/php-doctrine-persistence.spec
index 38ce37b..11cb8c5 100644
--- a/php-doctrine-persistence.spec
+++ b/php-doctrine-persistence.spec
@@ -8,7 +8,7 @@
#
%global bootstrap 0
-%global gh_commit 0af483f91bada1c9ded6c2cfd26ab7d5ab2094e0
+%global gh_commit 7a6eac9fb6f61bba91328f15aa7547f4806ca288
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner doctrine
%global gh_project persistence
@@ -26,7 +26,7 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}
-Version: 1.3.7
+Version: 1.3.8
Release: 1%{?dist}
Summary: Doctrine Persistence abstractions
@@ -45,9 +45,10 @@ BuildRequires: php-spl
# From composer.json
# "phpstan/phpstan": "^0.11",
# "doctrine/coding-standard": "^6.0",
-# "phpunit/phpunit": "^7.0"
+# "phpunit/phpunit": "^7.0 || ^8.0 || ^9.0",
+# "vimeo/psalm": "^3.11"
# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8
BuildRequires: (php-composer(doctrine/annotations) >= 1.0 with php-composer(doctrine/annotations) < 2)
BuildRequires: (php-composer(doctrine/cache) >= 1.0 with php-composer(doctrine/cache) < 2)
BuildRequires: (php-composer(doctrine/collections) >= 1.0 with php-composer(doctrine/collections) < 2)
@@ -66,11 +67,11 @@ BuildRequires: php-composer(doctrine/event-manager) >= 1.0
BuildRequires: php-composer(doctrine/reflection) < 2
BuildRequires: php-composer(doctrine/reflection) >= 1.2
%endif
-BuildRequires: phpunit7
+BuildRequires: phpunit9
%endif
# From composer.json
-# "php": "^7.1"
+# "php": "^7.1 || ^8.0"
# "doctrine/annotations": "^1.0",
# "doctrine/cache": "^1.0",
# "doctrine/collections": "^1.0",
@@ -165,9 +166,13 @@ find tests -type f -exec grep -q PHPStan {} \; -delete -print
: Run test suite
ret=0
-for cmd in php php71 php72 php73 php74; do
+# TODO php80 exception message differs
+for cmd in php73 php74 php80; do
if which $cmd; then
- $cmd %{_bindir}/phpunit7 \
+ VER=$($cmd -r 'echo PHP_VERSION_ID;')
+ [ $VER -ge 80000 ] && SKIP="--filter '^((?!(testGetManagerForInvalidClass|testGetManagerForInvalidAliasedClass)).)*$'"
+
+ $cmd %{_bindir}/phpunit9 $SKIP \
--bootstrap vendor/autoload.php \
--verbose || ret=1
fi
@@ -188,6 +193,10 @@ exit $ret
%changelog
+* Tue Aug 11 2020 Remi Collet <remi@remirepo.net> - 1.3.8-1
+- update to 1.3.8
+- switch to phpunit9
+
* Mon Mar 23 2020 Remi Collet <remi@remirepo.net> - 1.3.7-1
- update to 1.3.7 (no change)
- raise dependency on doctrine/reflection 1.2