summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-03-23 10:57:26 +0100
committerRemi Collet <remi@remirepo.net>2020-03-23 10:57:26 +0100
commitc52aeb1fe2267dd57520fff7888c209a0005f7ae (patch)
tree0b1bdc34b4ea33b468834e7feb3f57a8dabd9410
parentf409e4ff29eed192e2f29771fc8c9271175f45fe (diff)
update to 1.3.7 (no change)HEADmaster
raise dependency on doctrine/reflection 1.2
-rw-r--r--composer.json2
-rw-r--r--php-doctrine-persistence.spec18
2 files changed, 12 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 25a4eb3..d750c30 100644
--- a/composer.json
+++ b/composer.json
@@ -25,7 +25,7 @@
"doctrine/cache": "^1.0",
"doctrine/collections": "^1.0",
"doctrine/event-manager": "^1.0",
- "doctrine/reflection": "^1.1"
+ "doctrine/reflection": "^1.2"
},
"require-dev": {
"phpstan/phpstan": "^0.11",
diff --git a/php-doctrine-persistence.spec b/php-doctrine-persistence.spec
index d7e93a6..38ce37b 100644
--- a/php-doctrine-persistence.spec
+++ b/php-doctrine-persistence.spec
@@ -8,7 +8,7 @@
#
%global bootstrap 0
-%global gh_commit 5dd3ac5eebef2d0b074daa4440bb18f93132dee4
+%global gh_commit 0af483f91bada1c9ded6c2cfd26ab7d5ab2094e0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner doctrine
%global gh_project persistence
@@ -26,7 +26,7 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}
-Version: 1.3.6
+Version: 1.3.7
Release: 1%{?dist}
Summary: Doctrine Persistence abstractions
@@ -52,7 +52,7 @@ BuildRequires: (php-composer(doctrine/annotations) >= 1.0 with php-composer(
BuildRequires: (php-composer(doctrine/cache) >= 1.0 with php-composer(doctrine/cache) < 2)
BuildRequires: (php-composer(doctrine/collections) >= 1.0 with php-composer(doctrine/collections) < 2)
BuildRequires: (php-composer(doctrine/event-manager) >= 1.0 with php-composer(doctrine/event-manager) < 2)
-BuildRequires: (php-composer(doctrine/reflection) >= 1.1 with php-composer(doctrine/reflection) < 2)
+BuildRequires: (php-composer(doctrine/reflection) >= 1.2 with php-composer(doctrine/reflection) < 2)
# remirepo:12
%else
BuildRequires: php-composer(doctrine/annotations) < 2
@@ -64,7 +64,7 @@ BuildRequires: php-composer(doctrine/collections) >= 1.0
BuildRequires: php-composer(doctrine/event-manager) < 2
BuildRequires: php-composer(doctrine/event-manager) >= 1.0
BuildRequires: php-composer(doctrine/reflection) < 2
-BuildRequires: php-composer(doctrine/reflection) >= 1.1
+BuildRequires: php-composer(doctrine/reflection) >= 1.2
%endif
BuildRequires: phpunit7
%endif
@@ -75,7 +75,7 @@ BuildRequires: phpunit7
# "doctrine/cache": "^1.0",
# "doctrine/collections": "^1.0",
# "doctrine/event-manager": "^1.0",
-# "doctrine/reflection": "^1.1"
+# "doctrine/reflection": "^1.2"
Requires: php(language) >= 7.1
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -83,7 +83,7 @@ Requires: (php-composer(doctrine/annotations) >= 1.0 with php-composer(
Requires: (php-composer(doctrine/cache) >= 1.0 with php-composer(doctrine/cache) < 2)
Requires: (php-composer(doctrine/collections) >= 1.0 with php-composer(doctrine/collections) < 2)
Requires: (php-composer(doctrine/event-manager) >= 1.0 with php-composer(doctrine/event-manager) < 2)
-Requires: (php-composer(doctrine/reflection) >= 1.1 with php-composer(doctrine/reflection) < 2)
+Requires: (php-composer(doctrine/reflection) >= 1.2 with php-composer(doctrine/reflection) < 2)
# remirepo:12
%else
Requires: php-composer(doctrine/annotations) < 2
@@ -95,7 +95,7 @@ Requires: php-composer(doctrine/collections) >= 1.0
Requires: php-composer(doctrine/event-manager) < 2
Requires: php-composer(doctrine/event-manager) >= 1.0
Requires: php-composer(doctrine/reflection) < 2
-Requires: php-composer(doctrine/reflection) >= 1.1
+Requires: php-composer(doctrine/reflection) >= 1.2
%endif
# From phpcompatinfo report for version 1.0.0
Requires: php-reflection
@@ -188,6 +188,10 @@ exit $ret
%changelog
+* Mon Mar 23 2020 Remi Collet <remi@remirepo.net> - 1.3.7-1
+- update to 1.3.7 (no change)
+- raise dependency on doctrine/reflection 1.2
+
* Fri Jan 17 2020 Remi Collet <remi@remirepo.net> - 1.3.6-1
- update to 1.3.6
- raise dependency on doctrine/reflection 1.1