summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-11-09 09:01:59 +0100
committerRemi Collet <remi@remirepo.net>2020-11-09 09:01:59 +0100
commit6f05150fa5945d0ed6cbe296f37915e909516acb (patch)
treebae23828cfc77ef2e3ab0a2ac1ddacd8a3add6c9
parent45db73456b1704a716d09ed308ae1d9ccdc0ff24 (diff)
update to 2.2.0
allow twig version 3 switch to phpunit9
-rw-r--r--composer.json8
-rw-r--r--php-doctrine-doctrine-bundle2.spec28
2 files changed, 24 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index 9d16289..4febd11 100644
--- a/composer.json
+++ b/composer.json
@@ -38,10 +38,10 @@
"symfony/service-contracts": "^1.1.1|^2.0"
},
"require-dev": {
- "doctrine/coding-standard": "^6.0",
+ "doctrine/coding-standard": "^8.0",
"doctrine/orm": "^2.6",
"ocramius/proxy-manager": "^2.1",
- "phpunit/phpunit": "^7.5",
+ "phpunit/phpunit": "^7.5 || ^9.3",
"symfony/phpunit-bridge": "^4.2",
"symfony/property-info": "^4.3.3|^5.0",
"symfony/proxy-manager-bridge": "^3.4|^4.3.3|^5.0",
@@ -49,7 +49,7 @@
"symfony/validator": "^3.4.30|^4.3.3|^5.0",
"symfony/web-profiler-bundle": "^3.4.30|^4.3.3|^5.0",
"symfony/yaml": "^3.4.30|^4.3.3|^5.0",
- "twig/twig": "^1.34|^2.12"
+ "twig/twig": "^1.34|^2.12|^3.0"
},
"config": {
"sort-packages": true
@@ -70,7 +70,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "2.1.x-dev"
+ "dev-master": "2.2.x-dev"
}
}
}
diff --git a/php-doctrine-doctrine-bundle2.spec b/php-doctrine-doctrine-bundle2.spec
index 45e4598..1e7d257 100644
--- a/php-doctrine-doctrine-bundle2.spec
+++ b/php-doctrine-doctrine-bundle2.spec
@@ -13,8 +13,8 @@
%global github_owner doctrine
%global github_name DoctrineBundle
-%global github_version 2.1.2
-%global github_commit f5153089993e1230f5d8acbd8e126014d5a63e17
+%global github_version 2.2.0
+%global github_commit c1b1fe95a6cce5e53a1454c46ae3500e53fadae1
%global major 2
%global composer_vendor doctrine
@@ -53,10 +53,10 @@
# TODO v2 is not yet packaged
%global contracts_min_ver 1.1.1
%global contracts_max_ver 2
-# "twig/twig": "^1.34|^2.12"
+# "twig/twig": "^1.34|^2.12|^3.0"
%global twig_min_ver 1.34
%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
-%global twig_max_ver 3
+%global twig_max_ver 4
%else
%global twig_max_ver 2
%endif
@@ -128,7 +128,13 @@ BuildRequires: php-symfony4-twig-bridge >= %{symfony_br_ver}
BuildRequires: php-symfony4-validator >= %{symfony_br_ver}
BuildRequires: php-symfony4-web-profiler-bundle >= %{symfony_br_ver}
BuildRequires: php-symfony4-yaml >= %{symfony_br_ver}
+%if 0%{?fedora} >= 31 || 0%{?rhel} >= 9
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3
+%else
+%global phpunit %{_bindir}/phpunit7
BuildRequires: phpunit7 >= 7.5
+%endif
## phpcompatinfo (computed from version 2.0.0)
BuildRequires: php-dom
BuildRequires: php-pcre
@@ -262,6 +268,7 @@ require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
'%{phpdir}/Symfony4/Bundle/WebProfilerBundle/autoload.php',
'%{phpdir}/Symfony3/Bundle/WebProfilerBundle/autoload.php',
], [
+ '%{phpdir}/Twig3/autoload.php',
'%{phpdir}/Twig2/autoload.php',
'%{phpdir}/Twig/autoload.php',
],
@@ -293,10 +300,10 @@ sed -e '/listener/d' phpunit.xml.dist >phpunit.xml
: Upstream tests with SCLs if available
RETURN_CODE=0
-# TODO: php 8 PDOConnection::query() must be compatible with PDO::query(string $statement)
-for SCL in php php72 php73 php74; do
- if which $SCL; then
- $SCL %{_bindir}/phpunit7 \
+for CMDARG in "php %{phpunit}" "php72 %{_bindir}/phpunit7" php73 php74 php80; do
+ if which $CMDARG; then
+ set $CMDARG
+ $1 ${2:-%{_bindir}/phpunit9} \
--filter '^((?!(testBacktraceLogged)).)*$' \
--bootstrap bs.php \
--verbose || RETURN_CODE=1
@@ -320,6 +327,11 @@ exit $RETURN_CODE
%changelog
+* Mon Nov 9 2020 Remi Collet <remi@remirepo.net> - 2.2.0-1
+- update to 2.2.0
+- allow twig version 3
+- switch to phpunit9
+
* Tue Aug 25 2020 Remi Collet <remi@remirepo.net> - 2.1.2-1
- update to 2.1.2