summaryrefslogtreecommitdiffstats
path: root/php-doctrine-doctrine-bundle2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-doctrine-doctrine-bundle2.spec')
-rw-r--r--php-doctrine-doctrine-bundle2.spec28
1 files changed, 20 insertions, 8 deletions
diff --git a/php-doctrine-doctrine-bundle2.spec b/php-doctrine-doctrine-bundle2.spec
index 45e4598..1e7d257 100644
--- a/php-doctrine-doctrine-bundle2.spec
+++ b/php-doctrine-doctrine-bundle2.spec
@@ -13,8 +13,8 @@
%global github_owner doctrine
%global github_name DoctrineBundle
-%global github_version 2.1.2
-%global github_commit f5153089993e1230f5d8acbd8e126014d5a63e17
+%global github_version 2.2.0
+%global github_commit c1b1fe95a6cce5e53a1454c46ae3500e53fadae1
%global major 2
%global composer_vendor doctrine
@@ -53,10 +53,10 @@
# TODO v2 is not yet packaged
%global contracts_min_ver 1.1.1
%global contracts_max_ver 2
-# "twig/twig": "^1.34|^2.12"
+# "twig/twig": "^1.34|^2.12|^3.0"
%global twig_min_ver 1.34
%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
-%global twig_max_ver 3
+%global twig_max_ver 4
%else
%global twig_max_ver 2
%endif
@@ -128,7 +128,13 @@ BuildRequires: php-symfony4-twig-bridge >= %{symfony_br_ver}
BuildRequires: php-symfony4-validator >= %{symfony_br_ver}
BuildRequires: php-symfony4-web-profiler-bundle >= %{symfony_br_ver}
BuildRequires: php-symfony4-yaml >= %{symfony_br_ver}
+%if 0%{?fedora} >= 31 || 0%{?rhel} >= 9
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3
+%else
+%global phpunit %{_bindir}/phpunit7
BuildRequires: phpunit7 >= 7.5
+%endif
## phpcompatinfo (computed from version 2.0.0)
BuildRequires: php-dom
BuildRequires: php-pcre
@@ -262,6 +268,7 @@ require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
'%{phpdir}/Symfony4/Bundle/WebProfilerBundle/autoload.php',
'%{phpdir}/Symfony3/Bundle/WebProfilerBundle/autoload.php',
], [
+ '%{phpdir}/Twig3/autoload.php',
'%{phpdir}/Twig2/autoload.php',
'%{phpdir}/Twig/autoload.php',
],
@@ -293,10 +300,10 @@ sed -e '/listener/d' phpunit.xml.dist >phpunit.xml
: Upstream tests with SCLs if available
RETURN_CODE=0
-# TODO: php 8 PDOConnection::query() must be compatible with PDO::query(string $statement)
-for SCL in php php72 php73 php74; do
- if which $SCL; then
- $SCL %{_bindir}/phpunit7 \
+for CMDARG in "php %{phpunit}" "php72 %{_bindir}/phpunit7" php73 php74 php80; do
+ if which $CMDARG; then
+ set $CMDARG
+ $1 ${2:-%{_bindir}/phpunit9} \
--filter '^((?!(testBacktraceLogged)).)*$' \
--bootstrap bs.php \
--verbose || RETURN_CODE=1
@@ -320,6 +327,11 @@ exit $RETURN_CODE
%changelog
+* Mon Nov 9 2020 Remi Collet <remi@remirepo.net> - 2.2.0-1
+- update to 2.2.0
+- allow twig version 3
+- switch to phpunit9
+
* Tue Aug 25 2020 Remi Collet <remi@remirepo.net> - 2.1.2-1
- update to 2.1.2