summaryrefslogtreecommitdiffstats
path: root/php-doctrine-common3.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-12-08 11:23:34 +0100
committerRemi Collet <remi@remirepo.net>2020-12-08 11:23:34 +0100
commit8308e69fef4cea2e8db182a80504037f4ce3346c (patch)
tree2178b77a02b61e2d72c562f61c311e4ad5c63637 /php-doctrine-common3.spec
parent969902c87e05d1102bf67b9fa96452611b0e9919 (diff)
update to 3.1.0
switch to phpunit9
Diffstat (limited to 'php-doctrine-common3.spec')
-rw-r--r--php-doctrine-common3.spec23
1 files changed, 17 insertions, 6 deletions
diff --git a/php-doctrine-common3.spec b/php-doctrine-common3.spec
index fefa53b..fe38d66 100644
--- a/php-doctrine-common3.spec
+++ b/php-doctrine-common3.spec
@@ -10,8 +10,8 @@
%global github_owner doctrine
%global github_name common
-%global github_version 3.0.2
-%global github_commit a3c6479858989e242a2465972b4f7a8642baf0d4
+%global github_version 3.1.0
+%global github_commit 9f3e3f3cc5399604c0325d5ffa92609d694d950d
%global major 3
%global composer_vendor doctrine
@@ -59,7 +59,13 @@ BuildRequires: (php-composer(doctrine/persistence) >= %{doctrine_pers_min_ver} w
%else
BuildRequires: php-doctrine-persistence2
%endif
-BuildRequires: phpunit7
+%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.0
+%else
+%global phpunit %{_bindir}/phpunit8
+BuildRequires: phpunit8 >= 8.5
+%endif
## phpcompatinfo (computed from version 3.0.0)
BuildRequires: php-reflection
BuildRequires: php-date
@@ -127,9 +133,10 @@ sed "s#require.*autoload.*#require_once '%{buildroot}%{phpdir}/%{ns_vendor}/%{ns
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in "" php71 php72 php73 php74; do
- if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC %{_bindir}/phpunit7 --verbose || RETURN_CODE=1
+for CMDARG in "php %{phpunit}" "php71 %{_bindir}/phpunit7" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+ if which $CMDARG; then
+ set $CMDARG
+ $1 ${2:-%{_bindir}/phpunit9} --verbose || RETURN_CODE=1
fi
done
exit $RETURN_CODE
@@ -149,6 +156,10 @@ exit $RETURN_CODE
%changelog
+* Tue Dec 8 2020 Remi Collet <remi@remirepo.net> - 3.1.0-1
+- update to 3.1.0
+- switch to phpunit9
+
* Mon Jun 8 2020 Remi Collet <remi@remirepo.net> - 3.0.2-1
- update to 3.0.2