summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-12-08 11:23:34 +0100
committerRemi Collet <remi@remirepo.net>2020-12-08 11:23:34 +0100
commit8308e69fef4cea2e8db182a80504037f4ce3346c (patch)
tree2178b77a02b61e2d72c562f61c311e4ad5c63637
parent969902c87e05d1102bf67b9fa96452611b0e9919 (diff)
update to 3.1.0
switch to phpunit9
-rw-r--r--composer.json15
-rw-r--r--php-doctrine-common3.spec23
2 files changed, 22 insertions, 16 deletions
diff --git a/composer.json b/composer.json
index 655bfaa..f1d7ad9 100644
--- a/composer.json
+++ b/composer.json
@@ -1,7 +1,7 @@
{
"name": "doctrine/common",
"type": "library",
- "description": "PHP Doctrine Common project is a library that provides additional functionality that other Doctrine projects depend on such as better reflection support, persistence interfaces, proxies, event system and much more.",
+ "description": "PHP Doctrine Common project is a library that provides additional functionality that other Doctrine projects depend on such as better reflection support, proxies and much more.",
"keywords": [
"php",
"common",
@@ -22,10 +22,10 @@
"doctrine/persistence": "^2.0"
},
"require-dev": {
- "phpstan/phpstan": "^0.11",
- "phpstan/phpstan-phpunit": "^0.11",
- "phpunit/phpunit": "^7.0",
- "doctrine/coding-standard": "^1.0",
+ "phpstan/phpstan": "^0.12",
+ "phpstan/phpstan-phpunit": "^0.12",
+ "phpunit/phpunit": "^7.5.20 || ^8.5 || ^9.0",
+ "doctrine/coding-standard": "^6.0 || ^8.0",
"squizlabs/php_codesniffer": "^3.0",
"symfony/phpunit-bridge": "^4.0.5"
},
@@ -38,10 +38,5 @@
"psr-4": {
"Doctrine\\Tests\\": "tests/Doctrine/Tests"
}
- },
- "extra": {
- "branch-alias": {
- "dev-master": "3.0.x-dev"
- }
}
}
diff --git a/php-doctrine-common3.spec b/php-doctrine-common3.spec
index fefa53b..fe38d66 100644
--- a/php-doctrine-common3.spec
+++ b/php-doctrine-common3.spec
@@ -10,8 +10,8 @@
%global github_owner doctrine
%global github_name common
-%global github_version 3.0.2
-%global github_commit a3c6479858989e242a2465972b4f7a8642baf0d4
+%global github_version 3.1.0
+%global github_commit 9f3e3f3cc5399604c0325d5ffa92609d694d950d
%global major 3
%global composer_vendor doctrine
@@ -59,7 +59,13 @@ BuildRequires: (php-composer(doctrine/persistence) >= %{doctrine_pers_min_ver} w
%else
BuildRequires: php-doctrine-persistence2
%endif
-BuildRequires: phpunit7
+%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.0
+%else
+%global phpunit %{_bindir}/phpunit8
+BuildRequires: phpunit8 >= 8.5
+%endif
## phpcompatinfo (computed from version 3.0.0)
BuildRequires: php-reflection
BuildRequires: php-date
@@ -127,9 +133,10 @@ sed "s#require.*autoload.*#require_once '%{buildroot}%{phpdir}/%{ns_vendor}/%{ns
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in "" php71 php72 php73 php74; do
- if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC %{_bindir}/phpunit7 --verbose || RETURN_CODE=1
+for CMDARG in "php %{phpunit}" "php71 %{_bindir}/phpunit7" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+ if which $CMDARG; then
+ set $CMDARG
+ $1 ${2:-%{_bindir}/phpunit9} --verbose || RETURN_CODE=1
fi
done
exit $RETURN_CODE
@@ -149,6 +156,10 @@ exit $RETURN_CODE
%changelog
+* Tue Dec 8 2020 Remi Collet <remi@remirepo.net> - 3.1.0-1
+- update to 3.1.0
+- switch to phpunit9
+
* Mon Jun 8 2020 Remi Collet <remi@remirepo.net> - 3.0.2-1
- update to 3.0.2