summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-08-11 10:23:53 +0200
committerRemi Collet <remi@remirepo.net>2020-08-11 10:23:53 +0200
commitae5cdcd6e5d67c8c2f4548cab3b103a753b75d09 (patch)
treeb81bcf5ab54c34396ebba2904521db51b5bc9d31
parent70d47199fcf2b68c4c1c65eb44d7b028a4625f48 (diff)
update to 1.0.2
switch to phpunit9 drop patch merged upstream
-rw-r--r--2.patch38
-rw-r--r--composer.json7
-rw-r--r--php-dasprid-enum.spec37
3 files changed, 28 insertions, 54 deletions
diff --git a/2.patch b/2.patch
deleted file mode 100644
index e1ce9df..0000000
--- a/2.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 8e0c46b7907925b59d6640f8e9c11cf4454eb4f7 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Tue, 10 Sep 2019 09:36:48 +0200
-Subject: [PATCH] Fix #1 add LICENSE file
-
----
- LICENSE | 22 ++++++++++++++++++++++
- 1 file changed, 22 insertions(+)
- create mode 100644 LICENSE
-
-diff --git a/LICENSE b/LICENSE
-new file mode 100644
-index 0000000..d45a356
---- /dev/null
-+++ b/LICENSE
-@@ -0,0 +1,22 @@
-+Copyright (c) 2017, Ben Scholzen 'DASPRiD'
-+All rights reserved.
-+
-+Redistribution and use in source and binary forms, with or without
-+modification, are permitted provided that the following conditions are met:
-+
-+1. Redistributions of source code must retain the above copyright notice, this
-+ list of conditions and the following disclaimer.
-+2. Redistributions in binary form must reproduce the above copyright notice,
-+ this list of conditions and the following disclaimer in the documentation
-+ and/or other materials provided with the distribution.
-+
-+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
-+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR
-+ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
-+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
-+LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
-+ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
-+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/composer.json b/composer.json
index 41184d3..b3d745a 100644
--- a/composer.json
+++ b/composer.json
@@ -5,8 +5,9 @@
"authors": [
{
"name": "Ben Scholzen 'DASPRiD'",
+ "email": "mail@dasprids.de",
"homepage": "https://dasprids.de/",
- "email": "mail@dasprids.de"
+ "role": "Developer"
}
],
"keywords": [
@@ -14,8 +15,8 @@
"map"
],
"require-dev": {
- "phpunit/phpunit": "^6.4",
- "squizlabs/php_codesniffer": "^3.1"
+ "phpunit/phpunit": "^7 | ^8 | ^9",
+ "squizlabs/php_codesniffer": "^3.4"
},
"autoload": {
"psr-4": {
diff --git a/php-dasprid-enum.spec b/php-dasprid-enum.spec
index 321a729..0cb059f 100644
--- a/php-dasprid-enum.spec
+++ b/php-dasprid-enum.spec
@@ -6,7 +6,9 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 631ef6e638e9494b0310837fa531bedd908fc22b
+%bcond_without tests
+
+%global gh_commit 6ccc0d7141a7f149e3c56cb0ce5f05d9152cfd07
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner DASPRiD
%global gh_project Enum
@@ -18,10 +20,9 @@
%global ns_project %{gh_project}
%global php_home %{_datadir}/php
%global major %nil
-%global with_tests 0%{!?_without_tests:1}
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 1.0.0
+Version: 1.0.2
Release: 1%{?dist}
Summary: PHP enum implementation
@@ -29,18 +30,23 @@ License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
-Patch0: https://patch-diff.githubusercontent.com/raw/DASPRiD/Enum/pull/2.patch
-
BuildArch: noarch
-%if %{with_tests}
+%if %{with tests}
# For tests
BuildRequires: php(language)
BuildRequires: php-reflection
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^6.4",
-# "squizlabs/php_codesniffer": "^3.1"
-BuildRequires: phpunit6 >= 6.4
+# "phpunit/phpunit": "^7 | ^8 | ^9",
+# "squizlabs/php_codesniffer": "^3.4"
+# remirepo:1
+%if 0%{?fedora} >= 32
+%global phpunit %{_bindir}/phpunit9
+# remirepo:3
+%else
+%global phpunit %{_bindir}/phpunit8
+%endif
+BuildRequires: %{phpunit}
# Required by autoloader
BuildRequires: php-composer(fedora/autoloader)
%endif
@@ -69,7 +75,6 @@ Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
cat << 'EOF' | tee src/autoload.php
<?php
@@ -90,7 +95,7 @@ cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}
%check
-%if %{with_tests}
+%if %{with tests}
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
@@ -99,9 +104,10 @@ require '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
EOF
ret=0
-for cmd in php php71 php72 php73 php74; do
+for cmd in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
if which $cmd; then
- $cmd %{_bindir}/phpunit6 --verbose || ret=1
+ set $cmd
+ $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
fi
done
exit $ret
@@ -120,6 +126,11 @@ exit $ret
%changelog
+* Tue Aug 11 2020 Remi Collet <remi@remirepo.net> - 1.0.2-1
+- update to 1.0.2
+- switch to phpunit9
+- drop patch merged upstream
+
* Thu Oct 19 2017 Remi Collet <remi@remirepo.net> - 1.0.0-1
- initial package, version 1.0.0
- add license file from