summaryrefslogtreecommitdiffstats
path: root/php-dasprid-enum.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-dasprid-enum.spec')
-rw-r--r--php-dasprid-enum.spec37
1 files changed, 24 insertions, 13 deletions
diff --git a/php-dasprid-enum.spec b/php-dasprid-enum.spec
index 321a729..0cb059f 100644
--- a/php-dasprid-enum.spec
+++ b/php-dasprid-enum.spec
@@ -6,7 +6,9 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 631ef6e638e9494b0310837fa531bedd908fc22b
+%bcond_without tests
+
+%global gh_commit 6ccc0d7141a7f149e3c56cb0ce5f05d9152cfd07
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner DASPRiD
%global gh_project Enum
@@ -18,10 +20,9 @@
%global ns_project %{gh_project}
%global php_home %{_datadir}/php
%global major %nil
-%global with_tests 0%{!?_without_tests:1}
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 1.0.0
+Version: 1.0.2
Release: 1%{?dist}
Summary: PHP enum implementation
@@ -29,18 +30,23 @@ License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
-Patch0: https://patch-diff.githubusercontent.com/raw/DASPRiD/Enum/pull/2.patch
-
BuildArch: noarch
-%if %{with_tests}
+%if %{with tests}
# For tests
BuildRequires: php(language)
BuildRequires: php-reflection
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^6.4",
-# "squizlabs/php_codesniffer": "^3.1"
-BuildRequires: phpunit6 >= 6.4
+# "phpunit/phpunit": "^7 | ^8 | ^9",
+# "squizlabs/php_codesniffer": "^3.4"
+# remirepo:1
+%if 0%{?fedora} >= 32
+%global phpunit %{_bindir}/phpunit9
+# remirepo:3
+%else
+%global phpunit %{_bindir}/phpunit8
+%endif
+BuildRequires: %{phpunit}
# Required by autoloader
BuildRequires: php-composer(fedora/autoloader)
%endif
@@ -69,7 +75,6 @@ Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
cat << 'EOF' | tee src/autoload.php
<?php
@@ -90,7 +95,7 @@ cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}
%check
-%if %{with_tests}
+%if %{with tests}
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
@@ -99,9 +104,10 @@ require '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
EOF
ret=0
-for cmd in php php71 php72 php73 php74; do
+for cmd in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
if which $cmd; then
- $cmd %{_bindir}/phpunit6 --verbose || ret=1
+ set $cmd
+ $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
fi
done
exit $ret
@@ -120,6 +126,11 @@ exit $ret
%changelog
+* Tue Aug 11 2020 Remi Collet <remi@remirepo.net> - 1.0.2-1
+- update to 1.0.2
+- switch to phpunit9
+- drop patch merged upstream
+
* Thu Oct 19 2017 Remi Collet <remi@remirepo.net> - 1.0.0-1
- initial package, version 1.0.0
- add license file from