summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-05-31 07:55:06 +0200
committerRemi Collet <fedora@famillecollet.com>2015-05-31 07:55:06 +0200
commit37f58c7ded15f2e266d62ad127cd65a11e614151 (patch)
tree1cfaf39156e44b105c579ae5c2605476846f16da /Makefile
parent865037f9632dfd8a0001fb3c8a2bb7ba8be3e97a (diff)
php-d11wtq-boris: backport stuffHEADmaster
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed