summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-05-31 07:55:06 +0200
committerRemi Collet <fedora@famillecollet.com>2015-05-31 07:55:06 +0200
commit37f58c7ded15f2e266d62ad127cd65a11e614151 (patch)
tree1cfaf39156e44b105c579ae5c2605476846f16da
parent865037f9632dfd8a0001fb3c8a2bb7ba8be3e97a (diff)
php-d11wtq-boris: backport stuffHEADmaster
-rw-r--r--Makefile10
-rw-r--r--php-d11wtq-boris.spec12
2 files changed, 22 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed
diff --git a/php-d11wtq-boris.spec b/php-d11wtq-boris.spec
index db63931..65892fd 100644
--- a/php-d11wtq-boris.spec
+++ b/php-d11wtq-boris.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-d11wtq-boris, from Fedora:
#
# RPM spec file for php-d11wtq-boris
#
@@ -33,6 +34,7 @@ URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
BuildArch: noarch
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
# Autoload generation
BuildRequires: %{_bindir}/phpab
@@ -81,6 +83,8 @@ rm -f lib/autoload.php
%install
+rm -rf %{buildroot}
+
: Lib
mkdir -p %{buildroot}%{phpdir}
cp -pr lib/* %{buildroot}%{phpdir}/
@@ -94,7 +98,12 @@ install -pm 0755 bin/boris %{buildroot}%{_bindir}/
: No upstream tests
+%clean
+rm -rf %{buildroot}
+
+
%files
+%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -104,6 +113,9 @@ install -pm 0755 bin/boris %{buildroot}%{_bindir}/
%changelog
+* Sun May 31 2015 Remi Collet <remi@remirepo.net> - 1.0.10-2
+- backport in remi repository
+
* Sat May 30 2015 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.0.10-2
- php(language) => php-cli dependency change