summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-09-28 10:38:47 +0200
committerRemi Collet <fedora@famillecollet.com>2016-09-28 10:38:47 +0200
commit7d608ffab18faa6843617dea9f978ad460a820a7 (patch)
tree115a876f73045634af7af1d039086e45c35bdcc8
parent9d1aa24d000dea4b7e5003ebf8a6d7e5d5e11b10 (diff)
php-composer-spdx-licenses: 1.1.5
-rwxr-xr-xmakesrc.sh2
-rw-r--r--php-composer-spdx-licenses.spec31
2 files changed, 25 insertions, 8 deletions
diff --git a/makesrc.sh b/makesrc.sh
index bde65fc..c047df5 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -15,7 +15,7 @@ git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
echo "Getting commit..."
pushd $PROJECT-$COMMIT
git checkout $COMMIT
-cp composer.json ../composer-$VERSION.json
+cp composer.json ../composer.json
popd
echo "Archiving..."
diff --git a/php-composer-spdx-licenses.spec b/php-composer-spdx-licenses.spec
index 2a851c2..d1ad324 100644
--- a/php-composer-spdx-licenses.spec
+++ b/php-composer-spdx-licenses.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 88c26372b1afac36d8db601cdf04ad8716f53d88
+%global gh_commit 96c6a07b05b716e89a44529d060bc7f5c263cb13
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner composer
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-composer-spdx-licenses
-Version: 1.1.4
+Version: 1.1.5
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: SPDX licenses list and validation library
@@ -98,15 +98,29 @@ cp -pr res %{buildroot}%{_datadir}/%{name}
%check
%if %{with_tests}
export BUILDROOT_SPDX=%{buildroot}
-%{_bindir}/phpunit \
- --bootstrap %{buildroot}%{php_home}/Composer/Spdx/autoload.php \
- --verbose
-if which php70; then
- php70 %{_bindir}/phpunit \
+# remirepo:15
+run=0
+ret=0
+if which php56; then
+ php56 %{_bindir}/phpunit \
+ --bootstrap %{buildroot}%{php_home}/Composer/Spdx/autoload.php \
+ --verbose
+ run=1
+fi
+if which php71; then
+ php71 %{_bindir}/phpunit \
+ --bootstrap %{buildroot}%{php_home}/Composer/Spdx/autoload.php \
+ --verbose
+ run=1
+fi
+if [ $run -eq 0 ]; then
+%{_bindir}/phpunit \
--bootstrap %{buildroot}%{php_home}/Composer/Spdx/autoload.php \
--verbose
+# remirepo:2
fi
+exit $ret
%else
: Test suite disabled
%endif
@@ -128,6 +142,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Sep 28 2016 Remi Collet <remi@fedoraproject.org> - 1.1.5-1
+- version 1.1.5 (new licenses)
+
* Wed May 4 2016 Remi Collet <remi@fedoraproject.org> - 1.1.4-1
- version 1.1.4 (new licenses)