summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-05-04 18:04:37 +0200
committerRemi Collet <fedora@famillecollet.com>2016-05-04 18:04:37 +0200
commit9d1aa24d000dea4b7e5003ebf8a6d7e5d5e11b10 (patch)
tree6971665bae82e69da0980606611353c2f26c0fad
parentf59f6bb8028f7c57e6723e156a0f46a211cf688a (diff)
php-composer-spdx-licenses: 1.1.4
-rw-r--r--composer.json57
-rw-r--r--php-composer-spdx-licenses.spec7
2 files changed, 62 insertions, 2 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..2b5fed6
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,57 @@
+{
+ "name": "composer/spdx-licenses",
+ "description": "SPDX licenses list and validation library.",
+ "type": "library",
+ "license": "MIT",
+ "keywords": [
+ "spdx",
+ "license",
+ "validator"
+ ],
+ "authors": [
+ {
+ "name": "Nils Adermann",
+ "email": "naderman@naderman.de",
+ "homepage": "http://www.naderman.de"
+ },
+ {
+ "name": "Jordi Boggiano",
+ "email": "j.boggiano@seld.be",
+ "homepage": "http://seld.be"
+ },
+ {
+ "name": "Rob Bast",
+ "email": "rob.bast@gmail.com",
+ "homepage": "http://robbast.nl"
+ }
+ ],
+ "support": {
+ "irc": "irc://irc.freenode.org/composer",
+ "issues": "https://github.com/composer/spdx-licenses/issues"
+ },
+ "require": {
+ "php": "^5.3.2 || ^7.0"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^4.5 || ^5.0.5",
+ "phpunit/phpunit-mock-objects": "2.3.0 || ^3.0"
+ },
+ "autoload": {
+ "psr-4": {
+ "Composer\\Spdx\\": "src"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "Composer\\Spdx\\": "tests"
+ }
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.x-dev"
+ }
+ },
+ "scripts": {
+ "test": "phpunit"
+ }
+}
diff --git a/php-composer-spdx-licenses.spec b/php-composer-spdx-licenses.spec
index 3e5c201..2a851c2 100644
--- a/php-composer-spdx-licenses.spec
+++ b/php-composer-spdx-licenses.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 547659c3cacd3ccfe1b4714c2ff88cafc6b6793b
+%global gh_commit 88c26372b1afac36d8db601cdf04ad8716f53d88
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150717
%global gh_owner composer
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-composer-spdx-licenses
-Version: 1.1.3
+Version: 1.1.4
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: SPDX licenses list and validation library
@@ -128,6 +128,9 @@ rm -rf %{buildroot}
%changelog
+* Wed May 4 2016 Remi Collet <remi@fedoraproject.org> - 1.1.4-1
+- version 1.1.4 (new licenses)
+
* Fri Mar 25 2016 Remi Collet <remi@fedoraproject.org> - 1.1.3-1
- version 1.1.3 (new licenses)
- run test suite with both PHP 5 and 7 when available