summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-06-10 07:30:05 +0200
committerRemi Collet <fedora@famillecollet.com>2012-06-10 07:30:05 +0200
commite24ca0ddf6e608cb4ed2e5e313f46f2a486a6f49 (patch)
treedabcbb2119642fc7c7bb209440902c2516f977a7
php-channel-twig: import from rawhide
-rw-r--r--Makefile4
-rw-r--r--channel.xml16
-rw-r--r--php-channel-twig.spec73
3 files changed, 93 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/channel.xml b/channel.xml
new file mode 100644
index 0000000..31681a3
--- /dev/null
+++ b/channel.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<channel version="1.0" xmlns="http://pear.php.net/channel-1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://pear.php.net/channel-1.0 http://pear.php.net/dtd/channel-1.0.xsd">
+ <name>pear.twig-project.org</name>
+ <summary>Twig PEAR channel</summary>
+ <suggestedalias>twig</suggestedalias>
+ <servers>
+ <primary>
+ <rest>
+ <baseurl type="REST1.0">http://pear.twig-project.org/rest/</baseurl>
+ <baseurl type="REST1.1">http://pear.twig-project.org/rest/</baseurl>
+ <baseurl type="REST1.2">http://pear.twig-project.org/rest/</baseurl>
+ <baseurl type="REST1.3">http://pear.twig-project.org/rest/</baseurl>
+ </rest>
+ </primary>
+ </servers>
+</channel> \ No newline at end of file
diff --git a/php-channel-twig.spec b/php-channel-twig.spec
new file mode 100644
index 0000000..797dc4c
--- /dev/null
+++ b/php-channel-twig.spec
@@ -0,0 +1,73 @@
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_channel pear.twig-project.org
+
+Name: php-channel-twig
+Version: 1.0
+Release: 3%{?dist}
+Summary: Adds %{pear_channel} channel to PEAR
+
+Group: Development/Libraries
+License: Public Domain
+URL: http://%{pear_channel}
+Source0: http://%{pear_channel}/channel.xml
+
+BuildArch: noarch
+BuildRequires: php-pear(PEAR)
+
+Requires: php-pear(PEAR)
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+
+Provides: php-channel(%{pear_channel}) = %{version}
+
+%description
+This package adds the %{pear_channel} channel which allows PEAR packages
+from this channel to be installed.
+
+
+%prep
+%setup -q -c -T
+
+
+%build
+# Empty build section, nothing to build
+
+
+%install
+mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
+install -pm 644 %{SOURCE0} $RPM_BUILD_ROOT%{pear_xmldir}/%{name}.xml
+
+
+%post
+if [ $1 -eq 1 ] ; then
+ %{__pear} channel-add %{pear_xmldir}/%{name}.xml > /dev/null || :
+else
+ %{__pear} channel-update %{pear_xmldir}/%{name}.xml > /dev/null || :
+fi
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} channel-delete %{pear_channel} > /dev/null || :
+fi
+
+
+%files
+%{pear_xmldir}/%{name}.xml
+
+
+%changelog
+* Sat Jun 9 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 1.0-3
+- Changed license from BSD to Public Domain
+- Removed "BuildRequires: php-pear >= 1:1.4.9-1.2"
+- Removed cleaning buildroot from %%install section
+- Removed %%clean section
+
+* Sun May 20 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 1.0-2
+- %%global instead of %%define
+- Removed BuildRoot
+- Removed %%defattr from %%files section
+- Minor syntax update in %%post section
+
+* Fri Apr 27 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 1.0-1
+- Initial package