summaryrefslogtreecommitdiffstats
path: root/php-channel-twig.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-channel-twig.spec')
-rw-r--r--php-channel-twig.spec73
1 files changed, 73 insertions, 0 deletions
diff --git a/php-channel-twig.spec b/php-channel-twig.spec
new file mode 100644
index 0000000..797dc4c
--- /dev/null
+++ b/php-channel-twig.spec
@@ -0,0 +1,73 @@
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_channel pear.twig-project.org
+
+Name: php-channel-twig
+Version: 1.0
+Release: 3%{?dist}
+Summary: Adds %{pear_channel} channel to PEAR
+
+Group: Development/Libraries
+License: Public Domain
+URL: http://%{pear_channel}
+Source0: http://%{pear_channel}/channel.xml
+
+BuildArch: noarch
+BuildRequires: php-pear(PEAR)
+
+Requires: php-pear(PEAR)
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+
+Provides: php-channel(%{pear_channel}) = %{version}
+
+%description
+This package adds the %{pear_channel} channel which allows PEAR packages
+from this channel to be installed.
+
+
+%prep
+%setup -q -c -T
+
+
+%build
+# Empty build section, nothing to build
+
+
+%install
+mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
+install -pm 644 %{SOURCE0} $RPM_BUILD_ROOT%{pear_xmldir}/%{name}.xml
+
+
+%post
+if [ $1 -eq 1 ] ; then
+ %{__pear} channel-add %{pear_xmldir}/%{name}.xml > /dev/null || :
+else
+ %{__pear} channel-update %{pear_xmldir}/%{name}.xml > /dev/null || :
+fi
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} channel-delete %{pear_channel} > /dev/null || :
+fi
+
+
+%files
+%{pear_xmldir}/%{name}.xml
+
+
+%changelog
+* Sat Jun 9 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 1.0-3
+- Changed license from BSD to Public Domain
+- Removed "BuildRequires: php-pear >= 1:1.4.9-1.2"
+- Removed cleaning buildroot from %%install section
+- Removed %%clean section
+
+* Sun May 20 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 1.0-2
+- %%global instead of %%define
+- Removed BuildRoot
+- Removed %%defattr from %%files section
+- Minor syntax update in %%post section
+
+* Fri Apr 27 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 1.0-1
+- Initial package