summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-09-23 06:33:09 +0200
committerRemi Collet <fedora@famillecollet.com>2016-09-23 06:33:09 +0200
commitdfd093d99c6a5817239a45ea6e34bcfcdf398317 (patch)
tree27012ab25061a01a0c35218d22a1a4cff7b8b5e4
parent11ce67f6cfab8a2af82f6d39c128777fae0f5123 (diff)
php-bartlett-PHP-Reflect: 4.0.2
-rw-r--r--php-bartlett-PHP-Reflect-4.0.0-rpm.patch11
-rw-r--r--php-bartlett-PHP-Reflect-pr22.patch35
-rw-r--r--php-bartlett-PHP-Reflect.spec16
3 files changed, 8 insertions, 54 deletions
diff --git a/php-bartlett-PHP-Reflect-4.0.0-rpm.patch b/php-bartlett-PHP-Reflect-4.0.0-rpm.patch
index 16f5985..dac0ea6 100644
--- a/php-bartlett-PHP-Reflect-4.0.0-rpm.patch
+++ b/php-bartlett-PHP-Reflect-4.0.0-rpm.patch
@@ -131,14 +131,3 @@ diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
+foreach ($tab as $class => $file) {
+ require_once $file;
+}
-diff -up ./tests/Environment/YourLogger.php.rpm ./tests/Environment/YourLogger.php
---- ./tests/Environment/YourLogger.php.rpm 2015-06-18 13:30:46.000000000 +0200
-+++ ./tests/Environment/YourLogger.php 2015-06-26 09:18:15.578663966 +0200
-@@ -14,6 +14,7 @@ class YourLogger extends Logger
- if (!file_exists($tempDir)) {
- mkdir($tempDir, 0755, true);
- }
-+ date_default_timezone_set('UTC');
- $filename = sprintf('phpreflect-%s.log', date('Ymd'));
-
- $stream = new RotatingFileHandler("$tempDir/$filename", 30);
diff --git a/php-bartlett-PHP-Reflect-pr22.patch b/php-bartlett-PHP-Reflect-pr22.patch
deleted file mode 100644
index f9cb205..0000000
--- a/php-bartlett-PHP-Reflect-pr22.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 8587a88808ee913974f0c9bbf7353db767259f28 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Wed, 6 Jul 2016 16:37:55 +0200
-Subject: [PATCH] fix for monolog 1.20
-
----
- tests/Environment/YourLogger.php | 2 +-
- tests/EnvironmentTest.php | 1 -
- 2 files changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/tests/Environment/YourLogger.php b/tests/Environment/YourLogger.php
-index 2e5242d..2a06aed 100644
---- a/tests/Environment/YourLogger.php
-+++ b/tests/Environment/YourLogger.php
-@@ -17,7 +17,7 @@ public function __construct($name = 'DEV')
- $filename = sprintf('phpreflect-%s.log', date('Ymd'));
-
- $stream = new RotatingFileHandler("$tempDir/$filename", 30);
-- $stream->setFilenameFormat('{filename}-{date}', 'Ymd');
-+ $stream->setFilenameFormat('{filename}-{date}', 'Y-m-d');
-
- $handlers = array($stream);
-
-diff --git a/tests/EnvironmentTest.php b/tests/EnvironmentTest.php
-index be8f0a4..86b1809 100644
---- a/tests/EnvironmentTest.php
-+++ b/tests/EnvironmentTest.php
-@@ -188,7 +188,6 @@ public function testDefaultLoggerAccessor()
- /**
- * @covers Bartlett\Reflect\Environment::getLogger
- * @runInSeparateProcess
-- * @expectedException PHPUnit_Framework_Error_Deprecated
- *
- * @return void
- */
diff --git a/php-bartlett-PHP-Reflect.spec b/php-bartlett-PHP-Reflect.spec
index 996adee..5b96e48 100644
--- a/php-bartlett-PHP-Reflect.spec
+++ b/php-bartlett-PHP-Reflect.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 73eac11e5bd3b161745ad5d6bef6af73458010f6
+%global gh_commit 7aaf1f43760aff4b97c679c46dd8b6700c948ff5
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20150331
%global gh_owner llaville
@@ -20,8 +20,8 @@
%endif
Name: php-bartlett-PHP-Reflect
-Version: 4.0.1
-%global specrel 2
+Version: 4.0.2
+%global specrel 1
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Adds the ability to reverse-engineer PHP
@@ -35,8 +35,6 @@ Source1: %{name}-autoload.php
# Enable cache plugin
Patch0: %{name}-4.0.0-rpm.patch
-# See https://github.com/llaville/php-reflect/pull/22
-Patch1: %{name}-pr22.patch
BuildArch: noarch
BuildRequires: php(language) >= 5.4.0
@@ -158,7 +156,6 @@ Documentation: http://php5.laurent-laville.org/reflect/manual/current/en/
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p1 -b .rpm
-%patch1 -p1 -b .pr22
cp %{SOURCE1} src/Bartlett/Reflect/autoload.php
sed -e 's/@package_version@/%{version}%{?prever}/' \
@@ -180,8 +177,8 @@ install -D -p -m 644 bin/phpreflect.1 %{buildroot}%{_mandir}/man1/phpref
%check
%if %{with_tests}
-# Version 4.0.1: OK, but incomplete, skipped, or risky tests!
-# Tests: 122, Assertions: 122, Incomplete: 3.
+# Version 4.0.2: OK, but incomplete, skipped, or risky tests!
+# Tests: 122, Assertions: 123, Incomplete: 3.
# remirepo:11
run=0
ret=0
@@ -223,6 +220,9 @@ fi
%changelog
+* Fri Sep 23 2016 Remi Collet <remi@fedoraproject.org> - 4.0.2-1
+- update to 4.0.2
+
* Wed Aug 10 2016 Remi Collet <remi@fedoraproject.org> - 4.0.1-2
- fix test suite to work with all Monolog versions
from https://github.com/llaville/php-reflect/pull/22