summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-08-10 11:04:31 +0200
committerRemi Collet <fedora@famillecollet.com>2016-08-10 11:04:31 +0200
commit11ce67f6cfab8a2af82f6d39c128777fae0f5123 (patch)
treec8530db661339147cba59069ae2eff0f10fd16b2
parentff57ea19e0f8841fec3826ed88f570ea8ad0a7a2 (diff)
php-bartlett-PHP-Reflect: fix test
-rw-r--r--php-bartlett-PHP-Reflect-pr22.patch35
-rw-r--r--php-bartlett-PHP-Reflect.spec9
2 files changed, 43 insertions, 1 deletions
diff --git a/php-bartlett-PHP-Reflect-pr22.patch b/php-bartlett-PHP-Reflect-pr22.patch
new file mode 100644
index 0000000..f9cb205
--- /dev/null
+++ b/php-bartlett-PHP-Reflect-pr22.patch
@@ -0,0 +1,35 @@
+From 8587a88808ee913974f0c9bbf7353db767259f28 Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Wed, 6 Jul 2016 16:37:55 +0200
+Subject: [PATCH] fix for monolog 1.20
+
+---
+ tests/Environment/YourLogger.php | 2 +-
+ tests/EnvironmentTest.php | 1 -
+ 2 files changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/tests/Environment/YourLogger.php b/tests/Environment/YourLogger.php
+index 2e5242d..2a06aed 100644
+--- a/tests/Environment/YourLogger.php
++++ b/tests/Environment/YourLogger.php
+@@ -17,7 +17,7 @@ public function __construct($name = 'DEV')
+ $filename = sprintf('phpreflect-%s.log', date('Ymd'));
+
+ $stream = new RotatingFileHandler("$tempDir/$filename", 30);
+- $stream->setFilenameFormat('{filename}-{date}', 'Ymd');
++ $stream->setFilenameFormat('{filename}-{date}', 'Y-m-d');
+
+ $handlers = array($stream);
+
+diff --git a/tests/EnvironmentTest.php b/tests/EnvironmentTest.php
+index be8f0a4..86b1809 100644
+--- a/tests/EnvironmentTest.php
++++ b/tests/EnvironmentTest.php
+@@ -188,7 +188,6 @@ public function testDefaultLoggerAccessor()
+ /**
+ * @covers Bartlett\Reflect\Environment::getLogger
+ * @runInSeparateProcess
+- * @expectedException PHPUnit_Framework_Error_Deprecated
+ *
+ * @return void
+ */
diff --git a/php-bartlett-PHP-Reflect.spec b/php-bartlett-PHP-Reflect.spec
index 842ee0b..996adee 100644
--- a/php-bartlett-PHP-Reflect.spec
+++ b/php-bartlett-PHP-Reflect.spec
@@ -21,7 +21,7 @@
Name: php-bartlett-PHP-Reflect
Version: 4.0.1
-%global specrel 1
+%global specrel 2
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Adds the ability to reverse-engineer PHP
@@ -35,6 +35,8 @@ Source1: %{name}-autoload.php
# Enable cache plugin
Patch0: %{name}-4.0.0-rpm.patch
+# See https://github.com/llaville/php-reflect/pull/22
+Patch1: %{name}-pr22.patch
BuildArch: noarch
BuildRequires: php(language) >= 5.4.0
@@ -156,6 +158,7 @@ Documentation: http://php5.laurent-laville.org/reflect/manual/current/en/
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p1 -b .rpm
+%patch1 -p1 -b .pr22
cp %{SOURCE1} src/Bartlett/Reflect/autoload.php
sed -e 's/@package_version@/%{version}%{?prever}/' \
@@ -220,6 +223,10 @@ fi
%changelog
+* Wed Aug 10 2016 Remi Collet <remi@fedoraproject.org> - 4.0.1-2
+- fix test suite to work with all Monolog versions
+ from https://github.com/llaville/php-reflect/pull/22
+
* Wed Jul 6 2016 Remi Collet <remi@fedoraproject.org> - 4.0.1-1
- update to 4.0.1
- rewrite autoloader