summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-01-02 07:27:32 +0100
committerRemi Collet <remi@php.net>2024-01-02 07:27:32 +0100
commit18e549e49bfe517efcb32b52c316036177eea20e (patch)
tree3edb36fc2ef48bb444aba47241500fa527853c14
parent432e938ddef359226205dfb92b3119b26d7a55fc (diff)
update to 7.1.0
-rw-r--r--composer.json20
-rw-r--r--installed.json140
-rw-r--r--php-bartlett-PHP-CompatInfo-7.0.0-php83.patch57
-rw-r--r--php-bartlett-PHP-CompatInfo.spec30
4 files changed, 95 insertions, 152 deletions
diff --git a/composer.json b/composer.json
index fb31fc4..bbc89e5 100644
--- a/composer.json
+++ b/composer.json
@@ -10,7 +10,7 @@
"issues": "https://github.com/llaville/php-compatinfo/issues"
},
"require": {
- "php": "~8.0 || ~8.1 || ~8.2",
+ "php": "~8.0 || ~8.1 || ~8.2 || ~8.3",
"ext-json": "*",
"ext-pcre": "*",
"ext-spl": "*",
@@ -21,16 +21,16 @@
"nikic/php-parser": "^4.10",
"psr/log": "^3.0",
"ramsey/uuid": "^3.9 || ^4.0",
- "symfony/config": "^5.4 || ^6.0",
- "symfony/console": "^5.4 || ^6.0",
- "symfony/event-dispatcher": "^5.4 || ^6.0",
- "symfony/finder": "^5.4 || ^6.0",
- "symfony/dependency-injection": "^5.4 || ^6.0",
- "symfony/serializer": "^5.4 || ^6.0",
- "symfony/stopwatch": "^5.4 || ^6.0"
+ "symfony/config": "^5.4 || ^6.0 || ^7.0",
+ "symfony/console": "^5.4 || ^6.0 || ^7.0",
+ "symfony/event-dispatcher": "^5.4 || ^6.0 || ^7.0",
+ "symfony/finder": "^5.4 || ^6.0 || ^7.0",
+ "symfony/dependency-injection": "^5.4 || ^6.0 || ^7.0",
+ "symfony/serializer": "^5.4 || ^6.0 || ^7.0",
+ "symfony/stopwatch": "^5.4 || ^6.0 || ^7.0"
},
"require-dev": {
- "symfony/framework-bundle": "^5.4 || ^6.0",
+ "symfony/framework-bundle": "^5.4 || ^6.0 || ^7.0",
"bamarni/composer-bin-plugin": "^1.8"
},
"authors": [
@@ -68,7 +68,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "7.0.x-dev"
+ "dev-master": "7.1.x-dev"
},
"bamarni-bin": {
"bin-links": true,
diff --git a/installed.json b/installed.json
index bffce70..003ae08 100644
--- a/installed.json
+++ b/installed.json
@@ -1774,17 +1774,17 @@
},
{
"name": "symfony/cache",
- "version": "v6.4.0",
- "version_normalized": "6.4.0.0",
+ "version": "v6.4.2",
+ "version_normalized": "6.4.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/cache.git",
- "reference": "ac2d25f97b17eec6e19760b6b9962a4f7c44356a"
+ "reference": "14a75869bbb41cb35bc5d9d322473928c6f3f978"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/cache/zipball/ac2d25f97b17eec6e19760b6b9962a4f7c44356a",
- "reference": "ac2d25f97b17eec6e19760b6b9962a4f7c44356a",
+ "url": "https://api.github.com/repos/symfony/cache/zipball/14a75869bbb41cb35bc5d9d322473928c6f3f978",
+ "reference": "14a75869bbb41cb35bc5d9d322473928c6f3f978",
"shasum": ""
},
"require": {
@@ -1818,7 +1818,7 @@
"symfony/messenger": "^5.4|^6.0|^7.0",
"symfony/var-dumper": "^5.4|^6.0|^7.0"
},
- "time": "2023-11-24T19:28:07+00:00",
+ "time": "2023-12-29T15:34:34+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1853,7 +1853,7 @@
"psr6"
],
"support": {
- "source": "https://github.com/symfony/cache/tree/v6.4.0"
+ "source": "https://github.com/symfony/cache/tree/v6.4.2"
},
"funding": [
{
@@ -1952,17 +1952,17 @@
},
{
"name": "symfony/clock",
- "version": "v6.4.0",
- "version_normalized": "6.4.0.0",
+ "version": "v6.4.2",
+ "version_normalized": "6.4.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/clock.git",
- "reference": "48102bcc56b26d453c7f5e7f72829abc9df25a16"
+ "reference": "0639710e65f73cc504167958ea29be6de5c7177a"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/clock/zipball/48102bcc56b26d453c7f5e7f72829abc9df25a16",
- "reference": "48102bcc56b26d453c7f5e7f72829abc9df25a16",
+ "url": "https://api.github.com/repos/symfony/clock/zipball/0639710e65f73cc504167958ea29be6de5c7177a",
+ "reference": "0639710e65f73cc504167958ea29be6de5c7177a",
"shasum": ""
},
"require": {
@@ -1973,7 +1973,7 @@
"provide": {
"psr/clock-implementation": "1.0"
},
- "time": "2023-10-13T14:46:14+00:00",
+ "time": "2023-12-27T00:32:33+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2009,7 +2009,7 @@
"time"
],
"support": {
- "source": "https://github.com/symfony/clock/tree/v6.4.0"
+ "source": "https://github.com/symfony/clock/tree/v6.4.2"
},
"funding": [
{
@@ -2107,17 +2107,17 @@
},
{
"name": "symfony/console",
- "version": "v6.4.1",
- "version_normalized": "6.4.1.0",
+ "version": "v6.4.2",
+ "version_normalized": "6.4.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "a550a7c99daeedef3f9d23fb82e3531525ff11fd"
+ "reference": "0254811a143e6bc6c8deea08b589a7e68a37f625"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/a550a7c99daeedef3f9d23fb82e3531525ff11fd",
- "reference": "a550a7c99daeedef3f9d23fb82e3531525ff11fd",
+ "url": "https://api.github.com/repos/symfony/console/zipball/0254811a143e6bc6c8deea08b589a7e68a37f625",
+ "reference": "0254811a143e6bc6c8deea08b589a7e68a37f625",
"shasum": ""
},
"require": {
@@ -2150,7 +2150,7 @@
"symfony/stopwatch": "^5.4|^6.0|^7.0",
"symfony/var-dumper": "^5.4|^6.0|^7.0"
},
- "time": "2023-11-30T10:54:28+00:00",
+ "time": "2023-12-10T16:15:48+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2184,7 +2184,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v6.4.1"
+ "source": "https://github.com/symfony/console/tree/v6.4.2"
},
"funding": [
{
@@ -2204,17 +2204,17 @@
},
{
"name": "symfony/dependency-injection",
- "version": "v6.4.1",
- "version_normalized": "6.4.1.0",
+ "version": "v6.4.2",
+ "version_normalized": "6.4.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/dependency-injection.git",
- "reference": "f88ff6428afbeb17cc648c8003bd608534750baf"
+ "reference": "226ea431b1eda6f0d9f5a4b278757171960bb195"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/dependency-injection/zipball/f88ff6428afbeb17cc648c8003bd608534750baf",
- "reference": "f88ff6428afbeb17cc648c8003bd608534750baf",
+ "url": "https://api.github.com/repos/symfony/dependency-injection/zipball/226ea431b1eda6f0d9f5a4b278757171960bb195",
+ "reference": "226ea431b1eda6f0d9f5a4b278757171960bb195",
"shasum": ""
},
"require": {
@@ -2240,7 +2240,7 @@
"symfony/expression-language": "^5.4|^6.0|^7.0",
"symfony/yaml": "^5.4|^6.0|^7.0"
},
- "time": "2023-12-01T14:56:37+00:00",
+ "time": "2023-12-28T19:16:56+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2268,7 +2268,7 @@
"description": "Allows you to standardize and centralize the way objects are constructed in your application",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/dependency-injection/tree/v6.4.1"
+ "source": "https://github.com/symfony/dependency-injection/tree/v6.4.2"
},
"funding": [
{
@@ -2358,17 +2358,17 @@
},
{
"name": "symfony/event-dispatcher",
- "version": "v6.4.0",
- "version_normalized": "6.4.0.0",
+ "version": "v6.4.2",
+ "version_normalized": "6.4.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/event-dispatcher.git",
- "reference": "d76d2632cfc2206eecb5ad2b26cd5934082941b6"
+ "reference": "e95216850555cd55e71b857eb9d6c2674124603a"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/event-dispatcher/zipball/d76d2632cfc2206eecb5ad2b26cd5934082941b6",
- "reference": "d76d2632cfc2206eecb5ad2b26cd5934082941b6",
+ "url": "https://api.github.com/repos/symfony/event-dispatcher/zipball/e95216850555cd55e71b857eb9d6c2674124603a",
+ "reference": "e95216850555cd55e71b857eb9d6c2674124603a",
"shasum": ""
},
"require": {
@@ -2393,7 +2393,7 @@
"symfony/service-contracts": "^2.5|^3",
"symfony/stopwatch": "^5.4|^6.0|^7.0"
},
- "time": "2023-07-27T06:52:43+00:00",
+ "time": "2023-12-27T22:16:42+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2421,7 +2421,7 @@
"description": "Provides tools that allow your application components to communicate with each other by dispatching events and listening to them",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/event-dispatcher/tree/v6.4.0"
+ "source": "https://github.com/symfony/event-dispatcher/tree/v6.4.2"
},
"funding": [
{
@@ -2653,17 +2653,17 @@
},
{
"name": "symfony/http-client",
- "version": "v6.4.0",
- "version_normalized": "6.4.0.0",
+ "version": "v6.4.2",
+ "version_normalized": "6.4.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/http-client.git",
- "reference": "5c584530b77aa10ae216989ffc48b4bedc9c0b29"
+ "reference": "fc0944665bd932cf32a7b8a1d009466afc16528f"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/http-client/zipball/5c584530b77aa10ae216989ffc48b4bedc9c0b29",
- "reference": "5c584530b77aa10ae216989ffc48b4bedc9c0b29",
+ "url": "https://api.github.com/repos/symfony/http-client/zipball/fc0944665bd932cf32a7b8a1d009466afc16528f",
+ "reference": "fc0944665bd932cf32a7b8a1d009466afc16528f",
"shasum": ""
},
"require": {
@@ -2698,7 +2698,7 @@
"symfony/process": "^5.4|^6.0|^7.0",
"symfony/stopwatch": "^5.4|^6.0|^7.0"
},
- "time": "2023-11-28T20:55:58+00:00",
+ "time": "2023-12-02T12:49:56+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2729,7 +2729,7 @@
"http"
],
"support": {
- "source": "https://github.com/symfony/http-client/tree/v6.4.0"
+ "source": "https://github.com/symfony/http-client/tree/v6.4.2"
},
"funding": [
{
@@ -3510,23 +3510,23 @@
},
{
"name": "symfony/process",
- "version": "v6.4.0",
- "version_normalized": "6.4.0.0",
+ "version": "v6.4.2",
+ "version_normalized": "6.4.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/process.git",
- "reference": "191703b1566d97a5425dc969e4350d32b8ef17aa"
+ "reference": "c4b1ef0bc80533d87a2e969806172f1c2a980241"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/process/zipball/191703b1566d97a5425dc969e4350d32b8ef17aa",
- "reference": "191703b1566d97a5425dc969e4350d32b8ef17aa",
+ "url": "https://api.github.com/repos/symfony/process/zipball/c4b1ef0bc80533d87a2e969806172f1c2a980241",
+ "reference": "c4b1ef0bc80533d87a2e969806172f1c2a980241",
"shasum": ""
},
"require": {
"php": ">=8.1"
},
- "time": "2023-11-17T21:06:49+00:00",
+ "time": "2023-12-22T16:42:54+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -3554,7 +3554,7 @@
"description": "Executes commands in sub-processes",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/process/tree/v6.4.0"
+ "source": "https://github.com/symfony/process/tree/v6.4.2"
},
"funding": [
{
@@ -3643,17 +3643,17 @@
},
{
"name": "symfony/serializer",
- "version": "v6.4.1",
- "version_normalized": "6.4.1.0",
+ "version": "v6.4.2",
+ "version_normalized": "6.4.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/serializer.git",
- "reference": "7ead272e62c9567df619ef3c49809bf934ddbc1f"
+ "reference": "f87ea9d7bfd4cf2f7b72be554607e6c96e6664af"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/serializer/zipball/7ead272e62c9567df619ef3c49809bf934ddbc1f",
- "reference": "7ead272e62c9567df619ef3c49809bf934ddbc1f",
+ "url": "https://api.github.com/repos/symfony/serializer/zipball/f87ea9d7bfd4cf2f7b72be554607e6c96e6664af",
+ "reference": "f87ea9d7bfd4cf2f7b72be554607e6c96e6664af",
"shasum": ""
},
"require": {
@@ -3696,7 +3696,7 @@
"symfony/var-exporter": "^5.4|^6.0|^7.0",
"symfony/yaml": "^5.4|^6.0|^7.0"
},
- "time": "2023-12-01T14:54:37+00:00",
+ "time": "2023-12-29T15:34:34+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -3724,7 +3724,7 @@
"description": "Handles serializing and deserializing data structures, including object graphs, into array structures or other formats like XML and JSON.",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/serializer/tree/v6.4.1"
+ "source": "https://github.com/symfony/serializer/tree/v6.4.2"
},
"funding": [
{
@@ -3894,17 +3894,17 @@
},
{
"name": "symfony/string",
- "version": "v6.4.0",
- "version_normalized": "6.4.0.0",
+ "version": "v6.4.2",
+ "version_normalized": "6.4.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/string.git",
- "reference": "b45fcf399ea9c3af543a92edf7172ba21174d809"
+ "reference": "7cb80bc10bfcdf6b5492741c0b9357dac66940bc"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/string/zipball/b45fcf399ea9c3af543a92edf7172ba21174d809",
- "reference": "b45fcf399ea9c3af543a92edf7172ba21174d809",
+ "url": "https://api.github.com/repos/symfony/string/zipball/7cb80bc10bfcdf6b5492741c0b9357dac66940bc",
+ "reference": "7cb80bc10bfcdf6b5492741c0b9357dac66940bc",
"shasum": ""
},
"require": {
@@ -3924,7 +3924,7 @@
"symfony/translation-contracts": "^2.5|^3.0",
"symfony/var-exporter": "^5.4|^6.0|^7.0"
},
- "time": "2023-11-28T20:41:49+00:00",
+ "time": "2023-12-10T16:15:48+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -3963,7 +3963,7 @@
"utf8"
],
"support": {
- "source": "https://github.com/symfony/string/tree/v6.4.0"
+ "source": "https://github.com/symfony/string/tree/v6.4.2"
},
"funding": [
{
@@ -3983,17 +3983,17 @@
},
{
"name": "symfony/var-exporter",
- "version": "v6.4.1",
- "version_normalized": "6.4.1.0",
+ "version": "v6.4.2",
+ "version_normalized": "6.4.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/var-exporter.git",
- "reference": "2d08ca6b9cc704dce525615d1e6d1788734f36d9"
+ "reference": "5fe9a0021b8d35e67d914716ec8de50716a68e7e"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/var-exporter/zipball/2d08ca6b9cc704dce525615d1e6d1788734f36d9",
- "reference": "2d08ca6b9cc704dce525615d1e6d1788734f36d9",
+ "url": "https://api.github.com/repos/symfony/var-exporter/zipball/5fe9a0021b8d35e67d914716ec8de50716a68e7e",
+ "reference": "5fe9a0021b8d35e67d914716ec8de50716a68e7e",
"shasum": ""
},
"require": {
@@ -4003,7 +4003,7 @@
"require-dev": {
"symfony/var-dumper": "^5.4|^6.0|^7.0"
},
- "time": "2023-11-30T10:32:10+00:00",
+ "time": "2023-12-27T08:18:35+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -4041,7 +4041,7 @@
"serialize"
],
"support": {
- "source": "https://github.com/symfony/var-exporter/tree/v6.4.1"
+ "source": "https://github.com/symfony/var-exporter/tree/v6.4.2"
},
"funding": [
{
diff --git a/php-bartlett-PHP-CompatInfo-7.0.0-php83.patch b/php-bartlett-PHP-CompatInfo-7.0.0-php83.patch
deleted file mode 100644
index 443555c..0000000
--- a/php-bartlett-PHP-CompatInfo-7.0.0-php83.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From bc069b672d65748fdc257e23c667310946e7837e Mon Sep 17 00:00:00 2001
-From: Laurent Laville <laurent.laville@gmail.com>
-Date: Thu, 2 Nov 2023 06:52:05 +0000
-Subject: [PATCH] initialize PHP 8.3 support
-
----
- composer.json | 2 +-
- config/set/php83.php | 18 ++++++++++++++++++
- config/set/up-to-php83.php | 14 ++++++++++++++
- 3 files changed, 33 insertions(+), 1 deletion(-)
- create mode 100644 config/set/php83.php
- create mode 100644 config/set/up-to-php83.php
-
-diff --git a/config/set/php83.php b/config/set/php83.php
-new file mode 100644
-index 00000000..32531fb1
---- /dev/null
-+++ b/config/set/php83.php
-@@ -0,0 +1,18 @@
-+<?php declare(strict_types=1);
-+/**
-+ * This file is part of the PHP_CompatInfo package.
-+ *
-+ * For the full copyright and license information, please view the LICENSE
-+ * file that was distributed with this source code.
-+ */
-+
-+use Symfony\Component\DependencyInjection\Loader\Configurator\ContainerConfigurator;
-+
-+/**
-+ * Build the Container with PHP 8.3 features detection
-+ *
-+ * @author Laurent Laville
-+ * @since Release 8.0.0
-+ */
-+return static function (ContainerConfigurator $containerConfigurator): void {
-+};
-diff --git a/config/set/up-to-php83.php b/config/set/up-to-php83.php
-new file mode 100644
-index 00000000..8a496337
---- /dev/null
-+++ b/config/set/up-to-php83.php
-@@ -0,0 +1,14 @@
-+<?php declare(strict_types=1);
-+/**
-+ * Build the Container with PHP features detection up to version 8.3
-+ *
-+ * @author Laurent Laville
-+ * @since Release 8.0.0
-+ */
-+
-+use Symfony\Component\DependencyInjection\Loader\Configurator\ContainerConfigurator;
-+
-+return static function (ContainerConfigurator $containerConfigurator): void {
-+ $containerConfigurator->import(__DIR__ . '/up-to-php82.php');
-+ $containerConfigurator->import(__DIR__ . '/php83.php');
-+};
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index 87d3cc5..72ff061 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -11,13 +11,13 @@
%undefine __brp_mangle_shebangs
%{!?php_version: %global php_version %(php -r 'echo PHP_VERSION;' 2>/dev/null)}
-%global gh_commit dde87fe8879d5b9a86cb5b83a94c237adf2fc831
+%global gh_commit 26b0219fde16933f67d991fdc3974d304eec3ead
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20151005
%global gh_owner llaville
%global gh_project php-compatinfo
-%global upstream_version 7.0.3
+%global upstream_version 7.1.0
#global upstream_prever RC1
Name: php-bartlett-PHP-CompatInfo
@@ -36,8 +36,6 @@ Source9: makesrc.sh
# Relocate the database
Patch0: %{name}-6.0.0-rpm.patch
-# Allow PHP 8.3
-Patch1: %{name}-7.0.0-php83.patch
BuildArch: noarch
BuildRequires: php(language) >= 8.1
@@ -83,18 +81,18 @@ Provides: bundled(php-psr-event-dispatcher) = 1.0.0
Provides: bundled(php-psr-log) = 3.0.0
Provides: bundled(php-ramsey-collection) = 2.0.0
Provides: bundled(php-ramsey-uuid) = 4.7.5
-Provides: bundled(php-symfony-cache) = v6.4.0
+Provides: bundled(php-symfony-cache) = v6.4.2
Provides: bundled(php-symfony-cache-contracts) = v3.4.0
-Provides: bundled(php-symfony-clock) = v6.4.0
+Provides: bundled(php-symfony-clock) = v6.4.2
Provides: bundled(php-symfony-config) = v6.4.0
-Provides: bundled(php-symfony-console) = v6.4.1
-Provides: bundled(php-symfony-dependency-injection) = v6.4.1
+Provides: bundled(php-symfony-console) = v6.4.2
+Provides: bundled(php-symfony-dependency-injection) = v6.4.2
Provides: bundled(php-symfony-deprecation-contracts) = v3.4.0
-Provides: bundled(php-symfony-event-dispatcher) = v6.4.0
+Provides: bundled(php-symfony-event-dispatcher) = v6.4.2
Provides: bundled(php-symfony-event-dispatcher-contracts) = v3.4.0
Provides: bundled(php-symfony-filesystem) = v6.4.0
Provides: bundled(php-symfony-finder) = v6.4.0
-Provides: bundled(php-symfony-http-client) = v6.4.0
+Provides: bundled(php-symfony-http-client) = v6.4.2
Provides: bundled(php-symfony-http-client-contracts) = v3.4.0
Provides: bundled(php-symfony-messenger) = v6.4.0
Provides: bundled(php-symfony-polyfill-ctype) = v1.28.0
@@ -104,13 +102,13 @@ Provides: bundled(php-symfony-polyfill-mbstring) = v1.28.0
Provides: bundled(php-symfony-polyfill-php72) = v1.28.0
Provides: bundled(php-symfony-polyfill-php80) = v1.28.0
Provides: bundled(php-symfony-polyfill-php83) = v1.28.0
-Provides: bundled(php-symfony-process) = v6.4.0
+Provides: bundled(php-symfony-process) = v6.4.2
Provides: bundled(php-symfony-requirements-checker) = v2.0.1
-Provides: bundled(php-symfony-serializer) = v6.4.1
+Provides: bundled(php-symfony-serializer) = v6.4.2
Provides: bundled(php-symfony-service-contracts) = v3.4.1
Provides: bundled(php-symfony-stopwatch) = v6.4.0
-Provides: bundled(php-symfony-string) = v6.4.0
-Provides: bundled(php-symfony-var-exporter) = v6.4.1
+Provides: bundled(php-symfony-string) = v6.4.2
+Provides: bundled(php-symfony-var-exporter) = v6.4.2
Provides: phpcompatinfo = %{version}
Provides: php-composer(bartlett/php-compatinfo) = %{version}
@@ -126,7 +124,6 @@ show content of dictionary references.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
%patch -P0 -p1 -b .rpm
-%patch -P1 -p1
# https://github.com/llaville/php-compatinfo-db/issues/112
sed -e 's/touch/@touch/' -i vendor/bartlett/php-compatinfo-db/config/set/default.php
@@ -203,6 +200,9 @@ install -D -p -m 755 %{SOURCE1} %{buildroot}%{_datadir}/%{name}/fedora-
%changelog
+* Tue Jan 2 2024 Remi Collet <remi@remirepo.net> - 7.1.0-1
+- update to 7.1.0
+
* Sat Dec 30 2023 Remi Collet <remi@remirepo.net> - 7.0.3-1
- update to 7.0.3
- update bundled bartlett/php-compatinfo-db to 6.1.1