summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-12-30 09:00:17 +0100
committerRemi Collet <remi@php.net>2023-12-30 09:00:17 +0100
commit432e938ddef359226205dfb92b3119b26d7a55fc (patch)
tree4d8d320813a0fb4b1bc49b80eba4990207d3f150
parent3370aef6419d2308a3e28207723425de0d46b898 (diff)
update to 7.0.3
update bundled bartlett/php-compatinfo-db to 6.1.1
-rw-r--r--composer.json22
-rw-r--r--installed.json72
-rw-r--r--php-bartlett-PHP-CompatInfo.spec16
3 files changed, 69 insertions, 41 deletions
diff --git a/composer.json b/composer.json
index 756dfa4..fb31fc4 100644
--- a/composer.json
+++ b/composer.json
@@ -30,7 +30,8 @@
"symfony/stopwatch": "^5.4 || ^6.0"
},
"require-dev": {
- "symfony/framework-bundle": "^5.4 || ^6.0"
+ "symfony/framework-bundle": "^5.4 || ^6.0",
+ "bamarni/composer-bin-plugin": "^1.8"
},
"authors": [
{
@@ -60,11 +61,28 @@
"prefer-stable": true,
"config": {
"sort-packages": true,
- "optimize-autoloader": true
+ "optimize-autoloader": true,
+ "allow-plugins": {
+ "bamarni/composer-bin-plugin": true
+ }
},
"extra": {
"branch-alias": {
"dev-master": "7.0.x-dev"
+ },
+ "bamarni-bin": {
+ "bin-links": true,
+ "target-directory": "vendor-bin",
+ "forward-command": true
}
+ },
+ "scripts": {
+ "bin": "echo 'bin not installed'",
+ "post-update-cmd": [
+ "@composer bin all update --ansi"
+ ],
+ "post-install-cmd": [
+ "@composer bin all install --ansi"
+ ]
}
}
diff --git a/installed.json b/installed.json
index 179b7d1..bffce70 100644
--- a/installed.json
+++ b/installed.json
@@ -2,17 +2,17 @@
"packages": [
{
"name": "bartlett/php-compatinfo-db",
- "version": "6.0.0",
- "version_normalized": "6.0.0.0",
+ "version": "6.1.1",
+ "version_normalized": "6.1.1.0",
"source": {
"type": "git",
"url": "https://github.com/llaville/php-compatinfo-db.git",
- "reference": "7520c2728ba912b4de94b9d86106f6701cc84961"
+ "reference": "b687d48b04e5f38af0dcd465981792b4033b188b"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/llaville/php-compatinfo-db/zipball/7520c2728ba912b4de94b9d86106f6701cc84961",
- "reference": "7520c2728ba912b4de94b9d86106f6701cc84961",
+ "url": "https://api.github.com/repos/llaville/php-compatinfo-db/zipball/b687d48b04e5f38af0dcd465981792b4033b188b",
+ "reference": "b687d48b04e5f38af0dcd465981792b4033b188b",
"shasum": ""
},
"require": {
@@ -38,10 +38,11 @@
"symfony/stopwatch": "^6.4 || ^7.0"
},
"require-dev": {
- "psr/log": "^1.0 || ^3.0",
+ "bamarni/composer-bin-plugin": "^1.8",
+ "psr/log": "^3.0",
"symfony/framework-bundle": "^6.4 || ^7.0"
},
- "time": "2023-12-06T06:07:45+00:00",
+ "time": "2023-12-30T06:38:52+00:00",
"bin": [
"bin/compatinfo-db"
],
@@ -49,6 +50,11 @@
"extra": {
"branch-alias": {
"dev-master": "6.x-dev"
+ },
+ "bamarni-bin": {
+ "bin-links": true,
+ "target-directory": "vendor-bin",
+ "forward-command": true
}
},
"installation-source": "dist",
@@ -1052,17 +1058,17 @@
},
{
"name": "doctrine/orm",
- "version": "2.17.1",
- "version_normalized": "2.17.1.0",
+ "version": "2.17.2",
+ "version_normalized": "2.17.2.0",
"source": {
"type": "git",
"url": "https://github.com/doctrine/orm.git",
- "reference": "1a4fe6e0bb67762370937a7e6cee3da40a9122d1"
+ "reference": "393679a4795e49b0b3ac317dce84d0f8888f2b77"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/doctrine/orm/zipball/1a4fe6e0bb67762370937a7e6cee3da40a9122d1",
- "reference": "1a4fe6e0bb67762370937a7e6cee3da40a9122d1",
+ "url": "https://api.github.com/repos/doctrine/orm/zipball/393679a4795e49b0b3ac317dce84d0f8888f2b77",
+ "reference": "393679a4795e49b0b3ac317dce84d0f8888f2b77",
"shasum": ""
},
"require": {
@@ -1095,17 +1101,17 @@
"phpunit/phpunit": "^7.5 || ^8.5 || ^9.6",
"psr/log": "^1 || ^2 || ^3",
"squizlabs/php_codesniffer": "3.7.2",
- "symfony/cache": "^4.4 || ^5.4 || ^6.0",
- "symfony/var-exporter": "^4.4 || ^5.4 || ^6.2",
- "symfony/yaml": "^3.4 || ^4.0 || ^5.0 || ^6.0",
- "vimeo/psalm": "4.30.0 || 5.15.0"
+ "symfony/cache": "^4.4 || ^5.4 || ^6.4 || ^7.0",
+ "symfony/var-exporter": "^4.4 || ^5.4 || ^6.2 || ^7.0",
+ "symfony/yaml": "^3.4 || ^4.0 || ^5.0 || ^6.0 || ^7.0",
+ "vimeo/psalm": "4.30.0 || 5.16.0"
},
"suggest": {
"ext-dom": "Provides support for XSD validation for XML mapping files",
"symfony/cache": "Provides cache support for Setup Tool with doctrine/cache 2.0",
"symfony/yaml": "If you want to use YAML Metadata Mapping Driver"
},
- "time": "2023-11-17T06:25:40+00:00",
+ "time": "2023-12-20T21:47:52+00:00",
"bin": [
"bin/doctrine"
],
@@ -1150,7 +1156,7 @@
],
"support": {
"issues": "https://github.com/doctrine/orm/issues",
- "source": "https://github.com/doctrine/orm/tree/2.17.1"
+ "source": "https://github.com/doctrine/orm/tree/2.17.2"
},
"install-path": "../doctrine/orm"
},
@@ -1257,17 +1263,17 @@
},
{
"name": "nikic/php-parser",
- "version": "v4.17.1",
- "version_normalized": "4.17.1.0",
+ "version": "v4.18.0",
+ "version_normalized": "4.18.0.0",
"source": {
"type": "git",
"url": "https://github.com/nikic/PHP-Parser.git",
- "reference": "a6303e50c90c355c7eeee2c4a8b27fe8dc8fef1d"
+ "reference": "1bcbb2179f97633e98bbbc87044ee2611c7d7999"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/nikic/PHP-Parser/zipball/a6303e50c90c355c7eeee2c4a8b27fe8dc8fef1d",
- "reference": "a6303e50c90c355c7eeee2c4a8b27fe8dc8fef1d",
+ "url": "https://api.github.com/repos/nikic/PHP-Parser/zipball/1bcbb2179f97633e98bbbc87044ee2611c7d7999",
+ "reference": "1bcbb2179f97633e98bbbc87044ee2611c7d7999",
"shasum": ""
},
"require": {
@@ -1278,7 +1284,7 @@
"ircmaxell/php-yacc": "^0.0.7",
"phpunit/phpunit": "^6.5 || ^7.0 || ^8.0 || ^9.0"
},
- "time": "2023-08-13T19:53:39+00:00",
+ "time": "2023-12-10T21:03:43+00:00",
"bin": [
"bin/php-parse"
],
@@ -1310,7 +1316,7 @@
],
"support": {
"issues": "https://github.com/nikic/PHP-Parser/issues",
- "source": "https://github.com/nikic/PHP-Parser/tree/v4.17.1"
+ "source": "https://github.com/nikic/PHP-Parser/tree/v4.18.0"
},
"install-path": "../nikic/php-parser"
},
@@ -3738,27 +3744,27 @@
},
{
"name": "symfony/service-contracts",
- "version": "v3.4.0",
- "version_normalized": "3.4.0.0",
+ "version": "v3.4.1",
+ "version_normalized": "3.4.1.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/service-contracts.git",
- "reference": "b3313c2dbffaf71c8de2934e2ea56ed2291a3838"
+ "reference": "fe07cbc8d837f60caf7018068e350cc5163681a0"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/service-contracts/zipball/b3313c2dbffaf71c8de2934e2ea56ed2291a3838",
- "reference": "b3313c2dbffaf71c8de2934e2ea56ed2291a3838",
+ "url": "https://api.github.com/repos/symfony/service-contracts/zipball/fe07cbc8d837f60caf7018068e350cc5163681a0",
+ "reference": "fe07cbc8d837f60caf7018068e350cc5163681a0",
"shasum": ""
},
"require": {
"php": ">=8.1",
- "psr/container": "^2.0"
+ "psr/container": "^1.1|^2.0"
},
"conflict": {
"ext-psr": "<1.1|>=2"
},
- "time": "2023-07-30T20:28:31+00:00",
+ "time": "2023-12-26T14:02:43+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -3803,7 +3809,7 @@
"standards"
],
"support": {
- "source": "https://github.com/symfony/service-contracts/tree/v3.4.0"
+ "source": "https://github.com/symfony/service-contracts/tree/v3.4.1"
},
"funding": [
{
diff --git a/php-bartlett-PHP-CompatInfo.spec b/php-bartlett-PHP-CompatInfo.spec
index 367682d..87d3cc5 100644
--- a/php-bartlett-PHP-CompatInfo.spec
+++ b/php-bartlett-PHP-CompatInfo.spec
@@ -11,13 +11,13 @@
%undefine __brp_mangle_shebangs
%{!?php_version: %global php_version %(php -r 'echo PHP_VERSION;' 2>/dev/null)}
-%global gh_commit cff8a7aa5a0fcccb0ef8bcb11dc55480b88538bd
+%global gh_commit dde87fe8879d5b9a86cb5b83a94c237adf2fc831
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20151005
%global gh_owner llaville
%global gh_project php-compatinfo
-%global upstream_version 7.0.2
+%global upstream_version 7.0.3
#global upstream_prever RC1
Name: php-bartlett-PHP-CompatInfo
@@ -59,8 +59,8 @@ Requires: php-xmlreader
# Bundled libraries
# License BSD-3-Clause
-Provides: bundled(php-bartlett-php-compatinfo-db) = 6.0.0
-Provides: bundled(php-nikic-php-parser) = v4.17.1
+Provides: bundled(php-bartlett-php-compatinfo-db) = 6.1.1
+Provides: bundled(php-nikic-php-parser) = v4.18.0
# License MIT
Provides: bundled(php-bartlett-sarif-php-sdk) = 1.0.1
Provides: bundled(php-brick-math) = 0.11.0
@@ -74,7 +74,7 @@ Provides: bundled(php-doctrine-event-manager) = 2.0.0
Provides: bundled(php-doctrine-inflector) = 2.0.8
Provides: bundled(php-doctrine-instantiator) = 2.0.0
Provides: bundled(php-doctrine-lexer) = 2.1.0
-Provides: bundled(php-doctrine-orm) = 2.17.1
+Provides: bundled(php-doctrine-orm) = 2.17.2
Provides: bundled(php-doctrine-persistence) = 3.2.0
Provides: bundled(php-psr-cache) = 3.0.0
Provides: bundled(php-psr-clock) = 1.0.0
@@ -107,7 +107,7 @@ Provides: bundled(php-symfony-polyfill-php83) = v1.28.0
Provides: bundled(php-symfony-process) = v6.4.0
Provides: bundled(php-symfony-requirements-checker) = v2.0.1
Provides: bundled(php-symfony-serializer) = v6.4.1
-Provides: bundled(php-symfony-service-contracts) = v3.4.0
+Provides: bundled(php-symfony-service-contracts) = v3.4.1
Provides: bundled(php-symfony-stopwatch) = v6.4.0
Provides: bundled(php-symfony-string) = v6.4.0
Provides: bundled(php-symfony-var-exporter) = v6.4.1
@@ -203,6 +203,10 @@ install -D -p -m 755 %{SOURCE1} %{buildroot}%{_datadir}/%{name}/fedora-
%changelog
+* Sat Dec 30 2023 Remi Collet <remi@remirepo.net> - 7.0.3-1
+- update to 7.0.3
+- update bundled bartlett/php-compatinfo-db to 6.1.1
+
* Wed Dec 6 2023 Remi Collet <remi@remirepo.net> - 7.0.2-1
- update to 7.0.2
- update bundled bartlett/php-compatinfo-db to 6.0.0