summaryrefslogtreecommitdiffstats
path: root/phinx.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-02 11:08:47 +0100
committerRemi Collet <remi@remirepo.net>2020-01-02 11:08:47 +0100
commitf3679ae11f123c9e79aece86e03aaa31a65fc120 (patch)
treea9bfb4ef048c4ceee5b183ed47b04853ef09014f /phinx.spec
parent20d8e568224fdcf69ac60ef0a00fdfabd9b116fb (diff)
- update to 0.11.4
- raise dependency on cake 3.7
Diffstat (limited to 'phinx.spec')
-rw-r--r--phinx.spec38
1 files changed, 16 insertions, 22 deletions
diff --git a/phinx.spec b/phinx.spec
index e27397d..a4b3faa 100644
--- a/phinx.spec
+++ b/phinx.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 3c6a171b0455225cf42716dc4864feb620da716f
+%global gh_commit 10e8c3f6b09111f4c0ef128d5a43375e15286cc5
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner robmorgan
#global gh_date 20150820
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{gh_project}
-Version: 0.11.3
+Version: 0.11.4
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: Manage the database migrations for your PHP app
@@ -37,18 +37,14 @@ BuildArch: noarch
# Because we use PHPUnit 7
BuildRequires: php(language) >= 7.1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(cakephp/collection) >= 3.6 with php-composer(cakephp/collection) < 4)
-BuildRequires: (php-composer(cakephp/core) >= 3.6 with php-composer(cakephp/core) < 4)
-BuildRequires: (php-composer(cakephp/database) >= 3.6 with php-composer(cakephp/database) < 4)
-BuildRequires: (php-composer(cakephp/datasource) >= 3.6 with php-composer(cakephp/datasource) < 4)
+BuildRequires: (php-composer(cakephp/collection) >= 3.7 with php-composer(cakephp/collection) < 4)
+BuildRequires: (php-composer(cakephp/database) >= 3.7 with php-composer(cakephp/database) < 4)
BuildRequires: (php-composer(symfony/console) >= 3.4 with php-composer(symfony/console) < 6)
BuildRequires: (php-composer(symfony/config) >= 3.4 with php-composer(symfony/config) < 6)
BuildRequires: (php-composer(symfony/yaml) >= 3.4 with php-composer(symfony/yaml) < 6)
%else
-BuildRequires: php-cakephp-collection >= 3.6
-BuildRequires: php-cakephp-core >= 3.6
-BuildRequires: php-cakephp-database >= 3.6
-BuildRequires: php-cakephp-datasource >= 3.6
+BuildRequires: php-cakephp-collection >= 3.7
+BuildRequires: php-cakephp-database >= 3.7
BuildRequires: php-symfony3-console >= 3.4
BuildRequires: php-symfony3-config >= 3.4
BuildRequires: php-symfony3-yaml >= 3.4
@@ -69,27 +65,21 @@ BuildRequires: php-composer(fedora/autoloader)
# From composer.json, "require": {
# "php": ">=5.6",
-# "cakephp/collection": "^3.6",
-# "cakephp/core": "^3.6",
-# "cakephp/database": "^3.6",
-# "cakephp/datasource": "^3.6",
+# "cakephp/collection": "^3.7",
+# "cakephp/database": "^3.7",
# "symfony/console": "^3.4|^4.0",
# "symfony/config": "^3.4|^4.0",
# "symfony/yaml": "^3.4|^4.0"
Requires: php(language) >= 5.6
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(cakephp/collection) >= 3.6 with php-composer(cakephp/collection) < 4)
-Requires: (php-composer(cakephp/core) >= 3.6 with php-composer(cakephp/core) < 4)
-Requires: (php-composer(cakephp/database) >= 3.6 with php-composer(cakephp/database) < 4)
-Requires: (php-composer(cakephp/datasource) >= 3.6 with php-composer(cakephp/datasource) < 4)
+Requires: (php-composer(cakephp/collection) >= 3.7 with php-composer(cakephp/collection) < 4)
+Requires: (php-composer(cakephp/database) >= 3.7 with php-composer(cakephp/database) < 4)
Requires: (php-composer(symfony/console) >= 3.4 with php-composer(symfony/console) < 6)
Requires: (php-composer(symfony/config) >= 3.4 with php-composer(symfony/config) < 6)
Requires: (php-composer(symfony/yaml) >= 3.4 with php-composer(symfony/yaml) < 6)
%else
-Requires: php-cakephp-collection >= 3.6
-Requires: php-cakephp-core >= 3.6
-Requires: php-cakephp-database >= 3.6
-Requires: php-cakephp-datasource >= 3.6
+Requires: php-cakephp-collection >= 3.7
+Requires: php-cakephp-database >= 3.7
Requires: php-symfony3-console >= 3.4
Requires: php-symfony3-config >= 3.4
Requires: php-symfony3-yaml >= 3.4
@@ -199,6 +189,10 @@ exit $ret
%changelog
+* Thu Jan 2 2020 Remi Collet <remi@remirepo.net> - 0.11.4-1
+- update to 0.11.4
+- raise dependency on cake 3.7
+
* Fri Dec 13 2019 Remi Collet <remi@remirepo.net> - 0.11.3-1
- update to 0.11.3
- allow Symfony 5