summaryrefslogtreecommitdiffstats
path: root/phinx.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-12-13 10:00:56 +0100
committerRemi Collet <remi@remirepo.net>2019-12-13 10:00:56 +0100
commit20d8e568224fdcf69ac60ef0a00fdfabd9b116fb (patch)
treed30c12d153f84030736dbfb158b1f904809a287b /phinx.spec
parent56c857f0b2fd08864bc2c0817c02dc293543d27a (diff)
- update to 0.11.3
- allow Symfony 5
Diffstat (limited to 'phinx.spec')
-rw-r--r--phinx.spec28
1 files changed, 15 insertions, 13 deletions
diff --git a/phinx.spec b/phinx.spec
index 1dbfbf4..e27397d 100644
--- a/phinx.spec
+++ b/phinx.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit a6cced878695d26396b26dfd62ce300aea07de05
+%global gh_commit 3c6a171b0455225cf42716dc4864feb620da716f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner robmorgan
#global gh_date 20150820
@@ -19,8 +19,8 @@
%global with_tests 0%{!?_without_tests:1}
Name: %{gh_project}
-Version: 0.11.1
-Release: 2%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
+Version: 0.11.3
+Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: Manage the database migrations for your PHP app
License: MIT
@@ -29,9 +29,8 @@ Source0: %{name}-%{version}-%{?gh_short}.tgz
Source1: %{name}-autoload.php
Source2: makesrc.sh
-# hardcode version instead of read it from composer.json
+# Add version in application
Patch0: %{name}-version.patch
-Patch1: https://patch-diff.githubusercontent.com/raw/cakephp/phinx/pull/1603.patch
BuildArch: noarch
%if %{with_tests}
@@ -42,9 +41,9 @@ BuildRequires: (php-composer(cakephp/collection) >= 3.6 with php-composer(cake
BuildRequires: (php-composer(cakephp/core) >= 3.6 with php-composer(cakephp/core) < 4)
BuildRequires: (php-composer(cakephp/database) >= 3.6 with php-composer(cakephp/database) < 4)
BuildRequires: (php-composer(cakephp/datasource) >= 3.6 with php-composer(cakephp/datasource) < 4)
-BuildRequires: (php-composer(symfony/console) >= 3.4 with php-composer(symfony/console) < 5)
-BuildRequires: (php-composer(symfony/config) >= 3.4 with php-composer(symfony/config) < 5)
-BuildRequires: (php-composer(symfony/yaml) >= 3.4 with php-composer(symfony/yaml) < 5)
+BuildRequires: (php-composer(symfony/console) >= 3.4 with php-composer(symfony/console) < 6)
+BuildRequires: (php-composer(symfony/config) >= 3.4 with php-composer(symfony/config) < 6)
+BuildRequires: (php-composer(symfony/yaml) >= 3.4 with php-composer(symfony/yaml) < 6)
%else
BuildRequires: php-cakephp-collection >= 3.6
BuildRequires: php-cakephp-core >= 3.6
@@ -83,9 +82,9 @@ Requires: (php-composer(cakephp/collection) >= 3.6 with php-composer(cake
Requires: (php-composer(cakephp/core) >= 3.6 with php-composer(cakephp/core) < 4)
Requires: (php-composer(cakephp/database) >= 3.6 with php-composer(cakephp/database) < 4)
Requires: (php-composer(cakephp/datasource) >= 3.6 with php-composer(cakephp/datasource) < 4)
-Requires: (php-composer(symfony/console) >= 3.4 with php-composer(symfony/console) < 5)
-Requires: (php-composer(symfony/config) >= 3.4 with php-composer(symfony/config) < 5)
-Requires: (php-composer(symfony/yaml) >= 3.4 with php-composer(symfony/yaml) < 5)
+Requires: (php-composer(symfony/console) >= 3.4 with php-composer(symfony/console) < 6)
+Requires: (php-composer(symfony/config) >= 3.4 with php-composer(symfony/config) < 6)
+Requires: (php-composer(symfony/yaml) >= 3.4 with php-composer(symfony/yaml) < 6)
%else
Requires: php-cakephp-collection >= 3.6
Requires: php-cakephp-core >= 3.6
@@ -124,7 +123,6 @@ Documentation: http://docs.phinx.org
%patch0 -p0
sed -e 's/@VERSION@/%{version}/' \
-i src/Phinx/Console/PhinxApplication.php
-%patch1 -p1
cp %{SOURCE1} src/%{psr0}/autoload.php
@@ -177,7 +175,7 @@ sed -e '/_ENABLED/s/true/false/;/SQLITE_ENABLED/s/false/true/' \
: Run upstream test suite
ret=0
-for cmd in "php %{phpunit}" php71 php72 php73; do
+for cmd in "php %{phpunit}" php71 php72 php73 php74; do
if which $cmd; then
set $cmd
$1 ${2:-%{_bindir}/phpunit6} \
@@ -201,6 +199,10 @@ exit $ret
%changelog
+* Fri Dec 13 2019 Remi Collet <remi@remirepo.net> - 0.11.3-1
+- update to 0.11.3
+- allow Symfony 5
+
* Thu Aug 29 2019 Remi Collet <remi@remirepo.net> - 0.11.1-2
- add patch for PHP 7.4 from
https://github.com/cakephp/phinx/pull/1603