summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-23 09:07:11 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-23 09:07:11 +0100
commitb3c87c01045870ca7999263f9bff4802a713cfe7 (patch)
tree8f9b91fc0ac9c4eb8085239d986f50324014d6b2
parent5928fa18f796ff14148e465309e621576600e47a (diff)
owncloud: 8.2.3 (backported from Fedora)
-rw-r--r--owncloud-8.0.0-disable_minify.patch18
-rw-r--r--owncloud-8.1.5-autoloader_paths.patch24
-rw-r--r--owncloud-8.1.5-composer_includepath.patch11
-rw-r--r--owncloud-8.1.5-dont_update_htacess.patch49
-rw-r--r--owncloud-8.1.5-google_autoload.patch27
-rw-r--r--owncloud-8.2.2-dont_update_htacess.patch51
-rw-r--r--owncloud-8.2.2-drop-AWS-autoloader.patch (renamed from 0001-drop-AWS-autoloader.patch)22
-rw-r--r--owncloud-8.2.2-google_autoload.patch14
-rw-r--r--owncloud-8.2.3-composer_include_path.patch16
-rw-r--r--owncloud-8.2.3-drop-dropbox-autoloader.patch (renamed from owncloud-8.1.5-drop-dropbox-autoloader.patch)14
-rw-r--r--owncloud-8.2.3-use_system_phpparser.patch14
-rw-r--r--owncloud-8.2.3-use_system_psr_libraries.patch31
-rw-r--r--owncloud-8.2.3-videoviewer_noplugins.patch (renamed from owncloud-6.0.2-videoviewer_noplugins.patch)8
-rw-r--r--owncloud-README.fedora21
-rw-r--r--owncloud.spec168
15 files changed, 254 insertions, 234 deletions
diff --git a/owncloud-8.0.0-disable_minify.patch b/owncloud-8.0.0-disable_minify.patch
deleted file mode 100644
index f1673a7..0000000
--- a/owncloud-8.0.0-disable_minify.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- owncloud/lib/private/templatelayout.php 2015-02-18 11:23:48.588804666 -0800
-+++ owncloud/lib/private/templatelayout.php.new 2015-02-21 12:07:47.616822741 -0800
-@@ -5,7 +5,6 @@
- use Assetic\Filter\CssImportFilter;
- use Assetic\Filter\CssMinFilter;
- use Assetic\Filter\CssRewriteFilter;
--use Assetic\Filter\JSMinFilter;
- use OC\Assetic\SeparatorFilter; // waiting on upstream
-
- /**
-@@ -172,7 +171,6 @@
- ), $root, $file);
- }
- return new FileAsset($root . '/' . $file, array(
-- new JSMinFilter(),
- new SeparatorFilter(';')
- ), $root, $file);
- }, $jsFiles);
diff --git a/owncloud-8.1.5-autoloader_paths.patch b/owncloud-8.1.5-autoloader_paths.patch
deleted file mode 100644
index e055c88..0000000
--- a/owncloud-8.1.5-autoloader_paths.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/lib/base.php b/lib/base.php
-index bb60273..0f4021d 100644
---- a/lib/base.php
-+++ b/lib/base.php
-@@ -527,7 +527,9 @@ class OC {
- if (!file_exists($vendorAutoLoad)) {
- throw new \RuntimeException('Composer autoloader not found, unable to continue. Check the folder "3rdparty".');
- }
-- require_once $vendorAutoLoad;
-+ $loader = require_once $vendorAutoLoad;
-+ $loader->add('Pimple', '/usr/share/php/Pimple');
-+ $loader->add('Sabre', '/usr/share/php');
-
- } catch (\RuntimeException $e) {
- OC_Response::setStatus(OC_Response::STATUS_SERVICE_UNAVAILABLE);
-@@ -656,7 +659,7 @@ class OC {
- self::registerFilesystemHooks();
- if (\OC::$server->getSystemConfig()->getValue('enable_previews', true)) {
- self::registerPreviewHooks();
-- }
-+ }
- self::registerShareHooks();
- self::registerLogRotate();
- self::registerLocalAddressBook();
diff --git a/owncloud-8.1.5-composer_includepath.patch b/owncloud-8.1.5-composer_includepath.patch
deleted file mode 100644
index 1f4e4d5..0000000
--- a/owncloud-8.1.5-composer_includepath.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff --git a/lib/base.php b/lib/base.php
-index 0f4021d..431a1f3 100644
---- a/lib/base.php
-+++ b/lib/base.php
-@@ -531,5 +531,6 @@ class OC {
- $loader->add('Pimple', '/usr/share/php/Pimple');
- $loader->add('Sabre', '/usr/share/php');
-+ $loader->setUseIncludePath(true);
-
- } catch (\RuntimeException $e) {
- OC_Response::setStatus(OC_Response::STATUS_SERVICE_UNAVAILABLE);
diff --git a/owncloud-8.1.5-dont_update_htacess.patch b/owncloud-8.1.5-dont_update_htacess.patch
deleted file mode 100644
index c62305c..0000000
--- a/owncloud-8.1.5-dont_update_htacess.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-diff --git a/lib/private/setup.php b/lib/private/setup.php
-index 50bf0dc..d216675 100644
---- a/lib/private/setup.php
-+++ b/lib/private/setup.php
-@@ -350,12 +350,6 @@ class Setup {
- // out that this is indeed an ownCloud data directory
- file_put_contents($config->getSystemValue('datadirectory', \OC::$SERVERROOT.'/data').'/.ocdata', '');
-
-- // Update htaccess files for apache hosts
-- if (isset($_SERVER['SERVER_SOFTWARE']) && strstr($_SERVER['SERVER_SOFTWARE'], 'Apache')) {
-- self::updateHtaccess();
-- self::protectDataDirectory();
-- }
--
- //try to write logtimezone
- if (date_default_timezone_get()) {
- \OC_Config::setValue('logtimezone', date_default_timezone_get());
-diff --git a/lib/private/updater.php b/lib/private/updater.php
-index 8f4b81c..22a4861 100644
---- a/lib/private/updater.php
-+++ b/lib/private/updater.php
-@@ -54,10 +54,10 @@ class Updater extends BasicEmitter {
-
- /** @var ILogger $log */
- private $log;
--
-+
- /** @var \OC\HTTPHelper $helper */
- private $httpHelper;
--
-+
- /** @var IConfig */
- private $config;
-
-@@ -287,14 +287,6 @@ class Updater extends BasicEmitter {
- throw new \Exception('Updates between multiple major versions and downgrades are unsupported.');
- }
-
-- // Update .htaccess files
-- try {
-- Setup::updateHtaccess();
-- Setup::protectDataDirectory();
-- } catch (\Exception $e) {
-- throw new \Exception($e->getMessage());
-- }
--
- // FIXME: Some users do not upload the new ca-bundle.crt, let's catch this
- // in the update. For a newer release we shall use an integrity check after
- // the update.
diff --git a/owncloud-8.1.5-google_autoload.patch b/owncloud-8.1.5-google_autoload.patch
deleted file mode 100644
index 00aa63d..0000000
--- a/owncloud-8.1.5-google_autoload.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/apps/files_external/ajax/google.php b/apps/files_external/ajax/google.php
-index e094367..8f2638b 100644
---- a/apps/files_external/ajax/google.php
-+++ b/apps/files_external/ajax/google.php
-@@ -26,7 +26,7 @@
- */
- set_include_path(get_include_path().PATH_SEPARATOR.
- \OC_App::getAppPath('files_external').'/3rdparty/google-api-php-client/src');
--require_once 'Google/Client.php';
-+require_once 'Google/autoload.php';
-
- OCP\JSON::checkAppEnabled('files_external');
- OCP\JSON::checkLoggedIn();
-diff --git a/apps/files_external/lib/google.php b/apps/files_external/lib/google.php
-index 8199d97..4bec351 100644
---- a/apps/files_external/lib/google.php
-+++ b/apps/files_external/lib/google.php
-@@ -34,8 +34,7 @@ namespace OC\Files\Storage;
-
- set_include_path(get_include_path().PATH_SEPARATOR.
- \OC_App::getAppPath('files_external').'/3rdparty/google-api-php-client/src');
--require_once 'Google/Client.php';
--require_once 'Google/Service/Drive.php';
-+require_once 'Google/autoload.php';
-
- class Google extends \OC\Files\Storage\Common {
-
diff --git a/owncloud-8.2.2-dont_update_htacess.patch b/owncloud-8.2.2-dont_update_htacess.patch
new file mode 100644
index 0000000..4db8819
--- /dev/null
+++ b/owncloud-8.2.2-dont_update_htacess.patch
@@ -0,0 +1,51 @@
+diff --git a/lib/private/setup.php b/lib/private/setup.php
+index 8f1ae38..adc9f6a 100644
+--- a/lib/private/setup.php
++++ b/lib/private/setup.php
+@@ -369,12 +369,6 @@ class Setup {
+ // out that this is indeed an ownCloud data directory
+ file_put_contents($config->getSystemValue('datadirectory', \OC::$SERVERROOT.'/data').'/.ocdata', '');
+
+- // Update htaccess files for apache hosts
+- if (isset($_SERVER['SERVER_SOFTWARE']) && strstr($_SERVER['SERVER_SOFTWARE'], 'Apache')) {
+- self::updateHtaccess();
+- self::protectDataDirectory();
+- }
+-
+ //try to write logtimezone
+ if (date_default_timezone_get()) {
+ $config->setSystemValue('logtimezone', date_default_timezone_get());
+diff --git a/lib/private/updater.php b/lib/private/updater.php
+index 9e5207c..6a169a6 100644
+--- a/lib/private/updater.php
++++ b/lib/private/updater.php
+@@ -285,14 +285,6 @@ class Updater extends BasicEmitter {
+ throw new \Exception('Updates between multiple major versions and downgrades are unsupported.');
+ }
+
+- // Update .htaccess files
+- try {
+- Setup::updateHtaccess();
+- Setup::protectDataDirectory();
+- } catch (\Exception $e) {
+- throw new \Exception($e->getMessage());
+- }
+-
+ // create empty file in data dir, so we can later find
+ // out that this is indeed an ownCloud data directory
+ // (in case it didn't exist before)
+diff -up lib/private/setup.php.0 lib/private/setup.php
+--- a/lib/private/setup.php.0 2016-03-23 08:12:31.399538916 +0100
++++ b/lib/private/setup.php 2016-03-23 08:13:55.783981179 +0100
+@@ -415,6 +415,10 @@ class Setup {
+ * @throws \OC\HintException If .htaccess does not include the current version
+ */
+ public static function updateHtaccess() {
++
++ // Should never be called, but for safety
++ return;
++
+ $setupHelper = new \OC\Setup(\OC::$server->getConfig(), \OC::$server->getIniWrapper(),
+ \OC::$server->getL10N('lib'), new \OC_Defaults(), \OC::$server->getLogger(),
+ \OC::$server->getSecureRandom());
+
diff --git a/0001-drop-AWS-autoloader.patch b/owncloud-8.2.2-drop-AWS-autoloader.patch
index 879e1e8..1db87a7 100644
--- a/0001-drop-AWS-autoloader.patch
+++ b/owncloud-8.2.2-drop-AWS-autoloader.patch
@@ -1,16 +1,3 @@
-From 28d0809a2c8f79b706cc790e8375197bb04f8620 Mon Sep 17 00:00:00 2001
-From: Adam Williamson <awilliam@redhat.com>
-Date: Tue, 30 Dec 2014 13:53:54 -0800
-Subject: [PATCH] drop AWS autoloader
-
-Fedora doesn't need it, as the systemwide copy will be found
-by the Composer autoloader.
----
- .../3rdparty/aws-sdk-php/aws-autoloader.php | 37 ----------------------
- apps/files_external/lib/amazons3.php | 4 ---
- 2 files changed, 41 deletions(-)
- delete mode 100644 apps/files_external/3rdparty/aws-sdk-php/aws-autoloader.php
-
diff --git a/apps/files_external/3rdparty/aws-sdk-php/aws-autoloader.php b/apps/files_external/3rdparty/aws-sdk-php/aws-autoloader.php
deleted file mode 100644
index 8072b11..0000000
@@ -55,10 +42,10 @@ index 8072b11..0000000
-
-return $classLoader;
diff --git a/apps/files_external/lib/amazons3.php b/apps/files_external/lib/amazons3.php
-index 4d94e35..3ceb17a 100644
+index 0091514..4106191 100644
--- a/apps/files_external/lib/amazons3.php
+++ b/apps/files_external/lib/amazons3.php
-@@ -24,10 +24,6 @@
+@@ -35,10 +35,6 @@
namespace OC\Files\Storage;
@@ -68,7 +55,4 @@ index 4d94e35..3ceb17a 100644
-
use Aws\S3\S3Client;
use Aws\S3\Exception\S3Exception;
-
---
-2.2.0
-
+ use Icewind\Streams\IteratorDirectory;
diff --git a/owncloud-8.2.2-google_autoload.patch b/owncloud-8.2.2-google_autoload.patch
new file mode 100644
index 0000000..6b31a17
--- /dev/null
+++ b/owncloud-8.2.2-google_autoload.patch
@@ -0,0 +1,14 @@
+diff --git a/apps/files_external/lib/google.php b/apps/files_external/lib/google.php
+index eba2ee7..93a2096 100644
+--- a/apps/files_external/lib/google.php
++++ b/apps/files_external/lib/google.php
+@@ -37,8 +37,7 @@ use Icewind\Streams\IteratorDirectory;
+
+ set_include_path(get_include_path().PATH_SEPARATOR.
+ \OC_App::getAppPath('files_external').'/3rdparty/google-api-php-client/src');
+-require_once 'Google/Client.php';
+-require_once 'Google/Service/Drive.php';
++require_once 'Google/autoload.php';
+
+ class Google extends \OC\Files\Storage\Common {
+
diff --git a/owncloud-8.2.3-composer_include_path.patch b/owncloud-8.2.3-composer_include_path.patch
new file mode 100644
index 0000000..7832dc8
--- /dev/null
+++ b/owncloud-8.2.3-composer_include_path.patch
@@ -0,0 +1,16 @@
+diff --git a/lib/base.php b/lib/base.php
+index 5ce5fae..544e159 100644
+--- a/lib/base.php
++++ b/lib/base.php
+@@ -498,7 +498,10 @@ class OC {
+ if (!file_exists($vendorAutoLoad)) {
+ throw new \RuntimeException('Composer autoloader not found, unable to continue. Check the folder "3rdparty". Running "git submodule update --init" will initialize the git submodule that handles the subfolder "3rdparty".');
+ }
+- require_once $vendorAutoLoad;
++ $loader = require_once $vendorAutoLoad;
++ $loader->add('Sabre', '/usr/share/php');
++ $loader->add('Sabre\VObject', '/usr/share/php');
++ $loader->setUseIncludePath(true);
+
+ } catch (\RuntimeException $e) {
+ OC_Response::setStatus(OC_Response::STATUS_SERVICE_UNAVAILABLE);
diff --git a/owncloud-8.1.5-drop-dropbox-autoloader.patch b/owncloud-8.2.3-drop-dropbox-autoloader.patch
index 05d933b..8cfd754 100644
--- a/owncloud-8.1.5-drop-dropbox-autoloader.patch
+++ b/owncloud-8.2.3-drop-dropbox-autoloader.patch
@@ -1,7 +1,7 @@
-diff --git a/apps/files_external/ajax/dropbox.php b/apps/files_external/ajax/dropbox.php
-index 55dc417..fe834c0 100644
---- a/apps/files_external/ajax/dropbox.php
-+++ b/apps/files_external/ajax/dropbox.php
+diff --git a/apps/files_external/ajax/oauth1.php b/apps/files_external/ajax/oauth1.php
+index 3d6736b..028d21a 100644
+--- a/apps/files_external/ajax/oauth1.php
++++ b/apps/files_external/ajax/oauth1.php
@@ -23,7 +23,6 @@
* along with this program. If not, see <http://www.gnu.org/licenses/>
*
@@ -11,12 +11,12 @@ index 55dc417..fe834c0 100644
OCP\JSON::checkAppEnabled('files_external');
OCP\JSON::checkLoggedIn();
diff --git a/apps/files_external/lib/dropbox.php b/apps/files_external/lib/dropbox.php
-index 78219f8..b332c0a 100644
+index 6a822c3..b8e7f27 100644
--- a/apps/files_external/lib/dropbox.php
+++ b/apps/files_external/lib/dropbox.php
-@@ -29,8 +29,6 @@
+@@ -31,8 +31,6 @@ namespace OC\Files\Storage;
- namespace OC\Files\Storage;
+ use Icewind\Streams\IteratorDirectory;
-require_once __DIR__ . '/../3rdparty/Dropbox/autoload.php';
-
diff --git a/owncloud-8.2.3-use_system_phpparser.patch b/owncloud-8.2.3-use_system_phpparser.patch
new file mode 100644
index 0000000..716bd8d
--- /dev/null
+++ b/owncloud-8.2.3-use_system_phpparser.patch
@@ -0,0 +1,14 @@
+diff --git a/3rdparty/composer/autoload_files.php b/3rdparty/composer/autoload_files.php
+index 3408e4c..eda4201 100644
+--- a/3rdparty/composer/autoload_files.php
++++ b/3rdparty/composer/autoload_files.php
+@@ -7,8 +7,8 @@ $baseDir = $vendorDir;
+
+ return array(
+ 'ad155f8f1cf0d418fe49e248db8c661b' => $vendorDir . '/react/promise/src/functions_include.php',
+- 'fe1bcd0336136e435eaf197895daf81a' => $vendorDir . '/nikic/php-parser/lib/bootstrap.php',
+ 'e40631d46120a9c38ea139981f8dab26' => $vendorDir . '/ircmaxell/password-compat/lib/password.php',
+ '2c102faa651ef8ea5874edb585946bce' => $vendorDir . '/swiftmailer/swiftmailer/lib/swift_required.php',
+ 'ce89ac35a6c330c55f4710717db9ff78' => $vendorDir . '/kriswallsmith/assetic/src/functions.php',
+ );
++
diff --git a/owncloud-8.2.3-use_system_psr_libraries.patch b/owncloud-8.2.3-use_system_psr_libraries.patch
new file mode 100644
index 0000000..6448b24
--- /dev/null
+++ b/owncloud-8.2.3-use_system_psr_libraries.patch
@@ -0,0 +1,31 @@
+diff --git a/3rdparty/composer/autoload_psr4.php b/3rdparty/composer/autoload_psr4.php
+index 50419c3..0c50d0a 100644
+--- a/3rdparty/composer/autoload_psr4.php
++++ b/3rdparty/composer/autoload_psr4.php
+@@ -6,26 +6,4 @@ $vendorDir = dirname(dirname(__FILE__));
+ $baseDir = $vendorDir;
+
+ return array(
+- 'phpseclib\\' => array($vendorDir . '/phpseclib/phpseclib/phpseclib'),
+- 'ownCloud\\TarStreamer\\' => array($vendorDir . '/deepdiver1975/tarstreamer/src'),
+- 'bantu\\IniGetWrapper\\' => array($vendorDir . '/bantu/ini-get-wrapper/src'),
+- 'ZipStreamer\\' => array($vendorDir . '/mcnetic/zipstreamer/src'),
+- 'SuperClosure\\' => array($vendorDir . '/jeremeamia/SuperClosure/src'),
+- 'Sabre\\VObject\\' => array($vendorDir . '/sabre/vobject/lib'),
+- 'Sabre\\HTTP\\' => array($vendorDir . '/sabre/http/lib'),
+- 'Sabre\\Event\\' => array($vendorDir . '/sabre/event/lib'),
+- 'Sabre\\DAV\\' => array($vendorDir . '/sabre/dav/lib/DAV'),
+- 'Sabre\\DAVACL\\' => array($vendorDir . '/sabre/dav/lib/DAVACL'),
+- 'Sabre\\CardDAV\\' => array($vendorDir . '/sabre/dav/lib/CardDAV'),
+- 'Sabre\\CalDAV\\' => array($vendorDir . '/sabre/dav/lib/CalDAV'),
+- 'React\\Promise\\' => array($vendorDir . '/react/promise/src'),
+- 'Punic\\' => array($vendorDir . '/punic/punic/code'),
+- 'Patchwork\\' => array($vendorDir . '/patchwork/jsqueeze/src'),
+- 'League\\Flysystem\\' => array($vendorDir . '/league/flysystem/src'),
+- 'InterfaSys\\LogNormalizer\\' => array($vendorDir . '/interfasys/lognormalizer/src'),
+- 'Icewind\\Streams\\Tests\\' => array($vendorDir . '/icewind/streams/tests'),
+- 'Icewind\\Streams\\' => array($vendorDir . '/icewind/streams/src'),
+- 'GuzzleHttp\\Stream\\' => array($vendorDir . '/guzzlehttp/streams/src'),
+- 'GuzzleHttp\\Ring\\' => array($vendorDir . '/guzzlehttp/ringphp/src'),
+- 'GuzzleHttp\\' => array($vendorDir . '/guzzlehttp/guzzle/src'),
+ );
diff --git a/owncloud-6.0.2-videoviewer_noplugins.patch b/owncloud-8.2.3-videoviewer_noplugins.patch
index fb8dfd5..797def7 100644
--- a/owncloud-6.0.2-videoviewer_noplugins.patch
+++ b/owncloud-8.2.3-videoviewer_noplugins.patch
@@ -1,6 +1,8 @@
---- apps/files_videoviewer/js/mediaelement-and-player.min.js.orig 2014-03-04 21:35:13.921783071 +0100
-+++ apps/files_videoviewer/js/mediaelement-and-player.min.js 2014-03-04 21:39:40.528053899 +0100
-@@ -38,7 +38,7 @@
+diff --git a/apps/files_videoviewer/js/mediaelement-and-player.min.js b/apps/files_videoviewer/js/mediaelement-and-player.min.js
+index 7547c3c..df35ec9 100644
+--- a/apps/files_videoviewer/js/mediaelement-and-player.min.js
++++ b/apps/files_videoviewer/js/mediaelement-and-player.min.js
+@@ -38,7 +38,7 @@ this.setFullscreen(false)},addEventListener:function(a,b){this.events[a]=this.ev
this.attributes},removeAttribute:function(a){delete this.attributes[a]},getAttribute:function(a){if(this.hasAttribute(a))return this.attributes[a];return""},setAttribute:function(a,b){this.attributes[a]=b},remove:function(){mejs.Utility.removeSwf(this.pluginElement.id);mejs.MediaPluginBridge.unregisterPluginElement(this.pluginElement.id)}};
mejs.MediaPluginBridge={pluginMediaElements:{},htmlMediaElements:{},registerPluginElement:function(a,b,c){this.pluginMediaElements[a]=b;this.htmlMediaElements[a]=c},unregisterPluginElement:function(a){delete this.pluginMediaElements[a];delete this.htmlMediaElements[a]},initPlugin:function(a){var b=this.pluginMediaElements[a],c=this.htmlMediaElements[a];if(b){switch(b.pluginType){case "flash":b.pluginElement=b.pluginApi=document.getElementById(a);break;case "silverlight":b.pluginElement=document.getElementById(b.id);
b.pluginApi=b.pluginElement.Content.MediaElementJS}b.pluginApi!=null&&b.success&&b.success(b,c)}},fireEvent:function(a,b,c){var d,e;if(a=this.pluginMediaElements[a]){b={type:b,target:a};for(d in c){a[d]=c[d];b[d]=c[d]}e=c.bufferedTime||0;b.target.buffered=b.buffered={start:function(){return 0},end:function(){return e},length:1};a.dispatchEvent(b.type,b)}}};
diff --git a/owncloud-README.fedora b/owncloud-README.fedora
index 41c2861..d50fc9f 100644
--- a/owncloud-README.fedora
+++ b/owncloud-README.fedora
@@ -51,7 +51,7 @@ you first access the server it will be just a small stub containing settings
that differ in this package from the upstream defaults. After you first access
ownCloud, the initial setup process will populate it with some more settings.
Other settings that can be provided in this file are documented at:
-https://doc.owncloud.org/server/8.0/admin_manual/configuration/config_sample_php_parameters.html
+https://doc.owncloud.org/server/8.2/admin_manual/configuration_server/config_sample_php_parameters.html
User Data
---------
@@ -65,14 +65,29 @@ Logging
-------
As specified by the configuration file, ownCloud sends messages to the system
logger, which means in a standard Fedora configuration it will log to the
-systemd journal: try "journalctl -b | grep ownCloud". You can also change the
+systemd journal: try "journalctl -b -t ownCloud". You can also change the
loglevel or switch to the built-in log mechanism of ownCloud.
App Store
---------
If you install additional third party apps using the built-in app store, you
can find them in the directory '/var/lib/owncloud/apps'. This functionality is
-enabled by default.
+enabled by default. If this is moved then it's important to configure httpd/nginx
+appropriately for the correct /owncloud/apps-appstore path to alias to the new location.
+
+Selinux Booleans
+----------------
+If you want to use external files (eg remote smb/cifs server) the httpd_can_network_connect
+selinux boolean should be toggled on. If you want to use libreoffice document conversion
+then the httpd_execmem should be toggled on and the unoconv package should be installed.
+
+Memory caching
+--------------
+For performance reasons a memory cache should be configured. In larger installs redis
+may be required but as a basic lightweight alternative edit config.php as per upstream
+documentation and install ACPu via:
+
+dnf install 'php-pecl(apcu)'
For further information see http://owncloud.org/ and http://doc.owncloud.org/
diff --git a/owncloud.spec b/owncloud.spec
index a1dc22f..4a8e492 100644
--- a/owncloud.spec
+++ b/owncloud.spec
@@ -8,19 +8,24 @@
# Please preserve changelog entries
#
Name: owncloud
-Version: 8.1.6
-Release: 1%{?dist}
+Version: 8.2.3
+Release: 2%{?dist}
Summary: Private file sync and share server
Group: Applications/Internet
License: AGPLv3+ and MIT and BSD and CC-BY and CC-BY-SA and GPLv3 and Public Domain and (MPLv1.1 or GPLv2+ or LGPLv2+) and (MIT or GPL+) and (MIT or GPLv2) and ASL 2.0 and LGPLv3
URL: http://owncloud.org
+
# Tarball with non-free sources stripped. To generate:
# ./owncloud-delete-nonfree.sh %%{name}-%%{version}.tar.bz2
Source0: %{name}-%{version}-repack.tar.bz2
# orig source: https://download.owncloud.org/community/%%{name}-%%{version}.tar.bz2
# sha256sum: https://download.owncloud.org/community/%%{name}-%%{version}.tar.bz2.sha256
-# snapshot source: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{github_name}-%{github_commit}.tar.gz
+
+# used to repack the source tarball
+Source42: %{name}-delete-nonfree.sh
+
+
Source1: %{name}-httpd.conf
Source2: %{name}-access-httpd.conf.avail
Source6: %{name}-nginx.conf
@@ -37,42 +42,35 @@ Source5: %{name}-postgresql.txt
# initial setup will fill out other settings appropriately
Source7: %{name}-config.php
-# used to repack the source tarball
-Source42: %{name}-delete-nonfree.sh
-
# Adjust mediaelement not to use its SWF and Silverlight plugins. This
# changes 'plugins:["flash,"silverlight","youtube","vimeo"]' to
# 'plugins:["youtube","vimeo"]'
-Patch1: %{name}-6.0.2-videoviewer_noplugins.patch
-# Ugly way to deal with Pimple 1.x's lack of PSR-0 compliance. Also forces the
-# paths to Sabre deps: /usr/share/php for all of Sabre (to ensure php-sabre-dav
-# package, 2.1 version, is used). Please be careful
-# and *test* if changing this; test with all versions of all Sabre packages
-# installed to make sure it DTRT. Keep an eye on upstream for future changes
-# also.
-Patch2: %{name}-8.1.5-autoloader_paths.patch
+Patch1: %{name}-8.2.3-videoviewer_noplugins.patch
# Turn on include path usage for the Composer autoloader (so it'll find
# systemwide PSR-0 and PSR-4 compliant libraries)
# Upstream wouldn't likely take this, they probably only care about their
# bundled copies
-Patch3: %{name}-8.1.5-composer_includepath.patch
+Patch2: %{name}-8.2.3-composer_include_path.patch
# Drop use of dropbox's unnecessary autoloader (composer will find the
# systemwide copy). This is not upstreamable, but see
# https://github.com/owncloud/core/pull/12113 with similar effect for 8.1+
-Patch4: %{name}-8.1.5-drop-dropbox-autoloader.patch
+Patch3: %{name}-8.2.3-drop-dropbox-autoloader.patch
# Drop use of aws-sdk's dead autoloader (composer will find the systemwide copy)
-Patch6: 0001-drop-AWS-autoloader.patch
-# Disable JS minification (uses non-free JSMin minifier)
-Patch7: owncloud-8.0.0-disable_minify.patch
+Patch4: %{name}-8.2.2-drop-AWS-autoloader.patch
# Stop OC from trying to do stuff to .htaccess files. Just calm down, OC.
# Distributors are on the case.
-Patch8: owncloud-8.1.5-dont_update_htacess.patch
+Patch5: %{name}-8.2.2-dont_update_htacess.patch
# Use Google autoloader instead of including particular files. Upstream
# no longer has each file include all others it needs, they expect you
# to use the autoloader. Can't go upstream until upstream bumps to a
# version of the lib that actually includes the autoloader...
-Patch9: owncloud-8.1.5-google_autoload.patch
+Patch6: %{name}-8.2.2-google_autoload.patch
+
+# Owncloud should use the system libraries with psr
+Patch7: %{name}-8.2.3-use_system_psr_libraries.patch
+# Owncloud shoudl use the system autoloaded react-promise and nitic-phpParser
+Patch8: %{name}-8.2.3-use_system_phpparser.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -109,11 +107,9 @@ Requires: php-filter
# "kriswallsmith/assetic": "1.2.*@dev"
Requires: php-composer(kriswallsmith/assetic) >= 1.2
Requires: php-composer(kriswallsmith/assetic) < 1.3
-Requires: php-getid3
# "pimple/pimple": "~3.0"
Requires: php-composer(pimple/pimple) >= 3.0
Requires: php-composer(pimple/pimple) < 4.0
-Requires: php-opencloud
Requires: php-composer(doctrine/dbal) >= 2.5.0
Requires: php-composer(doctrine/dbal) < 2.6
# "symfony/console": "~2.5"
@@ -123,6 +119,33 @@ Requires: php-composer(symfony/console) < 3.0
Requires: php-composer(symfony/routing) >= 2.5.0
Requires: php-composer(symfony/routing) < 3.0
+Requires: php-composer(guzzlehttp/guzzle) >= 5.0
+Requires: php-composer(guzzlehttp/guzzle) < 6.0
+Requires: php-composer(guzzlehttp/ringphp) >= 1.1
+Requires: php-composer(guzzlehttp/ringphp) < 2.0
+Requires: php-composer(guzzlehttp/streams) >= 3.0
+Requires: php-composer(guzzlehttp/streams) < 4.0
+
+Requires: php-composer(icewind/smb) >= 1.0
+Requires: php-composer(icewind/streams) >= 0.2
+# This makes smb external storage usable and doesn't break things like encryption
+Requires: php-pecl(smbclient) >= 0.8.0
+# Requiring so that the shipped external smb storage works
+%if 0%{?fedora} >= 20 || 0%{?rhel} >= 7
+Requires: samba-common-tools
+Requires: samba-client
+%endif
+
+Requires: php-composer(jeremeamia/superclosure) >= 2.0
+
+Requires: php-composer(nikic/php-parser) >= 1.0
+Requires: php-composer(nikic/php-parser) < 2.0
+
+Requires: php-composer(react/promise) >= 2.0
+Requires: php-composer(react/promise) < 3.0
+
+Requires: php-composer(james-heinrich/getid3)
+
# NB: this will also pull in php-compose(guzzle/guzzle), which is in OC's
# 3rdparty directory. OC sort of has a direct dependency on it but in fact
# it's innately tied to the use of php-opencloud and php-aws-sdk and would
@@ -136,11 +159,18 @@ Requires: php-composer(bantu/ini-get-wrapper) >= 1.0.1
# "ircmaxell/random-lib": "v1.0.0"
# Also pulls in ircmaxell/security-lib which is a dep
Requires: php-composer(ircmaxell/random-lib) >= 1.0.0
+Requires: php-composer(ircmaxell/password-compat) >= 1.0.0
# "natxet/CssMin": "dev-master"
Requires: php-composer(natxet/CssMin) >= 3.0.2
+# Patchwork should now work from system
+Requires: php-composer(patchwork/utf8)
+Requires: php-composer(patchwork/jsqueeze)
+
+Requires: php-composer(punic/punic)
+
## SabreDAV
-Requires: php-composer(sabre/dav) >= 2.1.6
+Requires: php-composer(sabre/dav) >= 2.1.9
Requires: php-composer(sabre/dav) < 3
Requires: php-composer(sabre/event) >= 2.0
Requires: php-composer(sabre/event) < 3.0
@@ -151,16 +181,31 @@ Requires: php-composer(sabre/http) < 4.0
## apps/files_external
Requires: php-pear(pear.dropbox-php.com/Dropbox)
-Requires: php-pear(phpseclib.sourceforge.net/Net_SFTP)
+Requires: php-composer(phpseclib/phpseclib)
# Not pulled via Composer but manually dumped into files_external/3rdparty
Requires: php-google-apiclient >= 1.0.3
Requires: php-aws-sdk >= 2.7.0
+Requires: php-composer(league/flysystem)
+Requires: php-composer(interfasys/lognormalizer)
+Requires: php-composer(owncloud/tarstreamer)
+Requires: php-composer(mcnetic/zipstreamer)
+Requires: php-composer(pear/console_getopt)
+Requires: php-composer(pear/pear-core-minimal)
+Requires: php-composer(pear/archive_tar)
+# fedora have pear version 5.0, remirepo have version 5.4
+Requires: php-composer(swiftmailer/swiftmailer) >= 5.3.1
+
%if 0%{?rhel}
Requires(post): policycoreutils-python
Requires(postun): policycoreutils-python
%endif
+# Suggest as requirement for optional conversion in documents app
+%if 0%{?fedora} >= 21
+Suggests: unoconv
+%endif
+
%description
ownCloud gives you universal access to your files through a web interface or
WebDAV. It also provides a platform to easily view & sync your contacts,
@@ -251,14 +296,14 @@ work with an SQLite 3 database stored on the local system.
%prep
%setup -q -n %{name}
-%patch1 -p0
+%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
+%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
-%patch9 -p1
# prepare package doc
cp %{SOURCE3} README.fedora
@@ -267,8 +312,8 @@ cp %{SOURCE5} README.postgresql
# Strip bundled libraries from global 3rdparty dir
-rm -r 3rdparty/{bantu,doctrine,guzzle,ircmaxell/random-lib,ircmaxell/security-lib,james-heinrich,kriswallsmith,natxet,pear,phpseclib,pimple,rackspace,sabre,symfony}
-rm 3rdparty/{PEAR,PEAR5}.php
+find 3rdparty -mindepth 1 -maxdepth 1 -type d ! -name composer -exec rm -r "{}" \;
+
# we need to symlink some annoying files back here, though...direct file
# autoloading sucks. "files" sections of "autoload" statements in
# composer.json files cause composer to basically hardcode the path to a
@@ -280,56 +325,19 @@ rm 3rdparty/{PEAR,PEAR5}.php
# $vendorDir in the composer loader files to be /usr/share/php.
mkdir -p 3rdparty/kriswallsmith/assetic/src
mkdir -p 3rdparty/natxet/CssMin/src
-mkdir -p 3rdparty/phpseclib/phpseclib/phpseclib/Crypt
mkdir -p 3rdparty/james-heinrich/getid3/getid3
+mkdir -p 3rdparty/swiftmailer/swiftmailer/lib
+mkdir -p 3rdparty/ircmaxell/password-compat/lib
+mkdir -p 3rdparty/react/promise/src
# individual core apps now bundle libs as well - yay
-#rm -r apps/search_lucene/3rdparty/Zend
-rm -r apps/files_external/3rdparty/{Dropbox,google-api-php-client,aws-sdk-php}
-
-# ===== BUNDLING NOTES =====
-
-## 3rdparty/patchwork - https://github.com/nicolas-grekas/Patchwork-UTF8
-# "patchwork/utf8": "~1.1"
-#
-# Used to set a UTF-8 locale (function isSetLocaleWorking does not
-# just test whether setlocale works, it actually asks Patchwork to
-# set a locale) and for its pure PHP implementation of the Normalizer
-# class otherwise found in php-intl. See lib/private/util.php
-# Patch from adamw to use php-intl's if available:
-# https://github.com/owncloud/core/pull/6620
-# We'd also have to set a UTF-8 locale some other way to entirely
-# replace OC's use of Patchwork.
-
-## 3rdparty/mcnetic/phpzipstreamer - https://github.com/McNetic/PHPZipStreamer
-# "mcnetic/phpzipstreamer": "dev-master"
-#
-# OC's copy is somewhat behind upstream, and slightly forked: they imported
-# it on 2014-02-20, and added a downstream patch to make it work with
-# PHP 5.3 on 2014-03-17:
-# https://github.com/owncloud/3rdparty/commit/da3c9f651a26cf076249ebf25c477e3791e69ca3
-# Upstream implemented a different fix against PHP 5.3 on 2014-03-14:
-# https://github.com/McNetic/PHPZipStreamer/commit/0af57cc0d113b27e44455be4be690908c4909d78
-# but OC has never synced with that fix. See:
-# https://github.com/owncloud/core/pull/3439
-
-## apps/files_external/3rdparty/smb4php - forked php class from
-# http://www.phpclasses.org/package/4129-PHP-Stream-wrapper-to-access-Windows-shared-files.html
-# Replaced by https://github.com/icewind1991/SMB post-8.0
-
-## 3rdparty/punic - https://github.com/punic/punic
-# "punic/punic": "1.1.0"
-#
-# Used in date localization: lib/private/l10n.php
-# Should be straightforward to unbundle
-
-# ===== END BUNDLING NOTES =====
+rm -rf apps/files_external/3rdparty/{icewind,Dropbox,google-api-php-client,aws-sdk-php}
# clean up content
for f in {l10n.pl,init.sh,setup_owncloud.sh,image-optimization.sh,install_dependencies.sh}; do
find . -name "$f" -exec rm {} \;
done
-find . -size 0 -exec rm {} \;
+find . -size 0 -type f -exec rm {} \;
# Drop pre-compiled binary lumps: Flash and Silverlight
# This means that Flash/Silverlight video/audio fallbacks in the
@@ -395,9 +403,11 @@ install -Dpm 644 %{SOURCE6} \
# symlink 3rdparty libs - if possible
# global
ln -s %{_datadir}/php/Assetic/functions.php %{buildroot}%{_datadir}/%{name}/3rdparty/kriswallsmith/assetic/src/functions.php
-ln -s %{_datadir}/pear/Crypt/Random.php %{buildroot}%{_datadir}/%{name}/3rdparty/phpseclib/phpseclib/phpseclib/Crypt/Random.php
ln -s %{_datadir}/php/natxet/CssMin/src/CssMin.php %{buildroot}%{_datadir}/%{name}/3rdparty/natxet/CssMin/src/
ln -s %{_datadir}/php/getid3/getid3.php %{buildroot}%{_datadir}/%{name}/3rdparty/james-heinrich/getid3/getid3/
+ln -s %{_datadir}/php/Swift/swift_required.php %{buildroot}%{_datadir}/%{name}/3rdparty/swiftmailer/swiftmailer/lib/swift_required.php
+ln -s %{_datadir}/php/password_compat/password.php %{buildroot}%{_datadir}/%{name}/3rdparty/ircmaxell/password-compat/lib/password.php
+ln -s %{_datadir}/php/React/Promise/functions_include.php %{buildroot}%{_datadir}/%{name}/3rdparty/react/promise/src/functions_include.php
%if 0%{?rhel} < 7
@@ -498,7 +508,19 @@ rm -rf %{buildroot}
%changelog
-* Mon Mar 21 2016 Remi Collet <remi@fedoraproject.org> - 8.1.6-1
+* Wed Mar 23 2016 Remi Collet <remi@fedoraproject.org> - 8.2.3-2
+- use php-swift-Swift 5.4 in /usr/share/php
+- fix patch to not update .htaccess
+- drop samba dependency on old EL
+
+* Tue Mar 22 2016 James Hogarth <james.hogarth@gmail.com> - 8.2.3-2
+- Add smbclient dependency so that shipped external storage works as expected
+- Add some data to the Fedora readme
+
+* Mon Mar 14 2016 James Hogarth <james.hogarth@gmail.com> - 8.2.3-1
+- new release 8.2.3
+
+* Mon Mar 14 2016 Remi Collet <remi@fedoraproject.org> - 8.1.6-1
- Update to 8.1.6
- fix autoloader to ensure sabre/vobject 3.4 is used