summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-21 12:52:45 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-21 12:52:45 +0100
commit5928fa18f796ff14148e465309e621576600e47a (patch)
treeb880fb6607b3e7ecd18f045fab46bc4f14f6d3e3
parentcf476b262715557a3dc523f9878b49fd15708705 (diff)
owncloud: 8.1.6
-rw-r--r--owncloud-8.1.5-autoloader_paths.patch3
-rw-r--r--owncloud-8.1.5-composer_includepath.patch3
-rw-r--r--owncloud.spec14
3 files changed, 11 insertions, 9 deletions
diff --git a/owncloud-8.1.5-autoloader_paths.patch b/owncloud-8.1.5-autoloader_paths.patch
index a43da08..e055c88 100644
--- a/owncloud-8.1.5-autoloader_paths.patch
+++ b/owncloud-8.1.5-autoloader_paths.patch
@@ -2,7 +2,7 @@ diff --git a/lib/base.php b/lib/base.php
index bb60273..0f4021d 100644
--- a/lib/base.php
+++ b/lib/base.php
-@@ -527,7 +527,10 @@ class OC {
+@@ -527,7 +527,9 @@ class OC {
if (!file_exists($vendorAutoLoad)) {
throw new \RuntimeException('Composer autoloader not found, unable to continue. Check the folder "3rdparty".');
}
@@ -10,7 +10,6 @@ index bb60273..0f4021d 100644
+ $loader = require_once $vendorAutoLoad;
+ $loader->add('Pimple', '/usr/share/php/Pimple');
+ $loader->add('Sabre', '/usr/share/php');
-+ $loader->add('Sabre\VObject', '/usr/share/pear');
} catch (\RuntimeException $e) {
OC_Response::setStatus(OC_Response::STATUS_SERVICE_UNAVAILABLE);
diff --git a/owncloud-8.1.5-composer_includepath.patch b/owncloud-8.1.5-composer_includepath.patch
index fb1966a..1f4e4d5 100644
--- a/owncloud-8.1.5-composer_includepath.patch
+++ b/owncloud-8.1.5-composer_includepath.patch
@@ -2,10 +2,9 @@ diff --git a/lib/base.php b/lib/base.php
index 0f4021d..431a1f3 100644
--- a/lib/base.php
+++ b/lib/base.php
-@@ -531,6 +531,7 @@ class OC {
+@@ -531,5 +531,6 @@ class OC {
$loader->add('Pimple', '/usr/share/php/Pimple');
$loader->add('Sabre', '/usr/share/php');
- $loader->add('Sabre\VObject', '/usr/share/pear');
+ $loader->setUseIncludePath(true);
} catch (\RuntimeException $e) {
diff --git a/owncloud.spec b/owncloud.spec
index 24373ab..a1dc22f 100644
--- a/owncloud.spec
+++ b/owncloud.spec
@@ -8,7 +8,7 @@
# Please preserve changelog entries
#
Name: owncloud
-Version: 8.1.5
+Version: 8.1.6
Release: 1%{?dist}
Summary: Private file sync and share server
Group: Applications/Internet
@@ -45,9 +45,8 @@ Source42: %{name}-delete-nonfree.sh
# 'plugins:["youtube","vimeo"]'
Patch1: %{name}-6.0.2-videoviewer_noplugins.patch
# Ugly way to deal with Pimple 1.x's lack of PSR-0 compliance. Also forces the
-# paths to Sabre deps: /usr/share/php for most of Sabre (to ensure php-sabre-dav
-# package, 1.8 version, is used), /usr/share/pear for Sabre\VObject (to ensure
-# php-sabredav-Sabre_VObject package, 2.1 version, is used). Please be careful
+# paths to Sabre deps: /usr/share/php for all of Sabre (to ensure php-sabre-dav
+# package, 2.1 version, is used). Please be careful
# and *test* if changing this; test with all versions of all Sabre packages
# installed to make sure it DTRT. Keep an eye on upstream for future changes
# also.
@@ -141,7 +140,8 @@ Requires: php-composer(ircmaxell/random-lib) >= 1.0.0
Requires: php-composer(natxet/CssMin) >= 3.0.2
## SabreDAV
-Requires: php-sabre-dav >= 2.1.5
+Requires: php-composer(sabre/dav) >= 2.1.6
+Requires: php-composer(sabre/dav) < 3
Requires: php-composer(sabre/event) >= 2.0
Requires: php-composer(sabre/event) < 3.0
Requires: php-composer(sabre/vobject) >= 3.3.4
@@ -498,6 +498,10 @@ rm -rf %{buildroot}
%changelog
+* Mon Mar 21 2016 Remi Collet <remi@fedoraproject.org> - 8.1.6-1
+- Update to 8.1.6
+- fix autoloader to ensure sabre/vobject 3.4 is used
+
* Sat Feb 20 2016 James Hogarth <james.hogarth@gmail.com> - 8.1.5-1
- Update to 8.1.5