summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-16 13:43:36 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-16 13:43:36 +0100
commitcf476b262715557a3dc523f9878b49fd15708705 (patch)
tree080577ebcf9a2fecf01d529228e1630d9a4c23e2
parentb15855909305e99fea24b4874827d8100f49cfef (diff)
owncloud 8.1.5 (backported from Fedora)
-rw-r--r--owncloud-7.0.3-opcache_invalidate.patch131
-rw-r--r--owncloud-8.0.1-autoloader_paths.patch14
-rw-r--r--owncloud-8.0.1-composer_includepath.patch10
-rw-r--r--owncloud-8.0.3-dont_update_htacess.patch37
-rw-r--r--owncloud-8.1.5-autoloader_paths.patch25
-rw-r--r--owncloud-8.1.5-composer_includepath.patch12
-rw-r--r--owncloud-8.1.5-dont_update_htacess.patch49
-rw-r--r--owncloud-8.1.5-drop-dropbox-autoloader.patch (renamed from owncloud-8.0.0-drop-dropbox-autoloader.patch)16
-rw-r--r--owncloud-8.1.5-google_autoload.patch (renamed from owncloud-8.0.4-google_autoload.patch)28
-rw-r--r--owncloud.spec52
10 files changed, 136 insertions, 238 deletions
diff --git a/owncloud-7.0.3-opcache_invalidate.patch b/owncloud-7.0.3-opcache_invalidate.patch
deleted file mode 100644
index e6360aa..0000000
--- a/owncloud-7.0.3-opcache_invalidate.patch
+++ /dev/null
@@ -1,131 +0,0 @@
-From 3b4823d89c03e54917ce6844dfbd227c8b4d6adc Mon Sep 17 00:00:00 2001
-From: Adam Williamson <awilliam@redhat.com>
-Date: Fri, 12 Sep 2014 23:33:18 -0700
-Subject: [PATCH 1/3] add function to invalidate one opcache file, use it if
- possible #9885
-
-Issue #9885 appears to be triggered by ownCloud invalidating the entire
-PHP opcache. Testing indicates it can be avoided by only invalidating the
-single file that was written from the opcache, instead of clearing the
-whole thing. In general it is more efficient to invalidate only the single
-file that was changed, rather than the whole cache.
-
-This adds a deleteFromOpcodeCache() function which invalidates a single
-file from the opcache if possible, returning true if the underlying
-function returns true (which may mean 'success', or 'file does not exist',
-or 'file exists but is not in opcache', all of which are OK to treat as
-good for our purposes). It also changes writeData() in config.php to try
-using deleteFromOpcodeCache() and only fall back on clearOpcodeCache() if
-that fails.
----
- lib/private/config.php | 7 +++++--
- lib/private/util.php | 25 +++++++++++++++++++++++++
- 2 files changed, 30 insertions(+), 2 deletions(-)
-
-diff --git a/lib/private/config.php b/lib/private/config.php
-index f054844..8bb2a5c 100644
---- a/lib/private/config.php
-+++ b/lib/private/config.php
-@@ -207,8 +207,11 @@ private function writeData() {
- flock($filePointer, LOCK_UN);
- fclose($filePointer);
-
-- // Clear the opcode cache
-- \OC_Util::clearOpcodeCache();
-+ // Try invalidating the opcache just for the file we wrote...
-+ if (!\OC_Util::deleteFromOpcodeCache($this->configFilename)) {
-+ // But if that doesn't work, clear the whole cache.
-+ \OC_Util::clearOpcodeCache();
-+ }
- }
- }
-
-diff --git a/lib/private/util.php b/lib/private/util.php
-index bee0a57..fa0c6f1 100644
---- a/lib/private/util.php
-+++ b/lib/private/util.php
-@@ -1250,6 +1250,31 @@ public static function getTheme() {
- }
-
- /**
-+ * Clear a single file from the opcode cache
-+ * This is useful for writing to the config file
-+ * in case the opcode cache does not re-validate files
-+ * Returns true if successful, false if unsuccessful:
-+ * caller should fall back on clearing the entire cache
-+ * with clearOpcodeCache() if unsuccessful
-+ *
-+ * @return bool true if underlying function returns true, otherwise false
-+ */
-+ public static function deleteFromOpcodeCache($path=NULL) {
-+ $ret = false;
-+ if ($path) {
-+ // APC >= 3.1.1
-+ if (function_exists('apc_delete_file')) {
-+ $ret = @apc_delete_file($path);
-+ }
-+ // Zend OpCache >= 7.0.0, PHP >= 5.5.0
-+ if (function_exists('opcache_invalidate')) {
-+ $ret = opcache_invalidate($path);
-+ }
-+ }
-+ return $ret;
-+ }
-+
-+ /**
- * Clear the opcode cache if one exists
- * This is necessary for writing to the config file
- * in case the opcode cache does not re-validate files
-
-From 8b2b0aae31fe084c3f8edbc6b307a39db03211c9 Mon Sep 17 00:00:00 2001
-From: Adam Williamson <awilliam@redhat.com>
-Date: Thu, 6 Nov 2014 18:05:20 -0800
-Subject: [PATCH 2/3] deleteFromOpcodeCache: make parameter mandatory, document
- parameter
-
-Both pointed out in submission review by @bantu, thanks.
----
- lib/private/util.php | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/lib/private/util.php b/lib/private/util.php
-index fa0c6f1..0e1bb34 100644
---- a/lib/private/util.php
-+++ b/lib/private/util.php
-@@ -1257,9 +1257,10 @@ public static function getTheme() {
- * caller should fall back on clearing the entire cache
- * with clearOpcodeCache() if unsuccessful
- *
-+ * @param string $path the path of the file to clear from the cache
- * @return bool true if underlying function returns true, otherwise false
- */
-- public static function deleteFromOpcodeCache($path=NULL) {
-+ public static function deleteFromOpcodeCache($path) {
- $ret = false;
- if ($path) {
- // APC >= 3.1.1
-
-From 013feb8da052e7d8f2e1171fb6600d82b3c3ac29 Mon Sep 17 00:00:00 2001
-From: Adam Williamson <awilliam@redhat.com>
-Date: Thu, 6 Nov 2014 18:10:43 -0800
-Subject: [PATCH 3/3] writeData(): correct variable name for config file path
-
-It changed since we wrote this patch.
----
- lib/private/config.php | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/lib/private/config.php b/lib/private/config.php
-index 8bb2a5c..3e7fef4 100644
---- a/lib/private/config.php
-+++ b/lib/private/config.php
-@@ -208,7 +208,7 @@ private function writeData() {
- fclose($filePointer);
-
- // Try invalidating the opcache just for the file we wrote...
-- if (!\OC_Util::deleteFromOpcodeCache($this->configFilename)) {
-+ if (!\OC_Util::deleteFromOpcodeCache($this->configFilePath)) {
- // But if that doesn't work, clear the whole cache.
- \OC_Util::clearOpcodeCache();
- }
-
diff --git a/owncloud-8.0.1-autoloader_paths.patch b/owncloud-8.0.1-autoloader_paths.patch
deleted file mode 100644
index bb471f8..0000000
--- a/owncloud-8.0.1-autoloader_paths.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- owncloud/lib/base.php 2014-07-29 00:27:51.154263240 -0700
-+++ owncloud/lib/base.php.new 2014-07-29 00:30:26.998084605 -0700
-@@ -475,7 +475,10 @@
- // setup 3rdparty autoloader
- $vendorAutoLoad = OC::$THIRDPARTYROOT . '/3rdparty/autoload.php';
- if (file_exists($vendorAutoLoad)) {
-- require_once $vendorAutoLoad;
-+ $loader = require_once $vendorAutoLoad;
-+ $loader->add('Pimple', '/usr/share/php/Pimple');
-+ $loader->add('Sabre', '/usr/share/php');
-+ $loader->add('Sabre\VObject', '/usr/share/pear');
- } else {
- OC_Response::setStatus(OC_Response::STATUS_SERVICE_UNAVAILABLE);
- // we can't use the template error page here, because this needs the
diff --git a/owncloud-8.0.1-composer_includepath.patch b/owncloud-8.0.1-composer_includepath.patch
deleted file mode 100644
index f7b3a56..0000000
--- a/owncloud-8.0.1-composer_includepath.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- owncloud/lib/base.php 2014-07-29 00:30:26.998084605 -0700
-+++ owncloud/lib/base.php.new 2014-07-29 00:35:08.579372364 -0700
-@@ -491,6 +491,7 @@
- $loader->add('Pimple', '/usr/share/php/Pimple');
- $loader->add('Sabre', '/usr/share/php');
- $loader->add('Sabre\VObject', '/usr/share/pear');
-+ $loader->setUseIncludePath(true);
- } else {
- OC_Response::setStatus(OC_Response::STATUS_SERVICE_UNAVAILABLE);
- // we can't use the template error page here, because this needs the
diff --git a/owncloud-8.0.3-dont_update_htacess.patch b/owncloud-8.0.3-dont_update_htacess.patch
deleted file mode 100644
index db34f90..0000000
--- a/owncloud-8.0.3-dont_update_htacess.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-diff --git a/lib/private/setup.php b/lib/private/setup.php
-index e3a29b6..7eeeb92 100644
---- a/lib/private/setup.php
-+++ b/lib/private/setup.php
-@@ -230,12 +230,6 @@ class OC_Setup {
- // out that this is indeed an ownCloud data directory
- file_put_contents(OC_Config::getValue('datadirectory', OC::$SERVERROOT.'/data').'/.ocdata', '');
-
-- // Update htaccess files for apache hosts
-- if (isset($_SERVER['SERVER_SOFTWARE']) && strstr($_SERVER['SERVER_SOFTWARE'], 'Apache')) {
-- self::updateHtaccess();
-- self::protectDataDirectory();
-- }
--
- //and we are done
- OC_Config::setValue('installed', true);
- }
-diff --git a/lib/private/updater.php b/lib/private/updater.php
-index 08731c7..2b722e3 100644
---- a/lib/private/updater.php
-+++ b/lib/private/updater.php
-@@ -202,15 +202,6 @@ class Updater extends BasicEmitter {
- throw new \Exception('Updates between multiple major versions are unsupported.');
- }
-
-- // Update htaccess files for apache hosts
-- if (isset($_SERVER['SERVER_SOFTWARE']) && strstr($_SERVER['SERVER_SOFTWARE'], 'Apache')) {
-- try {
-- \OC_Setup::updateHtaccess();
-- } catch (\Exception $e) {
-- throw new \Exception($e->getMessage());
-- }
-- }
--
- // create empty file in data dir, so we can later find
- // out that this is indeed an ownCloud data directory
- // (in case it didn't exist before)
diff --git a/owncloud-8.1.5-autoloader_paths.patch b/owncloud-8.1.5-autoloader_paths.patch
new file mode 100644
index 0000000..a43da08
--- /dev/null
+++ b/owncloud-8.1.5-autoloader_paths.patch
@@ -0,0 +1,25 @@
+diff --git a/lib/base.php b/lib/base.php
+index bb60273..0f4021d 100644
+--- a/lib/base.php
++++ b/lib/base.php
+@@ -527,7 +527,10 @@ class OC {
+ if (!file_exists($vendorAutoLoad)) {
+ throw new \RuntimeException('Composer autoloader not found, unable to continue. Check the folder "3rdparty".');
+ }
+- require_once $vendorAutoLoad;
++ $loader = require_once $vendorAutoLoad;
++ $loader->add('Pimple', '/usr/share/php/Pimple');
++ $loader->add('Sabre', '/usr/share/php');
++ $loader->add('Sabre\VObject', '/usr/share/pear');
+
+ } catch (\RuntimeException $e) {
+ OC_Response::setStatus(OC_Response::STATUS_SERVICE_UNAVAILABLE);
+@@ -656,7 +659,7 @@ class OC {
+ self::registerFilesystemHooks();
+ if (\OC::$server->getSystemConfig()->getValue('enable_previews', true)) {
+ self::registerPreviewHooks();
+- }
++ }
+ self::registerShareHooks();
+ self::registerLogRotate();
+ self::registerLocalAddressBook();
diff --git a/owncloud-8.1.5-composer_includepath.patch b/owncloud-8.1.5-composer_includepath.patch
new file mode 100644
index 0000000..fb1966a
--- /dev/null
+++ b/owncloud-8.1.5-composer_includepath.patch
@@ -0,0 +1,12 @@
+diff --git a/lib/base.php b/lib/base.php
+index 0f4021d..431a1f3 100644
+--- a/lib/base.php
++++ b/lib/base.php
+@@ -531,6 +531,7 @@ class OC {
+ $loader->add('Pimple', '/usr/share/php/Pimple');
+ $loader->add('Sabre', '/usr/share/php');
+ $loader->add('Sabre\VObject', '/usr/share/pear');
++ $loader->setUseIncludePath(true);
+
+ } catch (\RuntimeException $e) {
+ OC_Response::setStatus(OC_Response::STATUS_SERVICE_UNAVAILABLE);
diff --git a/owncloud-8.1.5-dont_update_htacess.patch b/owncloud-8.1.5-dont_update_htacess.patch
new file mode 100644
index 0000000..c62305c
--- /dev/null
+++ b/owncloud-8.1.5-dont_update_htacess.patch
@@ -0,0 +1,49 @@
+diff --git a/lib/private/setup.php b/lib/private/setup.php
+index 50bf0dc..d216675 100644
+--- a/lib/private/setup.php
++++ b/lib/private/setup.php
+@@ -350,12 +350,6 @@ class Setup {
+ // out that this is indeed an ownCloud data directory
+ file_put_contents($config->getSystemValue('datadirectory', \OC::$SERVERROOT.'/data').'/.ocdata', '');
+
+- // Update htaccess files for apache hosts
+- if (isset($_SERVER['SERVER_SOFTWARE']) && strstr($_SERVER['SERVER_SOFTWARE'], 'Apache')) {
+- self::updateHtaccess();
+- self::protectDataDirectory();
+- }
+-
+ //try to write logtimezone
+ if (date_default_timezone_get()) {
+ \OC_Config::setValue('logtimezone', date_default_timezone_get());
+diff --git a/lib/private/updater.php b/lib/private/updater.php
+index 8f4b81c..22a4861 100644
+--- a/lib/private/updater.php
++++ b/lib/private/updater.php
+@@ -54,10 +54,10 @@ class Updater extends BasicEmitter {
+
+ /** @var ILogger $log */
+ private $log;
+-
++
+ /** @var \OC\HTTPHelper $helper */
+ private $httpHelper;
+-
++
+ /** @var IConfig */
+ private $config;
+
+@@ -287,14 +287,6 @@ class Updater extends BasicEmitter {
+ throw new \Exception('Updates between multiple major versions and downgrades are unsupported.');
+ }
+
+- // Update .htaccess files
+- try {
+- Setup::updateHtaccess();
+- Setup::protectDataDirectory();
+- } catch (\Exception $e) {
+- throw new \Exception($e->getMessage());
+- }
+-
+ // FIXME: Some users do not upload the new ca-bundle.crt, let's catch this
+ // in the update. For a newer release we shall use an integrity check after
+ // the update.
diff --git a/owncloud-8.0.0-drop-dropbox-autoloader.patch b/owncloud-8.1.5-drop-dropbox-autoloader.patch
index 45acd2c..05d933b 100644
--- a/owncloud-8.0.0-drop-dropbox-autoloader.patch
+++ b/owncloud-8.1.5-drop-dropbox-autoloader.patch
@@ -1,20 +1,20 @@
diff --git a/apps/files_external/ajax/dropbox.php b/apps/files_external/ajax/dropbox.php
-index db417de..a752ca1 100644
+index 55dc417..fe834c0 100644
--- a/apps/files_external/ajax/dropbox.php
+++ b/apps/files_external/ajax/dropbox.php
-@@ -1,7 +1,5 @@
- <?php
-
+@@ -23,7 +23,6 @@
+ * along with this program. If not, see <http://www.gnu.org/licenses/>
+ *
+ */
-require_once __DIR__ . '/../3rdparty/Dropbox/autoload.php';
--
+
OCP\JSON::checkAppEnabled('files_external');
OCP\JSON::checkLoggedIn();
- OCP\JSON::callCheck();
diff --git a/apps/files_external/lib/dropbox.php b/apps/files_external/lib/dropbox.php
-index cc1e628..586efd6 100644
+index 78219f8..b332c0a 100644
--- a/apps/files_external/lib/dropbox.php
+++ b/apps/files_external/lib/dropbox.php
-@@ -22,8 +22,6 @@
+@@ -29,8 +29,6 @@
namespace OC\Files\Storage;
diff --git a/owncloud-8.0.4-google_autoload.patch b/owncloud-8.1.5-google_autoload.patch
index 9565bad..00aa63d 100644
--- a/owncloud-8.0.4-google_autoload.patch
+++ b/owncloud-8.1.5-google_autoload.patch
@@ -1,23 +1,27 @@
---- owncloud/apps/files_external/lib/google.php 2015-06-04 06:43:13.000000000 -0700
-+++ owncloud/apps/files_external/lib/google.php.new 2015-07-01 15:53:19.363382205 -0700
-@@ -23,8 +23,7 @@
-
+diff --git a/apps/files_external/ajax/google.php b/apps/files_external/ajax/google.php
+index e094367..8f2638b 100644
+--- a/apps/files_external/ajax/google.php
++++ b/apps/files_external/ajax/google.php
+@@ -26,7 +26,7 @@
+ */
set_include_path(get_include_path().PATH_SEPARATOR.
\OC_App::getAppPath('files_external').'/3rdparty/google-api-php-client/src');
-require_once 'Google/Client.php';
--require_once 'Google/Service/Drive.php';
+require_once 'Google/autoload.php';
- class Google extends \OC\Files\Storage\Common {
+ OCP\JSON::checkAppEnabled('files_external');
+ OCP\JSON::checkLoggedIn();
+diff --git a/apps/files_external/lib/google.php b/apps/files_external/lib/google.php
+index 8199d97..4bec351 100644
+--- a/apps/files_external/lib/google.php
++++ b/apps/files_external/lib/google.php
+@@ -34,8 +34,7 @@ namespace OC\Files\Storage;
---- owncloud/apps/files_external/ajax/google.php 2015-06-04 06:43:13.000000000 -0700
-+++ owncloud/apps/files_external/ajax/google.php.new 2015-07-01 15:53:28.051505933 -0700
-@@ -1,7 +1,7 @@
- <?php
set_include_path(get_include_path().PATH_SEPARATOR.
\OC_App::getAppPath('files_external').'/3rdparty/google-api-php-client/src');
-require_once 'Google/Client.php';
+-require_once 'Google/Service/Drive.php';
+require_once 'Google/autoload.php';
- OCP\JSON::checkAppEnabled('files_external');
- OCP\JSON::checkLoggedIn();
+ class Google extends \OC\Files\Storage\Common {
+
diff --git a/owncloud.spec b/owncloud.spec
index 470a683..24373ab 100644
--- a/owncloud.spec
+++ b/owncloud.spec
@@ -8,7 +8,7 @@
# Please preserve changelog entries
#
Name: owncloud
-Version: 8.0.10
+Version: 8.1.5
Release: 1%{?dist}
Summary: Private file sync and share server
Group: Applications/Internet
@@ -51,32 +51,29 @@ Patch1: %{name}-6.0.2-videoviewer_noplugins.patch
# and *test* if changing this; test with all versions of all Sabre packages
# installed to make sure it DTRT. Keep an eye on upstream for future changes
# also.
-Patch2: %{name}-8.0.1-autoloader_paths.patch
+Patch2: %{name}-8.1.5-autoloader_paths.patch
# Turn on include path usage for the Composer autoloader (so it'll find
# systemwide PSR-0 and PSR-4 compliant libraries)
# Upstream wouldn't likely take this, they probably only care about their
# bundled copies
-Patch3: %{name}-8.0.1-composer_includepath.patch
+Patch3: %{name}-8.1.5-composer_includepath.patch
# Drop use of dropbox's unnecessary autoloader (composer will find the
# systemwide copy). This is not upstreamable, but see
# https://github.com/owncloud/core/pull/12113 with similar effect for 8.1+
-Patch4: %{name}-8.0.0-drop-dropbox-autoloader.patch
-# Submitted upstream: https://github.com/owncloud/core/pull/11056
-# Be less heavy-handed about clearing the opcache after editing config.php
-# Avoids triggering a crash in php-opcache: https://github.com/owncloud/core/issues/9885
-Patch5: %{name}-7.0.3-opcache_invalidate.patch
+Patch4: %{name}-8.1.5-drop-dropbox-autoloader.patch
# Drop use of aws-sdk's dead autoloader (composer will find the systemwide copy)
Patch6: 0001-drop-AWS-autoloader.patch
# Disable JS minification (uses non-free JSMin minifier)
Patch7: owncloud-8.0.0-disable_minify.patch
# Stop OC from trying to do stuff to .htaccess files. Just calm down, OC.
# Distributors are on the case.
-Patch8: owncloud-8.0.3-dont_update_htacess.patch
+Patch8: owncloud-8.1.5-dont_update_htacess.patch
# Use Google autoloader instead of including particular files. Upstream
# no longer has each file include all others it needs, they expect you
# to use the autoloader. Can't go upstream until upstream bumps to a
# version of the lib that actually includes the autoloader...
-Patch9: owncloud-8.0.4-google_autoload.patch
+Patch9: owncloud-8.1.5-google_autoload.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -114,8 +111,6 @@ Requires: php-filter
Requires: php-composer(kriswallsmith/assetic) >= 1.2
Requires: php-composer(kriswallsmith/assetic) < 1.3
Requires: php-getid3
-# states 5.2.8 exactly, but will work with 5.2.9 or later
-Requires: php-composer(phpmailer/phpmailer)
# "pimple/pimple": "~3.0"
Requires: php-composer(pimple/pimple) >= 3.0
Requires: php-composer(pimple/pimple) < 4.0
@@ -146,11 +141,13 @@ Requires: php-composer(ircmaxell/random-lib) >= 1.0.0
Requires: php-composer(natxet/CssMin) >= 3.0.2
## SabreDAV
-#Requires: php-composer(sabre/dav) >= 1.8.0
-Requires: php-sabre-dav >= 1.8.0
-# OwnCloud uses vobject directly as well as dav, and it is not at all compatible
-# with 3.x; calendar 'rework' branch will fix this when it lands, probably 9.x
-Requires: php-pear(pear.sabredav.org/Sabre_VObject) >= 2.0.0
+Requires: php-sabre-dav >= 2.1.5
+Requires: php-composer(sabre/event) >= 2.0
+Requires: php-composer(sabre/event) < 3.0
+Requires: php-composer(sabre/vobject) >= 3.3.4
+Requires: php-composer(sabre/vobject) < 4.0
+Requires: php-composer(sabre/http) >= 3.0
+Requires: php-composer(sabre/http) < 4.0
## apps/files_external
Requires: php-pear(pear.dropbox-php.com/Dropbox)
@@ -254,14 +251,10 @@ work with an SQLite 3 database stored on the local system.
%prep
%setup -q -n %{name}
-# Fix line endings of a file we're about to patch
-sed -i 's/\r$//' apps/files_encryption/lib/crypt.php
-#patch1
%patch1 -p0
%patch2 -p1
%patch3 -p1
%patch4 -p1
-%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
@@ -274,7 +267,7 @@ cp %{SOURCE5} README.postgresql
# Strip bundled libraries from global 3rdparty dir
-rm -r 3rdparty/{bantu,doctrine,guzzle,ircmaxell/random-lib,ircmaxell/security-lib,james-heinrich,kriswallsmith,natxet,pear,phpmailer/phpmailer/*,phpseclib,pimple,rackspace,sabre,symfony}
+rm -r 3rdparty/{bantu,doctrine,guzzle,ircmaxell/random-lib,ircmaxell/security-lib,james-heinrich,kriswallsmith,natxet,pear,phpseclib,pimple,rackspace,sabre,symfony}
rm 3rdparty/{PEAR,PEAR5}.php
# we need to symlink some annoying files back here, though...direct file
# autoloading sucks. "files" sections of "autoload" statements in
@@ -378,12 +371,15 @@ for f in {*.php,*.xml,*.html,occ,robots.txt}; do
install -pm 644 "$f" %{buildroot}%{_datadir}/%{name}
done
-# set default config
-install -pm 644 %{SOURCE7} %{buildroot}%{_sysconfdir}/%{name}/config.php
-
# symlink config dir
ln -sf %{_sysconfdir}/%{name} %{buildroot}%{_datadir}/%{name}/config
+# Owncloud looks for ca-bundle.crt in config dir
+ln -sf %{_sysconfdir}/pki/tls/certs/ca-bundle.crt %{buildroot}%{_sysconfdir}/%{name}/ca-bundle.crt
+
+# set default config
+install -pm 644 %{SOURCE7} %{buildroot}%{_sysconfdir}/%{name}/config.php
+
# httpd config
install -Dpm 644 %{SOURCE1} \
%{buildroot}%{_sysconfdir}/httpd/conf.d/%{name}.conf
@@ -398,7 +394,6 @@ install -Dpm 644 %{SOURCE6} \
# symlink 3rdparty libs - if possible
# global
-ln -s %{_datadir}/php/PHPMailer/class.{phpmailer.php,pop3.php,smtp.php} %{buildroot}%{_datadir}/%{name}/3rdparty/phpmailer/phpmailer
ln -s %{_datadir}/php/Assetic/functions.php %{buildroot}%{_datadir}/%{name}/3rdparty/kriswallsmith/assetic/src/functions.php
ln -s %{_datadir}/pear/Crypt/Random.php %{buildroot}%{_datadir}/%{name}/3rdparty/phpseclib/phpseclib/phpseclib/Crypt/Random.php
ln -s %{_datadir}/php/natxet/CssMin/src/CssMin.php %{buildroot}%{_datadir}/%{name}/3rdparty/natxet/CssMin/src/
@@ -470,6 +465,8 @@ rm -rf %{buildroot}
%dir %attr(-,apache,apache) %{_sysconfdir}/%{name}
# contains sensitive data (dbpassword, passwordsalt)
%config(noreplace) %attr(0600,apache,apache) %{_sysconfdir}/%{name}/config.php
+# need the symlink in confdir but it's not config
+%{_sysconfdir}/%{name}/ca-bundle.crt
%{_datadir}/%{name}
%dir %attr(0755,apache,apache) %{_localstatedir}/lib/%{name}
@@ -501,6 +498,9 @@ rm -rf %{buildroot}
%changelog
+* Sat Feb 20 2016 James Hogarth <james.hogarth@gmail.com> - 8.1.5-1
+- Update to 8.1.5
+
* Mon Jan 11 2016 Adam Williamson <awilliam@redhat.com> - 8.0.10-1
- new release 8.0.10 (multiple security fixes)