summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-08-06 18:33:15 +0200
committerRemi Collet <fedora@famillecollet.com>2012-08-06 18:33:15 +0200
commite5c92796f54858e607f887731506c89c6e3f8be0 (patch)
tree42c64eda30d7ab86ab85f9fc0754f3d41abcc632
parent8d1f57980be9def79140b4b54b2f7077afb12c2e (diff)
mysql: sync with rawhide (no build)
-rw-r--r--mysql-cipherspec.patch63
-rw-r--r--mysql55.spec4
-rw-r--r--rh-skipped-tests-base.list7
3 files changed, 36 insertions, 38 deletions
diff --git a/mysql-cipherspec.patch b/mysql-cipherspec.patch
index 23d3cb0..18b8fee 100644
--- a/mysql-cipherspec.patch
+++ b/mysql-cipherspec.patch
@@ -4,8 +4,9 @@ This patch enhances connect command by an option to specify a cipher
and tests are adjusted to specify the expected cipher explicitly.
Upstream bug report: http://bugs.mysql.com/bug.php?id=64461
---- mysql-5.5.27/client/mysqltest.cc.orig 2012-07-20 19:38:02.000000000 +0200
-+++ mysql-5.5.27/client/mysqltest.cc 2012-08-03 08:33:01.256212903 +0200
+diff -Naur mysql-5.5.27.orig/client/mysqltest.cc mysql-5.5.27/client/mysqltest.cc
+--- mysql-5.5.27.orig/client/mysqltest.cc 2012-07-20 13:38:02.000000000 -0400
++++ mysql-5.5.27/client/mysqltest.cc 2012-08-05 01:01:21.502130550 -0400
@@ -5458,6 +5458,7 @@
my_bool con_ssl= 0, con_compress= 0;
my_bool con_pipe= 0, con_shm= 0, con_cleartext_enable= 0;
@@ -14,15 +15,15 @@ Upstream bug report: http://bugs.mysql.com/bug.php?id=64461
static DYNAMIC_STRING ds_connection_name;
static DYNAMIC_STRING ds_host;
-@@ -5546,6 +5547,8 @@
- con_pipe= 1;
- else if (!strncmp(con_options, "SHM", 3))
+@@ -5548,6 +5549,8 @@
con_shm= 1;
-+ else if (!strncmp(con_options, "CIPHER:", 7))
-+ con_cipher = con_options + 7;
else if (!strncmp(con_options, "CLEARTEXT", 9))
con_cleartext_enable= 1;
++ else if (!strncmp(con_options, "CIPHER:", 7))
++ con_cipher = con_options + 7;
else
+ die("Illegal option to connect: %.*s",
+ (int) (end - con_options), con_options);
@@ -5595,8 +5598,11 @@
if (con_ssl)
{
@@ -36,10 +37,10 @@ Upstream bug report: http://bugs.mysql.com/bug.php?id=64461
#if MYSQL_VERSION_ID >= 50000
/* Turn on ssl_verify_server_cert only if host is "localhost" */
opt_ssl_verify_server_cert= !strcmp(ds_host.str, "localhost");
-diff -up mysql-5.5.21/mysql-test/t/openssl_1.test.cipherspec mysql-5.5.21/mysql-test/t/openssl_1.test
---- mysql-5.5.21/mysql-test/t/openssl_1.test.cipherspec 2012-01-31 12:28:15.000000000 +0100
-+++ mysql-5.5.21/mysql-test/t/openssl_1.test 2012-03-09 14:59:52.305752562 +0100
-@@ -20,13 +20,13 @@ grant select on test.* to ssl_user4@loca
+diff -Naur mysql-5.5.27.orig/mysql-test/t/openssl_1.test mysql-5.5.27/mysql-test/t/openssl_1.test
+--- mysql-5.5.27.orig/mysql-test/t/openssl_1.test 2012-07-20 13:38:03.000000000 -0400
++++ mysql-5.5.27/mysql-test/t/openssl_1.test 2012-08-05 01:00:27.798822919 -0400
+@@ -20,13 +20,13 @@
grant select on test.* to ssl_user5@localhost require cipher "DHE-RSA-AES256-SHA" AND SUBJECT "xxx";
flush privileges;
@@ -58,7 +59,7 @@ diff -up mysql-5.5.21/mysql-test/t/openssl_1.test.cipherspec mysql-5.5.21/mysql-
connection con1;
# Check ssl turned on
-@@ -119,7 +119,7 @@ drop table t1;
+@@ -119,7 +119,7 @@
# verification of servers certificate by setting both ca certificate
# and ca path to NULL
#
@@ -67,7 +68,7 @@ diff -up mysql-5.5.21/mysql-test/t/openssl_1.test.cipherspec mysql-5.5.21/mysql-
--echo End of 5.0 tests
#
-@@ -244,7 +244,7 @@ select 'is still running; no cipher requ
+@@ -244,7 +244,7 @@
GRANT SELECT ON test.* TO bug42158@localhost REQUIRE X509;
FLUSH PRIVILEGES;
@@ -76,9 +77,21 @@ diff -up mysql-5.5.21/mysql-test/t/openssl_1.test.cipherspec mysql-5.5.21/mysql-
SHOW STATUS LIKE 'Ssl_cipher';
disconnect con1;
connection default;
-diff -up mysql-5.5.21/mysql-test/t/ssl_8k_key.test.cipherspec mysql-5.5.21/mysql-test/t/ssl_8k_key.test
---- mysql-5.5.21/mysql-test/t/ssl_8k_key.test.cipherspec 2012-01-31 12:28:15.000000000 +0100
-+++ mysql-5.5.21/mysql-test/t/ssl_8k_key.test 2012-03-09 14:38:37.084890702 +0100
+diff -Naur mysql-5.5.27.orig/mysql-test/t/ssl.test mysql-5.5.27/mysql-test/t/ssl.test
+--- mysql-5.5.27.orig/mysql-test/t/ssl.test 2012-07-20 13:38:03.000000000 -0400
++++ mysql-5.5.27/mysql-test/t/ssl.test 2012-08-05 01:00:27.800822919 -0400
+@@ -6,7 +6,7 @@
+ # Save the initial number of concurrent sessions
+ --source include/count_sessions.inc
+
+-connect (ssl_con,localhost,root,,,,,SSL);
++connect (ssl_con,localhost,root,,,,,SSL CIPHER:DHE-RSA-AES256-SHA);
+
+ # Check ssl turned on
+ SHOW STATUS LIKE 'Ssl_cipher';
+diff -Naur mysql-5.5.27.orig/mysql-test/t/ssl_8k_key.test mysql-5.5.27/mysql-test/t/ssl_8k_key.test
+--- mysql-5.5.27.orig/mysql-test/t/ssl_8k_key.test 2012-07-20 13:38:03.000000000 -0400
++++ mysql-5.5.27/mysql-test/t/ssl_8k_key.test 2012-08-05 01:00:27.799822918 -0400
@@ -2,7 +2,7 @@
#
# Bug#29784 YaSSL assertion failure when reading 8k key.
@@ -88,9 +101,9 @@ diff -up mysql-5.5.21/mysql-test/t/ssl_8k_key.test.cipherspec mysql-5.5.21/mysql
## This test file is for testing encrypted communication only, not other
## encryption routines that the SSL library happens to provide!
-diff -up mysql-5.5.21/mysql-test/t/ssl_compress.test.cipherspec mysql-5.5.21/mysql-test/t/ssl_compress.test
---- mysql-5.5.21/mysql-test/t/ssl_compress.test.cipherspec 2012-01-31 12:28:15.000000000 +0100
-+++ mysql-5.5.21/mysql-test/t/ssl_compress.test 2012-03-09 14:38:37.085890587 +0100
+diff -Naur mysql-5.5.27.orig/mysql-test/t/ssl_compress.test mysql-5.5.27/mysql-test/t/ssl_compress.test
+--- mysql-5.5.27.orig/mysql-test/t/ssl_compress.test 2012-07-20 13:38:03.000000000 -0400
++++ mysql-5.5.27/mysql-test/t/ssl_compress.test 2012-08-05 01:00:27.799822918 -0400
@@ -7,7 +7,7 @@
# Save the initial number of concurrent sessions
--source include/count_sessions.inc
@@ -100,15 +113,3 @@ diff -up mysql-5.5.21/mysql-test/t/ssl_compress.test.cipherspec mysql-5.5.21/mys
# Check ssl turned on
SHOW STATUS LIKE 'Ssl_cipher';
-diff -up mysql-5.5.21/mysql-test/t/ssl.test.cipherspec mysql-5.5.21/mysql-test/t/ssl.test
---- mysql-5.5.21/mysql-test/t/ssl.test.cipherspec 2012-01-31 12:28:15.000000000 +0100
-+++ mysql-5.5.21/mysql-test/t/ssl.test 2012-03-09 14:38:37.086890472 +0100
-@@ -6,7 +6,7 @@
- # Save the initial number of concurrent sessions
- --source include/count_sessions.inc
-
--connect (ssl_con,localhost,root,,,,,SSL);
-+connect (ssl_con,localhost,root,,,,,SSL CIPHER:DHE-RSA-AES256-SHA);
-
- # Check ssl turned on
- SHOW STATUS LIKE 'Ssl_cipher';
diff --git a/mysql55.spec b/mysql55.spec
index ec85cb4..1907d28 100644
--- a/mysql55.spec
+++ b/mysql55.spec
@@ -790,6 +790,10 @@ fi
%{_mandir}/man1/mysql_client_test.1*
%changelog
+* Sun Aug 5 2012 Tom Lane <tgl@redhat.com> 5.5.27-1
+- Update to MySQL 5.5.27, for various fixes described at
+ http://dev.mysql.com/doc/refman/5.5/en/news-5-5-27.html
+
* Fri Aug 03 2012 Remi Collet <RPMS@FamilleCollet.com> - 5.5.27-1
- update to MySQL 5.5.27 Community Server GA
http://dev.mysql.com/doc/refman/5.5/en/news-5-5-27.html
diff --git a/rh-skipped-tests-base.list b/rh-skipped-tests-base.list
index a855f78..8d92952 100644
--- a/rh-skipped-tests-base.list
+++ b/rh-skipped-tests-base.list
@@ -7,13 +7,6 @@
outfile_loaddata : bug#46895 code wrong, expected results wrong too
-# Disable sys_vars.plugin_dir_basic, which is broken because
-# mysql-test-run doesn't set the right value of MYSQL_LIBDIR.
-# Upstream at http://bugs.mysql.com/bug.php?id=52223
-# Still fails in 5.5.16, even though upstream marked it closed.
-
-sys_vars.plugin_dir_basic : bug#52223 fails for lib64 library directory
-
# Disable innodb.innodb, which is showing platform-dependent results
# as of 5.5.9. Upstream at http://bugs.mysql.com/bug.php?id=60155