summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-08-03 12:49:00 +0200
committerRemi Collet <fedora@famillecollet.com>2012-08-03 12:49:00 +0200
commit8d1f57980be9def79140b4b54b2f7077afb12c2e (patch)
treecde1162c1a2422f3d8c38c52d1812909b7438a1d
parentd81b273982dd282c51b0b3def0dd4310fb141554 (diff)
MySQL 5.5.27
-rw-r--r--mysql-cipherspec.patch17
-rw-r--r--mysql.5.5.27.spec (renamed from mysql.5.5.25a.spec)6
-rw-r--r--mysql55.spec28
3 files changed, 24 insertions, 27 deletions
diff --git a/mysql-cipherspec.patch b/mysql-cipherspec.patch
index b9180f2..23d3cb0 100644
--- a/mysql-cipherspec.patch
+++ b/mysql-cipherspec.patch
@@ -4,27 +4,26 @@ This patch enhances connect command by an option to specify a cipher
and tests are adjusted to specify the expected cipher explicitly.
Upstream bug report: http://bugs.mysql.com/bug.php?id=64461
-diff -up mysql-5.5.21/client/mysqltest.cc.cipherspec mysql-5.5.21/client/mysqltest.cc
---- mysql-5.5.21/client/mysqltest.cc.cipherspec 2012-01-31 12:28:16.000000000 +0100
-+++ mysql-5.5.21/client/mysqltest.cc 2012-03-09 14:38:37.083890817 +0100
-@@ -5458,6 +5458,7 @@ void do_connect(struct st_command *comma
+--- mysql-5.5.27/client/mysqltest.cc.orig 2012-07-20 19:38:02.000000000 +0200
++++ mysql-5.5.27/client/mysqltest.cc 2012-08-03 08:33:01.256212903 +0200
+@@ -5458,6 +5458,7 @@
my_bool con_ssl= 0, con_compress= 0;
- my_bool con_pipe= 0, con_shm= 0;
+ my_bool con_pipe= 0, con_shm= 0, con_cleartext_enable= 0;
struct st_connection* con_slot;
+ char *con_cipher=NULL;
static DYNAMIC_STRING ds_connection_name;
static DYNAMIC_STRING ds_host;
-@@ -5546,6 +5547,8 @@ void do_connect(struct st_command *comma
+@@ -5546,6 +5547,8 @@
con_pipe= 1;
else if (!strncmp(con_options, "SHM", 3))
con_shm= 1;
+ else if (!strncmp(con_options, "CIPHER:", 7))
+ con_cipher = con_options + 7;
+ else if (!strncmp(con_options, "CLEARTEXT", 9))
+ con_cleartext_enable= 1;
else
- die("Illegal option to connect: %.*s",
- (int) (end - con_options), con_options);
-@@ -5593,8 +5596,11 @@ void do_connect(struct st_command *comma
+@@ -5595,8 +5598,11 @@
if (con_ssl)
{
#if defined(HAVE_OPENSSL) && !defined(EMBEDDED_LIBRARY)
diff --git a/mysql.5.5.25a.spec b/mysql.5.5.27.spec
index 6bd976e..c47085f 100644
--- a/mysql.5.5.25a.spec
+++ b/mysql.5.5.27.spec
@@ -24,7 +24,7 @@
%define mysql_vendor_2 Sun Microsystems, Inc.
%define mysql_vendor Oracle and/or its affiliates
-%define mysql_version 5.5.25a
+%define mysql_version 5.5.27
%define mysqld_user mysql
%define mysqld_group mysql
@@ -176,7 +176,7 @@
%endif
%else
%if %(test -f /etc/SuSE-release && echo 1 || echo 0)
- %define susever %(rpm -qf --qf '%%{version}\\n' /etc/SuSE-release)
+ %define susever %(rpm -qf --qf '%%{version}\\n' /etc/SuSE-release | cut -d. -f1)
%if "%susever" == "10"
%define distro_description SUSE Linux Enterprise Server 10
%define distro_releasetag sles10
@@ -241,7 +241,7 @@
Name: MySQL%{product_suffix}
Summary: MySQL: a very fast and reliable SQL database server
Group: Applications/Databases
-Version: 5.5.25a
+Version: 5.5.27
Release: %{release}%{?distro_releasetag:.%{distro_releasetag}}
Distribution: %{distro_description}
License: Copyright (c) 2000, 2012, %{mysql_vendor}. All rights reserved. Under %{license_type} license as shown in the Description field.
diff --git a/mysql55.spec b/mysql55.spec
index d8cf1c7..ec85cb4 100644
--- a/mysql55.spec
+++ b/mysql55.spec
@@ -1,6 +1,6 @@
Name: mysql
-Version: 5.5.25a
-Release: 1%{?dist}.1
+Version: 5.5.27
+Release: 1%{?dist}
Summary: MySQL client programs and shared libraries
Group: Applications/Databases
@@ -66,7 +66,7 @@ Patch21: mysql-readline.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: gperf, perl, readline-devel, openssl-devel
BuildRequires: gcc-c++, cmake, ncurses-devel, zlib-devel, libaio-devel
-%if 0%{?fedora} >= 12
+%if 0%{?fedora} >= 12 || 0%{?rhel} >= 6
BuildRequires: systemtap-sdt-devel >= 1.3
%endif
# make test requires time and ps
@@ -76,8 +76,6 @@ BuildRequires: perl(Socket), perl(Time::HiRes)
%if 0%{?fedora} >= 15
BuildRequires: systemd-units
%endif
-# This is required old EL4
-BuildRequires: bison
Requires: grep, fileutils
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
@@ -233,10 +231,8 @@ rm -f Docs/mysql.info
%patch8 -p1
%patch10 -p1
%patch11 -p1
-%if 0%{?fedora} >= 9 || 0%{?rhel} >= 5
# When build with system openssl
%patch12 -p1
-%endif
%patch14 -p1
%patch15 -p1
%patch16 -p1
@@ -309,16 +305,12 @@ cmake . -DBUILD_CONFIG=mysql_release \
-DMYSQL_DATADIR="/var/lib/mysql" \
-DMYSQL_UNIX_ADDR="/var/lib/mysql/mysql.sock" \
-DENABLED_LOCAL_INFILE=ON \
-%if 0%{?fedora} >= 12
+%if 0%{?fedora} >= 12 || 0%{?rhel} >= 6
-DENABLE_DTRACE=ON \
%endif
-DWITH_EMBEDDED_SERVER=ON \
-DWITH_READLINE=ON \
-%if 0%{?fedora} >= 9 || 0%{?rhel} >= 5
-DWITH_SSL=system \
-%else
- -DWITH_SSL=bundled \
-%endif
-DWITH_ZLIB=system
gcc $CFLAGS $LDFLAGS -o scriptstub "-DLIBDIR=\"%{_libdir}/mysql\"" %{SOURCE4}
@@ -333,7 +325,7 @@ ar -x ../libmysqld.a
rm -f sql_binlog.cc.o rpl_utility.cc.o
gcc $CFLAGS $LDFLAGS -shared -Wl,-soname,libmysqld.so.0 -o libmysqld.so.0.0.1 \
*.o \
-%if 0%{?fedora} >= 12
+%if 0%{?fedora} >= 12 || 0%{?rhel} >= 6
../../probes_mysql.o \
%endif
-lpthread -laio -lcrypt -lssl -lcrypto -lz -lrt -lstdc++ -ldl -lm -lc
@@ -518,8 +510,8 @@ install -m 0644 mysql-test/rh-skipped-tests.list ${RPM_BUILD_ROOT}%{_datadir}/my
rm -rf $RPM_BUILD_ROOT
%pre libs
-echo -e "\nWARNING : This MySQL RPM is not an official Fedora/Redhat build and it"
-echo -e "overrides the official one. Don't file bugs on Fedora Project nor Redhat."
+echo -e "\nWARNING : This MySQL RPM is not an official Fedora / Red Hat build and it"
+echo -e "overrides the official one. Don't file bugs on Fedora Project nor Red Hat."
echo -e "Use dedicated forums http://forums.famillecollet.com/\n"
%if %{?fedora}%{!?fedora:99} <= 15
@@ -798,6 +790,12 @@ fi
%{_mandir}/man1/mysql_client_test.1*
%changelog
+* Fri Aug 03 2012 Remi Collet <RPMS@FamilleCollet.com> - 5.5.27-1
+- update to MySQL 5.5.27 Community Server GA
+ http://dev.mysql.com/doc/refman/5.5/en/news-5-5-27.html
+- enable dtrace on EL6
+- cleanup old stuff (EL4)
+
* Sat Jul 07 2012 Remi Collet <RPMS@FamilleCollet.com> - 5.5.25a-1.1
- sync with rawhide