summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-08-07 17:52:04 +0200
committerRemi Collet <fedora@famillecollet.com>2013-08-07 17:52:04 +0200
commit8f8678df6b7bc565ed104d1fd7cae0f9d5e19749 (patch)
tree315a4c29100b479ebde788c5be6624851cb92d1e
parent2059f1bfdd9a987068373065b7c86a83f4a13400 (diff)
Xulrunner / Firefox 23.0
-rw-r--r--mozilla-817533.patch32
-rw-r--r--mozilla-844883.patch17
-rw-r--r--mozilla-851850.patch31
-rw-r--r--xulrunner.spec51
4 files changed, 35 insertions, 96 deletions
diff --git a/mozilla-817533.patch b/mozilla-817533.patch
deleted file mode 100644
index 11d1bb7..0000000
--- a/mozilla-817533.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-# HG changeset patch
-# Parent d09a5a5666baa44c817a4e1e463ef62eae0a1105
-# User Patrick McManus <mcmanus@ducksong.com>
-bug 817533 - failed system proxy lookups should not fallback to manual configs r?jduell
-
-diff --git a/netwerk/base/src/nsProtocolProxyService.cpp b/netwerk/base/src/nsProtocolProxyService.cpp
---- a/netwerk/base/src/nsProtocolProxyService.cpp
-+++ b/netwerk/base/src/nsProtocolProxyService.cpp
-@@ -1553,17 +1553,22 @@ nsProtocolProxyService::Resolve_Internal
-
- // Proxy auto config magic...
- if (mProxyConfig == PROXYCONFIG_PAC || mProxyConfig == PROXYCONFIG_WPAD) {
- // Do not query PAC now.
- *usePACThread = true;
- return NS_OK;
- }
-
-- // proxy info values
-+ // If we aren't in manual proxy configuration mode then we don't
-+ // want to honor any manual specific prefs that might be still set
-+ if (mProxyConfig != PROXYCONFIG_MANUAL)
-+ return NS_OK;
-+
-+ // proxy info values for manual configuration mode
- const char *type = nullptr;
- const nsACString *host = nullptr;
- int32_t port = -1;
-
- uint32_t proxyFlags = 0;
-
- if ((flags & RESOLVE_PREFER_SOCKS_PROXY) &&
- !mSOCKSProxyHost.IsEmpty() && mSOCKSProxyPort > 0) {
diff --git a/mozilla-844883.patch b/mozilla-844883.patch
deleted file mode 100644
index 9298d7d..0000000
--- a/mozilla-844883.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-# HG changeset patch
-# Parent f8a3e008d03b538873a8d4f16fb97829f171517b
-# User Steve Singer <steve@ssinger.info>
-bug 844883 use a signed value for the stride
-
-diff -r f8a3e008d03b -r a298fedfda70 gfx/2d/Blur.cpp
---- a/gfx/2d/Blur.cpp Sun Mar 17 00:55:23 2013 -0400
-+++ b/gfx/2d/Blur.cpp Sun Mar 17 01:28:39 2013 -0400
-@@ -650,7 +650,7 @@
- return;
- }
-
-- uint32_t stride32bit = aIntegralImageStride / 4;
-+ int32_t stride32bit = aIntegralImageStride / 4;
-
- int32_t leftInflation = RoundUpToMultipleOf4(aLeftLobe).value();
-
diff --git a/mozilla-851850.patch b/mozilla-851850.patch
deleted file mode 100644
index 04260b9..0000000
--- a/mozilla-851850.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-
-# HG changeset patch
-# User Steve Singer <steve@ssinger.info>
-# Date 1363699875 14400
-# Node ID fe010206e5add13f4202113dcd74f54acb1e5b37
-# Parent 90c5dd3a2d1533ce2646a53c6ec84773e6f42d43
-Bug 851850 - Link in altivec on ppc64. r=jmuizelaar
-
-diff --git a/gfx/qcms/Makefile.in b/gfx/qcms/Makefile.in
---- a/gfx/qcms/Makefile.in
-+++ b/gfx/qcms/Makefile.in
-@@ -48,17 +48,17 @@ else
- endif
- else
- SSE1_FLAGS=
- SSE2_FLAGS=
- endif
- endif
- endif
- else
--ifeq (ppc,$(CPU_ARCH))
-+ifeq (ppc,$(findstring ppc,$(CPU_ARCH)))
- ifdef GNU_CC
- CSRCS += transform-altivec.c
- ALTIVEC_FLAGS=-maltivec
- endif
- endif
- endif
-
- FORCE_STATIC_LIB = 1
-
diff --git a/xulrunner.spec b/xulrunner.spec
index cd846b5..fd7080b 100644
--- a/xulrunner.spec
+++ b/xulrunner.spec
@@ -1,4 +1,4 @@
-%if 0%{?fedora} < 17
+%if 0%{?fedora} < 18
%define system_nss 0
%else
%define system_nss 1
@@ -13,8 +13,10 @@
# Use system sqlite?
%if 0%{?fedora} < 19
%define system_sqlite 0
+%define system_ffi 0
%else
%define system_sqlite 1
+%define system_ffi 1
%endif
# Use system libpeg (and libjpeg-turbo) ?
@@ -38,13 +40,13 @@
# grep 'min_ns.*=[0-9]' configure
%global nspr_version 4.9.6
%global nspr_build_version %((pkg-config --silence-errors --modversion nspr 2>/dev/null || echo 65536) | sed s/\.0\$//)
-%global nss_version 3.14.3
+%global nss_version 3.15
%global nss_build_version %((pkg-config --silence-errors --modversion nss 2>/dev/null || echo 65536) | sed s/\.0\$//)
%endif
%if %{?system_sqlite}
# grep '^SQLITE_VERSION' configure
-%global sqlite_version 3.7.15.2
+%global sqlite_version 3.7.16.1
# The actual sqlite version (see #480989):
%global sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo 65536)
%endif
@@ -87,8 +89,8 @@
Summary: XUL Runtime for Gecko Applications
Name: %{shortname}-last
-Version: 22.0
-Release: 2%{?pre_tag}%{?dist}
+Version: 23.0
+Release: 1%{?pre_tag}%{?dist}
URL: http://developer.mozilla.org/En/XULRunner
License: MPLv1.1 or GPLv2+ or LGPLv2+
Group: Applications/Internet
@@ -110,13 +112,10 @@ Patch19: xulrunner-21.0-s390-inlines.patch
# Fedora specific patches
Patch20: mozilla-193-pkgconfig.patch
Patch21: rhbz-911314.patch
-Patch23: mozilla-851850.patch
# Unable to install addons from https pages
Patch24: rhbz-966424.patch
# Upstream patches
-Patch104: mozilla-844883.patch
-Patch105: mozilla-817533.patch
Patch106: mozilla-831688.patch
# ---------------------------------------------------
@@ -166,14 +165,16 @@ Requires: nss >= %{nss_build_version}
%endif
Provides: gecko-libs = %{gecko_verrel}
Provides: gecko-libs%{?_isa} = %{gecko_verrel}
-Obsoletes: xulrunner15
-Obsoletes: xulrunner16
%if %{?system_sqlite}
BuildRequires: sqlite-devel >= %{sqlite_version}
Requires: sqlite >= %{sqlite_build_version}
%endif
+%if %{?system_ffi}
+BuildRequires: libffi-devel
+%endif
+
%description
XULRunner is a Mozilla runtime package that can be used to bootstrap XUL+XPCOM
applications that are as rich as Firefox and Thunderbird. It provides mechanisms
@@ -187,8 +188,6 @@ Group: Development/Libraries
Obsoletes: mozilla-devel < 1.9
Obsoletes: firefox-devel < 2.1
Obsoletes: xulrunner-devel-unstable
-Obsoletes: xulrunner15-devel
-Obsoletes: xulrunner16-devel
Provides: gecko-devel = %{gecko_verrel}
Provides: gecko-devel%{?_isa} = %{gecko_verrel}
Provides: gecko-devel-unstable = %{gecko_verrel}
@@ -282,12 +281,9 @@ cd %{tarballdir}
%patch20 -p2 -b .pk
%ifarch ppc ppc64
%patch21 -p2 -b .ppc
-%patch23 -p1 -b .851850
-%patch104 -p1 -b .844883
%endif
%patch24 -p1 -b .966424
-%patch105 -p1 -b .817533
%patch106 -p1 -b .831688
%{__rm} -f .mozconfig
@@ -324,6 +320,10 @@ echo "ac_add_options --enable-system-cairo" >> .mozconfig
echo "ac_add_options --disable-system-cairo" >> .mozconfig
%endif
+%if %{?system_ffi}
+echo "ac_add_options --enable-system-ffi" >> .mozconfig
+%endif
+
%if %{?debug_build}
echo "ac_add_options --enable-debug" >> .mozconfig
echo "ac_add_options --disable-optimize" >> .mozconfig
@@ -362,7 +362,7 @@ echo "ac_add_options --disable-polyic" >> .mozconfig
echo "ac_add_options --disable-tracejit" >> .mozconfig
%endif
-%ifnarch %{ix86} x86_64
+%ifnarch %{ix86} x86_64 armv7hl armv7hnl
echo "ac_add_options --disable-webrtc" >> .mozconfig
%endif
@@ -597,6 +597,25 @@ fi
#---------------------------------------------------------------------
%changelog
+* Wed Aug 7 2013 Remi Collet <RPMS@FamilleCollet.com> - 23.0-1
+- sync with rawhide, update to 23.0
+
+* Mon Aug 5 2013 Martin Stransky <stransky@redhat.com> - 23.0-2
+- Update to latest upstream (23.0 Build 2)
+
+* Mon Aug 5 2013 Martin Stransky <stransky@redhat.com> - 23.0-1
+- Update to latest upstream (23.0)
+
+* Mon Jul 29 2013 Jan Horak <jhorak@redhat.com> - 22.0-7
+- Use system libffi for Fedora 19+
+- Added fix for mozbz#860213
+
+* Thu Jul 25 2013 Martin Stransky <stransky@redhat.com> - 22.0-6
+- Removed already applied patches (rhbz#978123)
+
+* Wed Jul 24 2013 Peter Robinson <pbrobinson@fedoraproject.org> 22.0-5
+- Enable web-rtc on ARM now it's fixed upstream (RHBZ 886976)
+
* Tue Jul 2 2013 Remi Collet <RPMS@FamilleCollet.com> - 22.0-2
- sync with rawhide
- always disable crashreporter