summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-07-03 15:35:43 +0200
committerRemi Collet <fedora@famillecollet.com>2013-07-03 15:35:43 +0200
commit2059f1bfdd9a987068373065b7c86a83f4a13400 (patch)
tree7f4c9c2baf59ddd9726d98f14703191686e1db98
parent48c9fbc4181da5d6b61f056bd19a46a655e63fcd (diff)
Firefox: fix build
-rw-r--r--xulrunner.spec14
1 files changed, 11 insertions, 3 deletions
diff --git a/xulrunner.spec b/xulrunner.spec
index 54ae5c1..cd846b5 100644
--- a/xulrunner.spec
+++ b/xulrunner.spec
@@ -37,9 +37,9 @@
%if %{?system_nss}
# grep 'min_ns.*=[0-9]' configure
%global nspr_version 4.9.6
-%global nspr_build_version %(pkg-config --silence-errors --modversion nspr 2>/dev/null || echo 65536)
+%global nspr_build_version %((pkg-config --silence-errors --modversion nspr 2>/dev/null || echo 65536) | sed s/\.0\$//)
%global nss_version 3.14.3
-%global nss_build_version %(pkg-config --silence-errors --modversion nss 2>/dev/null || echo 65536)
+%global nss_build_version %((pkg-config --silence-errors --modversion nss 2>/dev/null || echo 65536) | sed s/\.0\$//)
%endif
%if %{?system_sqlite}
@@ -260,7 +260,15 @@ debug %{name}, you want to install %{name}-debuginfo instead.
#---------------------------------------------------------------------
%prep
-echo TARGET = %{name}-%{version}-%{release} GECKO = %{gecko_verrel}
+: "TARGET =" %{name}-%{version}-%{release}
+: "GECKO =" %{gecko_verrel}
+%if %{?system_nss}
+: "NSS =" %{nss_build_version}
+: "NSPR =" %{nspr_build_version}
+%endif
+%if %{?system_sqlite}
+: "SQLITE =" %{sqlite_build_version}
+%endif
%setup -q -c
cd %{tarballdir}