summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2010-08-06 18:36:51 +0200
committerRemi Collet <fedora@famillecollet.com>2010-08-06 18:36:51 +0200
commite0e372df300555da06481d4df2704fd883f74dec (patch)
tree63dfe7242fbcf64d1d54aefb1bdcea0f291a5366
parentb26d2c20e28e466550aac816be700c6ce6d77e70 (diff)
thunderbird 3.1.2
-rw-r--r--thunderbird-mozconfig2
-rw-r--r--thunderbird.spec17
-rwxr-xr-xthxpi85
3 files changed, 96 insertions, 8 deletions
diff --git a/thunderbird-mozconfig b/thunderbird-mozconfig
index c7334ff..6e51584 100644
--- a/thunderbird-mozconfig
+++ b/thunderbird-mozconfig
@@ -28,6 +28,8 @@ ac_add_options --enable-canvas
ac_add_options --enable-system-hunspell
ac_add_options --disable-crashreporter
ac_add_options --disable-necko-wifi
+ac_add_options --disable-updater
+
export BUILD_OFFICIAL=1
export MOZILLA_OFFICIAL=1
diff --git a/thunderbird.spec b/thunderbird.spec
index 0cb0269..a312290 100644
--- a/thunderbird.spec
+++ b/thunderbird.spec
@@ -26,7 +26,7 @@
Summary: Mozilla Thunderbird mail/newsgroup client
Name: thunderbird
-Version: 3.1.1
+Version: 3.1.2
Release: 1%{?dist}
URL: http://www.mozilla.org/projects/thunderbird/
License: MPLv1.1 or GPLv2+ or LGPLv2+
@@ -41,7 +41,7 @@ Source0: %{tarball}
#NoSource: 0
%if %{build_langpacks}
# Language package archive is build by RH
-Source1: thunderbird-langpacks-%{version}%{?relcan}-20100721.tar.bz2
+Source1: thunderbird-langpacks-%{version}%{?relcan}-20100806.tar.bz2
%endif
# Config file for compilation
Source10: thunderbird-mozconfig
@@ -262,8 +262,6 @@ DESTDIR=$RPM_BUILD_ROOT make install
# install icons
cd -
-%{__cp} other-licenses/branding/%{name}/mailicon16.png \
- $RPM_BUILD_ROOT/%{mozappdir}/icons/
%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
%{__cp} other-licenses/branding/%{name}/mailicon16.png \
$RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
@@ -446,7 +444,6 @@ fi
%{mozappdir}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
%dir %{mozappdir}/langpacks
%{mozappdir}/greprefs
-%{mozappdir}/icons
%{mozappdir}/isp
%{mozappdir}/mozilla-xremote-client
%{mozappdir}/open-browser.sh
@@ -454,7 +451,6 @@ fi
%{mozappdir}/run-mozilla.sh
%{mozappdir}/thunderbird-bin
%{mozappdir}/thunderbird
-%{mozappdir}/updater
%{mozappdir}/*.so
%dir %{mozappdir}/modules
%{mozappdir}/modules/*.jsm
@@ -465,10 +461,8 @@ fi
%{mozappdir}/modules/activity/*.js
%{mozappdir}/README.txt
%{mozappdir}/platform.ini
-%{mozappdir}/updater.ini
%{mozappdir}/application.ini
%exclude %{mozappdir}/removed-files
-%{mozappdir}/update.locale
%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
@@ -484,6 +478,13 @@ fi
#===============================================================================
%changelog
+* Fri Aug 06 2010 Remi Collet <rpms@famillecollet.com> 3.1.2-1
+- Thunderbird 3.1.1
+
+* Fri Aug 6 2010 Jan Horak <jhorak@redhat.com> - 3.1.2-1
+- Update to 3.1.2
+- Disable updater
+
* Wed Jul 21 2010 Remi Collet <rpms@famillecollet.com> 3.1.1-1
- Thunderbird 3.1.1
diff --git a/thxpi b/thxpi
new file mode 100755
index 0000000..903fb36
--- /dev/null
+++ b/thxpi
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+getxpi() {
+ if [ x$1 = x ]
+ then
+ echo "ERREUR : Numero de version absent !"
+ else
+ if [ x$2 = x ]
+ then URL=http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/$1/linux-i686/xpi
+ else URL=http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/$1-candidates/$2/linux-xpi
+ fi
+ # 52 extensions (13 + 13 + 13 + 13)
+ for i in af ar be bg bn-BD ca cs da de el en-GB es-AR \
+ es-ES et eu fi fr fy-NL ga-IE gl he hu id is it \
+ ja ka ko lt mk nb-NO nl nn-NO pa-IN pl pt-BR pt-PT ro \
+ ru si sk sl sq sr sv-SE ta-LK tr uk vi zh-CN zh-TW
+ do echo -en "$i\t"
+ #wget -nv $URL/$i.xpi
+ [ -f $i.xpi ] && echo "already downloaded"
+ [ -f $i.xpi ] || wget -nv $URL/$i.xpi -O $i.xpi
+ find . -size 0 -exec rm -f {} \;
+ done
+ fi
+}
+
+checkxpi() {
+ [ -d tmp ] && rm -rf tmp/* || mkdir tmp
+
+ for i in *.xpi
+ do j=$(basename $i .xpi)
+ unzip -q $i -d tmp/$j
+ done
+
+ xmlwf tmp/*/install.rdf && echo xmlwf OK.
+}
+packxpi() {
+ if [ x$1 = x ]
+ then
+ echo "ERREUR : langue absente !"
+ elif [ ! -d tmp/$1 ]
+ then
+ echo "ERREUR : langue $1 absente !"
+ else
+ echo Création de $1.xpi
+ mv $1.xpi /tmp
+ cd tmp/$1
+ zip ../../$1.xpi install.rdf chrome/* chrome.manifest defaults/pref/all-l10n.js dictionaries/*
+ fi
+}
+donexpi() {
+ if [ x$1 = x ]
+ then
+ echo "ERREUR : Numero de version absent !"
+ else
+ echo "Création de /home/rpmbuild/SPECS/remirepo/thunderbird/thunderbird-langpacks-$1-$(date +%Y%m%d).tar.bz2"
+ tar cvjf /home/rpmbuild/SPECS/remirepo/thunderbird/thunderbird-langpacks-$1-$(date +%Y%m%d).tar.bz2 \
+ --exclude tmp -C /tmp thunderbird-langpacks
+ fi
+}
+case "$1" in
+dir) dir=/tmp/thunderbird-langpacks
+ if [ -d $dir ]
+ then
+ echo $dir exists
+ else
+ mkdir $dir && echo $dir created
+ fi
+ ;;
+get) getxpi $2 $3
+ ;;
+check) checkxpi
+ ;;
+pack) packxpi $2
+ ;;
+done) donexpi $2
+ ;;
+*) echo -e "\nusage $0 action\n"
+ echo -e "\t dir"
+ echo -e "\t get version [ rc# ]"
+ echo -e "\t check"
+ echo -e "\t pack langue"
+ echo -e "\t done version"
+ echo ""
+ ;;
+esac