summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2010-07-22 08:36:36 +0200
committerRemi Collet <fedora@famillecollet.com>2010-07-22 08:36:36 +0200
commitb26d2c20e28e466550aac816be700c6ce6d77e70 (patch)
tree442f52b15eda00a023bc710598cbc1617797a6a5
parente52fb77abf3a9ccec08399ae6ce98fa19c8e7473 (diff)
thunderbird: sync patches
-rw-r--r--remove-static.patch11
-rw-r--r--thunderbird.spec5
-rw-r--r--xulrunner-missing-headers.patch11
3 files changed, 27 insertions, 0 deletions
diff --git a/remove-static.patch b/remove-static.patch
new file mode 100644
index 0000000..9cc94fb
--- /dev/null
+++ b/remove-static.patch
@@ -0,0 +1,11 @@
+diff -up comm-1.9.2/mozilla/toolkit/crashreporter/google-breakpad/src/tools/linux/dump_syms/Makefile.in.static comm-1.9.2/mozilla/toolkit/crashreporter/google-breakpad/src/tools/linux/dump_syms/Makefile.in
+--- comm-1.9.2/mozilla/toolkit/crashreporter/google-breakpad/src/tools/linux/dump_syms/Makefile.in.static 2010-06-23 19:47:11.000000000 +0200
++++ comm-1.9.2/mozilla/toolkit/crashreporter/google-breakpad/src/tools/linux/dump_syms/Makefile.in 2010-07-12 15:51:41.000000000 +0200
+@@ -64,6 +64,6 @@ FORCE_USE_PIC = 1
+
+ #XXX: bug 554854 causes us to be unable to run binaries on the build slaves
+ # due to them having an older libstdc++
+-HOST_LDFLAGS += -static
++#HOST_LDFLAGS += -static
+
+ include $(topsrcdir)/config/rules.mk
diff --git a/thunderbird.spec b/thunderbird.spec
index 9552bdb..0cb0269 100644
--- a/thunderbird.spec
+++ b/thunderbird.spec
@@ -68,6 +68,9 @@ Patch1: mozilla-jemalloc.patch
Patch2: thunderbird-shared-error.patch
# Fixes gcc complain that nsFrame::delete is protected
Patch4: xulrunner-1.9.2.1-build.patch
+# Fix missing includes for crash reporter, remove in 3.1 final
+Patch5: xulrunner-missing-headers.patch
+Patch6: remove-static.patch
%if %{official_branding}
# Required by Mozilla Corporation
@@ -154,6 +157,8 @@ sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
%patch1 -p0 -b .jemalloc
%patch2 -p1 -b .shared-error
%patch4 -p1 -b .protected
+%patch5 -p0 -b .stat
+%patch6 -p1 -b .static
%if %{official_branding}
diff --git a/xulrunner-missing-headers.patch b/xulrunner-missing-headers.patch
new file mode 100644
index 0000000..946c35c
--- /dev/null
+++ b/xulrunner-missing-headers.patch
@@ -0,0 +1,11 @@
+diff -up mozilla/toolkit/crashreporter/google-breakpad/src/common/linux/file_id.cc.stat mozilla/toolkit/crashreporter/google-breakpad/src/common/linux/file_id.cc
+--- mozilla/toolkit/crashreporter/google-breakpad/src/common/linux/file_id.cc.stat 2010-06-16 15:12:57.000000000 +0200
++++ mozilla/toolkit/crashreporter/google-breakpad/src/common/linux/file_id.cc 2010-06-16 15:13:02.000000000 +0200
+@@ -42,6 +42,7 @@
+ #include <link.h>
+ #include <string.h>
+ #include <sys/mman.h>
++#include <sys/stat.h>
+ #include <unistd.h>
+
+ #include <algorithm>