summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2011-07-17 12:29:45 +0200
committerRemi Collet <fedora@famillecollet.com>2011-07-17 12:29:45 +0200
commitb7a0413466410197d8906f01f5c286e499872a36 (patch)
tree735a7b0ab3ab110ca4dcea1dee92ebc3850363c5
parent939b6d748353db69f9760f8f4d6a4a0e64621f66 (diff)
thunderbird: don't unzip the langpacks
-rw-r--r--thunderbird.sh.in4
-rw-r--r--thunderbird.spec21
2 files changed, 16 insertions, 9 deletions
diff --git a/thunderbird.sh.in b/thunderbird.sh.in
index cf8d3ec..c787869 100644
--- a/thunderbird.sh.in
+++ b/thunderbird.sh.in
@@ -101,8 +101,8 @@ if [ $MOZILLA_DOWN -ne 0 ]; then
function create_langpack_link() {
local language=$*
- local langpack=langpack-${language}@thunderbird.mozilla.org
- if [ -f $MOZ_LANGPACKS_DIR/$langpack/chrome.manifest ]; then
+ local langpack=langpack-${language}@thunderbird.mozilla.org.xpi
+ if [ -f $MOZ_LANGPACKS_DIR/$langpack ]; then
rm -rf $MOZ_EXTENSIONS_PROFILE_DIR/$langpack
ln -s $MOZ_LANGPACKS_DIR/$langpack \
$MOZ_EXTENSIONS_PROFILE_DIR/$langpack
diff --git a/thunderbird.spec b/thunderbird.spec
index 2550df1..c683a78 100644
--- a/thunderbird.spec
+++ b/thunderbird.spec
@@ -26,7 +26,7 @@
Summary: Mozilla Thunderbird mail/newsgroup client
Name: thunderbird
Version: 5.0
-Release: 1%{?dist}
+Release: 1%{?dist}.1
URL: http://www.mozilla.org/projects/thunderbird/
License: MPLv1.1 or GPLv2+ or LGPLv2+
Group: Applications/Internet
@@ -316,14 +316,18 @@ touch %{name}.lang
%{__tar} xjf %{SOURCE1}
for langpack in `ls thunderbird-langpacks/*.xpi`; do
language=`basename $langpack .xpi`
- extensiondir=$RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-$language@thunderbird.mozilla.org
- %{__mkdir_p} $extensiondir
- unzip -q $langpack -d $extensiondir
- find $extensiondir -type f | xargs chmod 644
+ extensionID=langpack-$language@thunderbird.mozilla.org
+
+# extensiondir=$RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-$language@thunderbird.mozilla.org
+# %{__mkdir_p} $extensiondir
+# unzip -q $langpack -d $extensiondir
+# find $extensiondir -type f | xargs chmod 644
language=`echo $language | sed -e 's/-/_/g'`
- extensiondir=`echo $extensiondir | sed -e "s,^$RPM_BUILD_ROOT,,"`
- echo "%%lang($language) $extensiondir" >> %{name}.lang
+# extensiondir=`echo $extensiondir | sed -e "s,^$RPM_BUILD_ROOT,,"`
+# echo "%%lang($language) $extensiondir" >> %{name}.lang
+ %{__install} -m 644 ${langpack} $RPM_BUILD_ROOT%{mozappdir}/langpacks/${extensionID}.xpi
+ echo "%%lang($language) %{mozappdir}/langpacks/${extensionID}.xpi" >> %{name}.lang
done
%{__rm} -rf thunderbird-langpacks
%endif # build_langpacks
@@ -453,6 +457,9 @@ fi
#===============================================================================
%changelog
+* Sun Jul 17 2011 Remi Collet <rpms@famillecollet.com> 5.0-1.1
+- don't unzip the langpacks
+
* Sun Jul 17 2011 Remi Collet <rpms@famillecollet.com> 5.0-1
- Thunderbird 5.0, sync with rawhide