summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2011-07-17 11:47:57 +0200
committerRemi Collet <fedora@famillecollet.com>2011-07-17 11:47:57 +0200
commit939b6d748353db69f9760f8f4d6a4a0e64621f66 (patch)
tree7a5d5704bd4ae1f91c6d7589aaad9cbb85a92fe6
parent248f51e340777275a31848ee7a0759803e871419 (diff)
thunderbird 5.0, sync with rawhide
-rw-r--r--mozilla-jemalloc.patch47
-rw-r--r--mozilla-libjpeg-turbo.patch54
-rw-r--r--thunderbird-default.patch34
-rw-r--r--thunderbird-mozconfig2
-rw-r--r--thunderbird.spec79
-rw-r--r--xulrunner-1.9.2.1-build.patch16
-rw-r--r--xulrunner-2.0-os2cc.patch21
7 files changed, 26 insertions, 227 deletions
diff --git a/mozilla-jemalloc.patch b/mozilla-jemalloc.patch
deleted file mode 100644
index ed255c0..0000000
--- a/mozilla-jemalloc.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-# HG changeset patch
-# User Takanori MATSUURA <t.matsuu@gmail.com>
-# Date 1267955626 -3600
-# Node ID 7a2802932585e73f9fc817497b1d323f820d8fc9
-# Parent c2630edd612be6e301616c5219327560ea3955f5
-Bug 526389 - Skip redefinition of memory allocation functions for MacOS X and Linux. r=jasone
-
-diff --git mozilla/memory/jemalloc/jemalloc.h mozilla/memory/jemalloc/jemalloc.h
---- mozilla/memory/jemalloc/jemalloc.h
-+++ mozilla/memory/jemalloc/jemalloc.h
-@@ -74,26 +74,31 @@ typedef struct {
- * Current memory usage statistics.
- */
- size_t mapped; /* Bytes mapped (not necessarily committed). */
- size_t committed; /* Bytes committed (readable/writable). */
- size_t allocated; /* Bytes allocted (in use by application). */
- size_t dirty; /* Bytes dirty (committed unused pages). */
- } jemalloc_stats_t;
-
--#ifndef MOZ_MEMORY_DARWIN
-+/* Darwin and Linux already have memory allocation functions */
-+#if (!defined(MOZ_MEMORY_DARWIN) && !defined(MOZ_MEMORY_LINUX))
- void *malloc(size_t size);
- void *valloc(size_t size);
- void *calloc(size_t num, size_t size);
- void *realloc(void *ptr, size_t size);
- void free(void *ptr);
--#endif
-+int posix_memalign(void **memptr, size_t alignment, size_t size);
-+#endif /* MOZ_MEMORY_DARWIN, MOZ_MEMORY_LINUX */
-
--int posix_memalign(void **memptr, size_t alignment, size_t size);
-+/* Linux has memalign */
-+#if !defined(MOZ_MEMORY_LINUX)
- void *memalign(size_t alignment, size_t size);
-+#endif /* MOZ_MEMORY_LINUX */
-+
- size_t malloc_usable_size(const void *ptr);
- void jemalloc_stats(jemalloc_stats_t *stats);
-
- #ifdef __cplusplus
- } /* extern "C" */
- #endif
-
- #endif /* _JEMALLOC_H_ */
-
-
diff --git a/mozilla-libjpeg-turbo.patch b/mozilla-libjpeg-turbo.patch
deleted file mode 100644
index 43783de..0000000
--- a/mozilla-libjpeg-turbo.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-diff -up xulrunner-1.9.2.7/mozilla-1.9.2/modules/libpr0n/decoders/jpeg/nsJPEGDecoder.cpp.old xulrunner-1.9.2.7/mozilla-1.9.2/modules/libpr0n/decoders/jpeg/nsJPEGDecoder.cpp
---- xulrunner-1.9.2.7/mozilla/modules/libpr0n/decoders/jpeg/nsJPEGDecoder.cpp.old 2010-07-13 21:10:28.000000000 +0200
-+++ xulrunner-1.9.2.7/mozilla/modules/libpr0n/decoders/jpeg/nsJPEGDecoder.cpp 2010-07-22 12:33:21.000000000 +0200
-@@ -57,19 +57,6 @@
-
- extern "C" {
- #include "iccjpeg.h"
--
--/* Colorspace conversion (copied from jpegint.h) */
--struct jpeg_color_deconverter {
-- JMETHOD(void, start_pass, (j_decompress_ptr cinfo));
-- JMETHOD(void, color_convert, (j_decompress_ptr cinfo,
-- JSAMPIMAGE input_buf, JDIMENSION input_row,
-- JSAMPARRAY output_buf, int num_rows));
--};
--
--METHODDEF(void)
--ycc_rgb_convert_argb (j_decompress_ptr cinfo,
-- JSAMPIMAGE input_buf, JDIMENSION input_row,
-- JSAMPARRAY output_buf, int num_rows);
- }
-
- NS_IMPL_ISUPPORTS1(nsJPEGDecoder, imgIDecoder)
-@@ -514,14 +501,6 @@ nsresult nsJPEGDecoder::ProcessData(cons
- return NS_OK; /* I/O suspension */
- }
-
-- /* Force to use our YCbCr to Packed RGB converter when possible */
-- if (!mTransform && (gfxPlatform::GetCMSMode() == eCMSMode_Off) &&
-- mInfo.jpeg_color_space == JCS_YCbCr && mInfo.out_color_space == JCS_RGB) {
-- /* Special case for the most common case: transform from YCbCr direct into packed ARGB */
-- mInfo.out_color_components = 4; /* Packed ARGB pixels are always 4 bytes...*/
-- mInfo.cconvert->color_convert = ycc_rgb_convert_argb;
-- }
--
- /* If this is a progressive JPEG ... */
- mState = mInfo.buffered_image ? JPEG_DECOMPRESS_PROGRESSIVE : JPEG_DECOMPRESS_SEQUENTIAL;
- }
-@@ -678,15 +657,6 @@ nsJPEGDecoder::OutputScanlines(PRBool* s
- PRUint32 *imageRow = ((PRUint32*)mImageData) +
- (mInfo.output_scanline * mInfo.output_width);
-
-- if (mInfo.cconvert->color_convert == ycc_rgb_convert_argb) {
-- /* Special case: scanline will be directly converted into packed ARGB */
-- if (jpeg_read_scanlines(&mInfo, (JSAMPARRAY)&imageRow, 1) != 1) {
-- *suspend = PR_TRUE; /* suspend */
-- break;
-- }
-- continue; /* all done for this row! */
-- }
--
- JSAMPROW sampleRow = (JSAMPROW)imageRow;
- if (mInfo.output_components == 3) {
- /* Put the pixels at end of row to enable in-place expansion */
diff --git a/thunderbird-default.patch b/thunderbird-default.patch
deleted file mode 100644
index 7ab2104..0000000
--- a/thunderbird-default.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-diff -up comm-1.9.2/mozilla/browser/components/shell/src/nsGNOMEShellService.cpp.default comm-1.9.2/mozilla/browser/components/shell/src/nsGNOMEShellService.cpp
---- comm-1.9.2/mozilla/browser/components/shell/src/nsGNOMEShellService.cpp.default 2010-12-07 08:35:33.000000000 -0800
-+++ comm-1.9.2/mozilla/browser/components/shell/src/nsGNOMEShellService.cpp 2011-02-07 17:32:42.866343508 -0800
-@@ -104,8 +104,6 @@ static const char kDesktopColorKey[] = D
- nsresult
- nsGNOMEShellService::Init()
- {
-- nsresult rv;
--
- // GConf and GnomeVFS _must_ be available, or we do not allow
- // CreateInstance to succeed.
-
-@@ -120,19 +118,9 @@ nsGNOMEShellService::Init()
- // the locale encoding. If it's not set, they use UTF-8.
- mUseLocaleFilenames = PR_GetEnv("G_BROKEN_FILENAMES") != nsnull;
-
-- nsCOMPtr<nsIProperties> dirSvc
-- (do_GetService("@mozilla.org/file/directory_service;1"));
-- NS_ENSURE_TRUE(dirSvc, NS_ERROR_NOT_AVAILABLE);
--
-- nsCOMPtr<nsILocalFile> appPath;
-- rv = dirSvc->Get(NS_XPCOM_CURRENT_PROCESS_DIR, NS_GET_IID(nsILocalFile),
-- getter_AddRefs(appPath));
-- NS_ENSURE_SUCCESS(rv, rv);
-+ mAppPath.Assign(NS_LITERAL_CSTRING(MOZ_APP_NAME));
-
-- rv = appPath->AppendNative(NS_LITERAL_CSTRING(MOZ_APP_NAME));
-- NS_ENSURE_SUCCESS(rv, rv);
--
-- return appPath->GetNativePath(mAppPath);
-+ return NS_OK;
- }
-
- NS_IMPL_ISUPPORTS1(nsGNOMEShellService, nsIShellService)
diff --git a/thunderbird-mozconfig b/thunderbird-mozconfig
index 6b5fc85..6745396 100644
--- a/thunderbird-mozconfig
+++ b/thunderbird-mozconfig
@@ -29,7 +29,7 @@ ac_add_options --enable-system-hunspell
ac_add_options --disable-crashreporter
ac_add_options --disable-necko-wifi
ac_add_options --disable-updater
-ac_add_options --enable-static
+#ac_add_options --enable-static
ac_add_options --enable-startup-notification
export BUILD_OFFICIAL=1
diff --git a/thunderbird.spec b/thunderbird.spec
index e1994a2..2550df1 100644
--- a/thunderbird.spec
+++ b/thunderbird.spec
@@ -14,22 +14,18 @@
# IMPORTANT: If there is no top level directory, this should be
# set to the cwd, ie: '.'
#%define tarballdir .
-%define tarballdir comm-1.9.2
+%define tarballdir comm-miramar
%define official_branding 1
-# enable crash reporter only for iX86
-%ifarch %{ix86} x86_64
-%define enable_mozilla_crashreporter 1
-%else
+# don't enable crash reporter for remi repo
%define enable_mozilla_crashreporter 0
-%endif
-%define version_internal 3.1
+%define version_internal 5.0
%define mozappdir %{_libdir}/%{name}-%{version_internal}
Summary: Mozilla Thunderbird mail/newsgroup client
Name: thunderbird
-Version: 3.1.11
+Version: 5.0
Release: 1%{?dist}
URL: http://www.mozilla.org/projects/thunderbird/
License: MPLv1.1 or GPLv2+ or LGPLv2+
@@ -41,7 +37,7 @@ Group: Applications/Internet
%endif
Source0: %{tarball}
%if %{build_langpacks}
-Source1: thunderbird-langpacks-%{version}-20110625.tar.bz2
+Source1: thunderbird-langpacks-%{version}-20110717.tar.bz2
%endif
Source10: thunderbird-mozconfig
@@ -54,14 +50,8 @@ Source100: find-external-requires
# Mozilla (XULRunner) patches
Patch0: thunderbird-version.patch
-Patch1: thunderbird-default.patch
-Patch2: mozilla-jemalloc.patch
-Patch3: xulrunner-1.9.2.1-build.patch
-Patch4: mozilla-libjpeg-turbo.patch
-Patch5: mozilla-missing-cflags.patch
Patch6: mozilla-build-s390.patch
Patch7: crashreporter-remove-static.patch
-Patch9: xulrunner-2.0-os2cc.patch
%if %{official_branding}
# Required by Mozilla Corporation
@@ -109,6 +99,8 @@ BuildRequires: alsa-lib-devel
BuildRequires: autoconf213
BuildRequires: desktop-file-utils
BuildRequires: libcurl-devel
+BuildRequires: yasm
+BuildRequires: mesa-libGL-devel
BuildRequires: GConf2-devel
Requires: mozilla-filesystem
@@ -174,18 +166,10 @@ sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
# Mozilla (XULRunner) patches
cd mozilla
-%patch1 -p2 -b .default-application
-%patch2 -p1 -b .jemalloc
-%patch3 -p2 -b .protected
-%if %{fedora} >= 14
-%patch4 -p2 -b .turbo
-%endif
-%patch5 -p2 -b .mozcflags
%ifarch s390
%patch6 -p1 -b .s390
%endif
%patch7 -p2 -b .static
-%patch9 -p1 -b .os2cc
cd ..
%if %{official_branding}
@@ -298,8 +282,6 @@ done
desktop-file-install --vendor mozilla \
--dir $RPM_BUILD_ROOT%{_datadir}/applications \
- --add-category Network \
- --add-category Email \
../%{name}.desktop
@@ -336,23 +318,9 @@ for langpack in `ls thunderbird-langpacks/*.xpi`; do
language=`basename $langpack .xpi`
extensiondir=$RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-$language@thunderbird.mozilla.org
%{__mkdir_p} $extensiondir
- unzip $langpack -d $extensiondir
+ unzip -q $langpack -d $extensiondir
find $extensiondir -type f | xargs chmod 644
-
- tmpdir=`mktemp -d %{name}.XXXXXXXX`
- langtmp=$tmpdir/%{name}/langpack-$language
- %{__mkdir_p} $langtmp
- jarfile=$extensiondir/chrome/$language.jar
- unzip $jarfile -d $langtmp
-
- find $langtmp -type f | xargs chmod 644
- %{__rm} -rf $jarfile
- cd $langtmp
- zip -r -D $jarfile locale
- %{__rm} -rf locale
- cd -
- %{__rm} -rf $tmpdir
-
+
language=`echo $language | sed -e 's/-/_/g'`
extensiondir=`echo $extensiondir | sed -e "s,^$RPM_BUILD_ROOT,,"`
echo "%%lang($language) $extensiondir" >> %{name}.lang
@@ -444,10 +412,11 @@ fi
%dir %{mozappdir}/components
%ghost %{mozappdir}/components/compreg.dat
%ghost %{mozappdir}/components/xpti.dat
-%{mozappdir}/components/components.list
-%{mozappdir}/components/*.so
-%{mozappdir}/components/*.xpt
-%attr(644,root,root) %{mozappdir}/components/*.js
+%{mozappdir}/components/binary.manifest
+%{mozappdir}/components/libdbusservice.so
+%{mozappdir}/components/libmozgnome.so
+%{mozappdir}/omni.jar
+%{mozappdir}/plugin-container
%{mozappdir}/defaults
%{mozappdir}/dictionaries
%dir %{mozappdir}/extensions
@@ -456,18 +425,10 @@ fi
%{mozappdir}/greprefs
%{mozappdir}/isp
%{mozappdir}/mozilla-xremote-client
-%{mozappdir}/res
%{mozappdir}/run-mozilla.sh
%{mozappdir}/thunderbird-bin
%{mozappdir}/thunderbird
%{mozappdir}/*.so
-%dir %{mozappdir}/modules
-%{mozappdir}/modules/*.jsm
-%{mozappdir}/modules/*.js
-%dir %{mozappdir}/modules/gloda
-%{mozappdir}/modules/gloda/*.js
-%dir %{mozappdir}/modules/activity
-%{mozappdir}/modules/activity/*.js
%{mozappdir}/README.txt
%{mozappdir}/platform.ini
%{mozappdir}/application.ini
@@ -484,12 +445,22 @@ fi
%{mozappdir}/crashreporter.ini
%{mozappdir}/Throbber-small.gif
%endif
+%exclude %{_datadir}/idl/%{name}-%{version_internal}
+%exclude %{_includedir}/%{name}-%{version_internal}
+%exclude %{_libdir}/%{name}-devel-%{version_internal}
+%{mozappdir}/chrome.manifest
#===============================================================================
%changelog
+* Sun Jul 17 2011 Remi Collet <rpms@famillecollet.com> 5.0-1
+- Thunderbird 5.0, sync with rawhide
+
+* Tue Jun 28 2011 Jan Horak <jhorak@redhat.com> - 5.0-1
+- Update to 5.0
+
* Sat Jun 25 2011 Remi Collet <rpms@famillecollet.com> 3.1.11-1
-- Thunderbird 3.1.10
+- Thunderbird 3.1.11
* Tue Jun 21 2011 Jan Horak <jhorak@redhat.com> - 3.1.11-1
- Update to 3.1.11
diff --git a/xulrunner-1.9.2.1-build.patch b/xulrunner-1.9.2.1-build.patch
deleted file mode 100644
index 1d32a0c..0000000
--- a/xulrunner-1.9.2.1-build.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-XXX FIXME
-GCC complains that nsFrame::delete is protected
-..but this really needs to get solved a better way...
-
-diff -up xulrunner-1.9.2.1/mozilla-1.9.2/layout/generic/nsFrame.h.old xulrunner-1.9.2.1/mozilla-1.9.2/layout/generic/nsFrame.h
---- xulrunner-1.9.2.1/mozilla/layout/generic/nsFrame.h.old 2009-11-11 15:34:51.000000000 +0100
-+++ xulrunner-1.9.2.1/mozilla/layout/generic/nsFrame.h 2009-11-11 15:33:09.000000000 +0100
-@@ -157,7 +157,7 @@ private:
- // Left undefined; nsFrame objects are never allocated from the heap.
- void* operator new(size_t sz) CPP_THROW_NEW;
-
--protected:
-+public:
- // Overridden to prevent the global delete from being called, since
- // the memory came out of an arena instead of the heap.
- //
diff --git a/xulrunner-2.0-os2cc.patch b/xulrunner-2.0-os2cc.patch
deleted file mode 100644
index 3aa5286..0000000
--- a/xulrunner-2.0-os2cc.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-https://bugzilla.mozilla.org/show_bug.cgi?id=628252
-
-diff -r b5ee327bf536 gfx/ots/src/os2.cc
---- a/gfx/ots/src/os2.cc Fri Jan 28 19:59:59 2011 +0100
-+++ b/gfx/ots/src/os2.cc Sat Jan 29 10:56:30 2011 -0800
-@@ -1,12 +1,14 @@
- // Copyright (c) 2009 The Chromium Authors. All rights reserved.
- // Use of this source code is governed by a BSD-style license that can be
- // found in the LICENSE file.
-
-+#include <cstddef>
-+
- #include "os2.h"
-
- #include "head.h"
-
- // OS/2 - OS/2 and Windows Metrics
- // http://www.microsoft.com/opentype/otspec/os2.htm
-
- namespace ots {
-