summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2011-12-21 21:48:13 +0100
committerRemi Collet <fedora@famillecollet.com>2011-12-21 21:48:13 +0100
commitac3de9e33f4455a532b4ee59d5d6e57511052827 (patch)
tree9369152c426cd5d305d34cc104e7bd9faf08a49d
parentc9055b53bbb5556abebd5487b7037478e77e9261 (diff)
Lightning 1.1rc1HEADmaster
-rwxr-xr-xmklangsource.sh12
-rw-r--r--mozilla-670719.patch53
-rw-r--r--thunderbird-lightning.spec89
-rw-r--r--thunderbird-mozconfig2
-rw-r--r--xulrunner-6.0-secondary-ipc.patch60
-rw-r--r--xulrunner-9.0-secondary-ipc.patch60
6 files changed, 113 insertions, 163 deletions
diff --git a/mklangsource.sh b/mklangsource.sh
index 437add2..4a97b7f 100755
--- a/mklangsource.sh
+++ b/mklangsource.sh
@@ -1,20 +1,20 @@
#!/bin/bash
# This checks out and builds the language sources. The lightning source needs
# to already be unpacked
-locales=$PWD/thunderbird-lightning-1.0/comm-beta/calendar/locales/shipped-locales
+locales=$PWD/thunderbird-lightning-1.1/comm-beta/calendar/locales/shipped-locales
if [ ! -f $locale ]
then
echo "ERROR: missing $locales, try fedpkg prep first"
exit 1
fi
-rm -rf l10n-miramar
-mkdir l10n-miramar
-cd l10n-miramar
+rm -rf l10n
+mkdir l10n
+cd l10n
for lang in $(<$locales)
do
- hg clone http://hg.mozilla.org/releases/l10n-miramar/$lang
+ hg clone http://hg.mozilla.org/releases/l10n/mozilla-aurora/$lang
done
# Tar up, minus the mercurial files
cd ..
-tar cjf l10n-miramar.tar.bz2 --exclude='.hg*' l10n-miramar
+tar caf l10n.tar.xz --exclude='.hg*' l10n
diff --git a/mozilla-670719.patch b/mozilla-670719.patch
deleted file mode 100644
index afae907..0000000
--- a/mozilla-670719.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-# HG changeset patch
-# User Mike Hommey <mh+mozilla@glandium.org>
-# Date 1313846520 -7200
-# Node ID fdc3b63938f5a76d99c1e2bb12fd448465debc94
-# Parent 07a5a618ebe3f67b23100ceb1b51e92bb79be0cd
-Bug 670719 - Only add -DENABLE_JIT=1 to CXXFLAGS if any of trace/method/yarr jit is enabled.
-
-diff --git a/js/src/Makefile.in b/js/src/Makefile.in
---- a/js/src/Makefile.in
-+++ b/js/src/Makefile.in
-@@ -433,16 +433,19 @@ CPPSRCS += \
- YarrPattern.cpp \
- YarrSyntaxChecker.cpp \
- $(NULL)
- else
-
- ###############################################
- # BEGIN include sources for the Nitro assembler
- #
-+
-+ENABLE_YARR_JIT = 1
-+
- VPATH += $(srcdir)/assembler \
- $(srcdir)/assembler/wtf \
- $(srcdir)/assembler/jit \
- $(srcdir)/assembler/assembler \
- $(srcdir)/methodjit \
- $(srcdir)/yarr \
- $(NONE)
-
-@@ -1070,17 +1073,21 @@ endif
-
- ###############################################
- # BEGIN kludges for the Nitro assembler
- #
-
- # Needed to "configure" it correctly. Unfortunately these
- # flags wind up being applied to all code in js/src, not just
- # the code in js/src/assembler.
--CXXFLAGS += -DUSE_SYSTEM_MALLOC=1 -DENABLE_ASSEMBLER=1 -DENABLE_JIT=1
-+CXXFLAGS += -DUSE_SYSTEM_MALLOC=1 -DENABLE_ASSEMBLER=1
-+
-+ifneq (,$(ENABLE_YARR_JIT)$(ENABLE_TRACEJIT)$(ENABLE_METHODJIT))
-+CXXFLAGS += -DENABLE_JIT=1
-+endif
-
- INCLUDES += -I$(srcdir)/assembler -I$(srcdir)/yarr
-
- ifdef ENABLE_METHODJIT
- # Build a standalone test program that exercises the assembler
- # sources a bit.
- TESTMAIN_OBJS = \
- Assertions.$(OBJ_SUFFIX) \
diff --git a/thunderbird-lightning.spec b/thunderbird-lightning.spec
index 708cc9a..c5edf5c 100644
--- a/thunderbird-lightning.spec
+++ b/thunderbird-lightning.spec
@@ -1,18 +1,16 @@
-%define build_langpacks 1
%global nspr_version 4.8.8
-%global nss_version 3.12.10
+%global nss_version 3.13.1
%global cairo_version 1.10.0
%global freetype_version 2.1.9
%global lcms_version 1.19
-%global sqlite_version 3.6.22
+%global sqlite_version 3.7.7.1
%global libnotify_version 0.4
-# Update these two as a pair
-%global thunderbird_version 8.0
-%global thunderbird_next_version 9.0
-%global lightprever rc2
+# Update these two as a pair - see calendar/lightning/install.rdf
+%global thunderbird_version 9.0
+%global thunderbird_next_version 10.0
# Compatible versions are listed in:
-# comm-beta/calendar/lightning/install.rdf
-# comm-beta/calendar/providers/gdata/install.rdf
+# comm-release/calendar/lightning/install.rdf.rej
+# comm-release/calendar/providers/gdata/install.rdf.rej
%global moz_objdir objdir-tb
%global lightning_extname %{_libdir}/mozilla/extensions/{3550f703-e582-4d05-9a08-453d09bdfdc6}/{e2fda1a4-762b-4020-b5ad-a41df1933103}
%global gdata_extname %{_libdir}/mozilla/extensions/{3550f703-e582-4d05-9a08-453d09bdfdc6}/{a62ef8ec-5fdc-40c2-873c-223b8a6925cc}
@@ -25,42 +23,42 @@
#define tarballdir .
%global tarballdir comm-beta
+%global version_internal 5
%global mozappdir %{_libdir}/%{name}
+# Remi specific for check
+#global lightprever rc1
Name: thunderbird-lightning
Summary: The calendar extension to Thunderbird
-Version: 1.0
-Release: 0.52.%{lightprever}%{?dist}
+Version: 1.1
+Release: 0.1.rc1%{?dist}
URL: http://www.mozilla.org/projects/calendar/lightning/
License: MPLv1.1 or GPLv2+ or LGPLv2+
Group: Applications/Productivity
#Someday lightning will produce a release we can use
-Source0: http://releases.mozilla.org/pub/mozilla.org/calendar/lightning/releases/1.0rc2/source/lightning-1.0rc2.source.tar.bz2
+Source0: https://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/1.1-candidates/build1/source/lightning-1.1.source.tar.bz2
+#Source0: http://releases.mozilla.org/pub/mozilla.org/calendar/lightning/releases/1.0/source/lightning-1.0.source.tar.bz2
#Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{thunderbird_version}/source/thunderbird-%{thunderbird_version}.source.tar.bz2
# This script will generate the language source below
Source1: mklangsource.sh
-%if %{build_langpacks}
-Source2: l10n-miramar.tar.bz2
-%endif
+Source2: l10n.tar.bz2
# Config file for compilation
Source10: thunderbird-mozconfig
# Finds requirements provided outside of the current file set
Source100: find-external-requires
-
# Mozilla (XULRunner) patches
Patch0: thunderbird-install-dir.patch
# Fix build on secondary arches (patches copied from xulrunner)
-Patch2: xulrunner-6.0-secondary-ipc.patch
-Patch3: mozilla-670719.patch
+Patch2: xulrunner-9.0-secondary-ipc.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-%if 0%{?fedora} >= 14
+%if 0%{?fedora} >= 14 || 0%{?rhel} >= 6
BuildRequires: nspr-devel >= %{nspr_version}
-BuildRequires: nss-devel >= %{nss_version}
%endif
-%if 0%{?fedora} > 15
+%if 0%{?fedora} >= 17
+BuildRequires: nss-devel >= %{nss_version}
BuildRequires: nss-static
%endif
%if 0%{?fedora} >= 15
@@ -84,8 +82,7 @@ BuildRequires: freetype-devel >= %{freetype_version}
BuildRequires: libXt-devel
BuildRequires: libXrender-devel
BuildRequires: hunspell-devel
-%if 0%{?fedora} >= 15
-# Need SQLITE_SECURE_DELETE option
+%if 0%{?fedora} >= 16
BuildRequires: sqlite-devel >= %{sqlite_version}
%endif
BuildRequires: startup-notification-devel
@@ -115,17 +112,13 @@ calendaring tasks.
%prep
echo TARGET = %{name}-%{version}-%{release}
-%if %{build_langpacks}
%setup -q -c -a 2
-%else
-%setup -q -c
-%endif
cd %{tarballdir}
lightprever=$(cat calendar/sunbird/config/version.txt)
-if [ "$lightprever" != "%{version}%{lightprever}" ]; then
- echo Bad version, detected=$lightprever, expected=%{version}%{lightprever}
+if [ "$lightprever" != "%{version}%{?lightprever}" ]; then
+ echo Bad version, detected=$lightprever, expected=%{version}%{?lightprever}
exit 1
fi
@@ -133,31 +126,30 @@ fi
# Mozilla (XULRunner) patches
cd mozilla
%patch2 -p2 -b .secondary-ipc
-%patch3 -p1 -b .moz670719
cd ..
%{__rm} -f .mozconfig
#{__cp} %{SOURCE10} .mozconfig
cat %{SOURCE10} \
-%if 0%{?fedora} < 15 && 0%{?rhel} <= 6
+%if 0%{?fedora} < 16
| grep -v system-sqlite \
%endif
-%if 0%{?fedora} < 14 && 0%{?rhel} <= 6
+%if 0%{?fedora} < 17
| grep -v system-nss \
+%endif
+%if 0%{?fedora} < 14 && 0%{?rhel} < 6
| grep -v system-nspr \
%endif
-%if 0%{?fedora} < 15 && 0%{?rhel} <= 6
+%if 0%{?fedora} < 15
| grep -v enable-system-cairo \
%endif
| tee .mozconfig
cat <<EOF | tee -a .mozconfig
-#ac_add_options --enable-libnotify
-#ac_add_options --enable-system-lcms
-%if 0%{?fedora} >= 15
+%if 0%{?fedora} >= 16
#ac_add_options --enable-system-sqlite
%endif
-%if 0%{?fedora} < 14 && 0%{?rhel} <= 6
+%if 0%{?fedora} < 14
ac_add_options --disable-libjpeg-turbo
%endif
EOF
@@ -200,14 +192,14 @@ export MAKE="gmake %{moz_make_flags}"
make -f client.mk build STRIP=/bin/true
# Package l10n files
-%if %{build_langpacks}
cd objdir-tb/calendar/lightning
make AB_CD=all L10N_XPI_NAME=lightning-all repack-clobber-all
grep -v 'osx' ../../../calendar/locales/shipped-locales | while read lang x
do
+ #Skip eu local for now
+ [ "$lang" = eu ] && continue
make AB_CD=all L10N_XPI_NAME=lightning-all libs-$lang
done
-%endif
#===============================================================================
@@ -222,11 +214,7 @@ mkdir -p $RPM_BUILD_ROOT%{gdata_extname}
touch $RPM_BUILD_ROOT%{gdata_extname}/chrome.manifest
# Lightning and GData provider for it
-%if %{build_langpacks}
unzip -qod $RPM_BUILD_ROOT%{lightning_extname} objdir-tb/mozilla/dist/xpi-stage/lightning-all.xpi
-%else
-unzip -qod $RPM_BUILD_ROOT%{lightning_extname} objdir-tb/mozilla/dist/xpi-stage/lightning.xpi
-%endif
unzip -qod $RPM_BUILD_ROOT%{gdata_extname} objdir-tb/mozilla/dist/xpi-stage/gdata-provider.xpi
# Fix up permissions
@@ -248,6 +236,21 @@ find $RPM_BUILD_ROOT -name \*.so | xargs chmod 0755
#===============================================================================
%changelog
+* Wed Dec 21 2011 Remi Collet <rpms@famillecollet.com> 1.1-0.1.rc1
+- Update to lightning 1.1 rc1, sync with rawhide
+
+* Tue Dec 20 2011 Orion Poplawski <orion@cora.nwra.com> - 1.1-0.1.rc1
+- Update to lightning 1.1 rc1
+- Update l10n source
+- Skip eu locale for now
+
+* Tue Dec 20 2011 Jan Horak <jhorak@redhat.com> - 1.0-2
+- Rebuild due to Thunderbird 9.0
+
+* Mon Nov 14 2011 Orion Poplawski <orion@cora.nwra.com> - 1.0-1
+- Update to lightning 1.0
+- Update l10n source
+
* Sat Nov 12 2011 Remi Collet <rpms@famillecollet.com> 1.0-0.52.rc2
- Use lightning 1.0rc2 source for TB 8, sync with rawhide
diff --git a/thunderbird-mozconfig b/thunderbird-mozconfig
index ba80d63..b61a679 100644
--- a/thunderbird-mozconfig
+++ b/thunderbird-mozconfig
@@ -30,7 +30,7 @@ ac_add_options --enable-system-hunspell
ac_add_options --disable-crashreporter
ac_add_options --disable-necko-wifi
ac_add_options --disable-updater
-ac_add_options --with-l10n-base=../../l10n-miramar
+ac_add_options --with-l10n-base=../../l10n
export BUILD_OFFICIAL=1
export MOZILLA_OFFICIAL=1
diff --git a/xulrunner-6.0-secondary-ipc.patch b/xulrunner-6.0-secondary-ipc.patch
deleted file mode 100644
index ed09f25..0000000
--- a/xulrunner-6.0-secondary-ipc.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-diff -up xulrunner-6.0/mozilla-release/ipc/chromium/src/base/data_pack.cc.secondary-ipc xulrunner-6.0/mozilla-release/ipc/chromium/src/base/data_pack.cc
---- xulrunner-6.0/mozilla-release/ipc/chromium/src/base/data_pack.cc.secondary-ipc 2011-08-11 23:41:01.000000000 +0200
-+++ xulrunner-6.0/mozilla-release/ipc/chromium/src/base/data_pack.cc 2011-08-16 10:05:26.325449386 +0200
-@@ -91,14 +91,7 @@ bool DataPack::Load(const FilePath& path
- bool DataPack::Get(uint32_t resource_id, StringPiece* data) {
- // It won't be hard to make this endian-agnostic, but it's not worth
- // bothering to do right now.
--#if defined(__BYTE_ORDER)
-- // Linux check
-- COMPILE_ASSERT(__BYTE_ORDER == __LITTLE_ENDIAN,
-- datapack_assumes_little_endian);
--#elif defined(__BIG_ENDIAN__)
-- // Mac check
-- #error DataPack assumes little endian
--#endif
-+#warning DoTheRightThingMakingThisEndianAgnostic!
-
- DataPackEntry* target = reinterpret_cast<DataPackEntry*>(
- bsearch(&resource_id, mmap_->data() + kHeaderLength, resource_count_,
-diff -up xulrunner-6.0/mozilla-release/ipc/chromium/src/build/build_config.h.secondary-ipc xulrunner-6.0/mozilla-release/ipc/chromium/src/build/build_config.h
---- xulrunner-6.0/mozilla-release/ipc/chromium/src/build/build_config.h.secondary-ipc 2011-08-11 23:41:01.000000000 +0200
-+++ xulrunner-6.0/mozilla-release/ipc/chromium/src/build/build_config.h 2011-08-16 10:07:23.093899409 +0200
-@@ -57,9 +57,24 @@
- #define ARCH_CPU_ARMEL 1
- #define ARCH_CPU_32_BITS 1
- #define WCHAR_T_IS_UNSIGNED 1
-+#elif defined(__powerpc64__)
-+#define ARCH_CPU_PPC64 1
-+#define ARCH_CPU_64_BITS 1
- #elif defined(__ppc__) || defined(__powerpc__)
- #define ARCH_CPU_PPC 1
- #define ARCH_CPU_32_BITS 1
-+#elif defined(__s390x__)
-+#define ARCH_CPU_S390X 1
-+#define ARCH_CPU_64_BITS 1
-+#elif defined(__s390__)
-+#define ARCH_CPU_S390 1
-+#define ARCH_CPU_32_BITS 1
-+#elif defined(__sparc__) && !defined(__arch64)
-+#define ARCH_CPU_SPARC 1
-+#define ARCH_CPU_32_BITS 1
-+#elif defined(__sparc__) && defined(__arch64)
-+#define ARCH_CPU_SPARC64 1
-+#define ARCH_CPU_64_BITS 1
- #else
- #error Please add support for your architecture in build/build_config.h
- #endif
-diff -up xulrunner-6.0/mozilla-release/ipc/chromium/src/chrome/common/ipc_message_utils.h.secondary-ipc xulrunner-6.0/mozilla-release/ipc/chromium/src/chrome/common/ipc_message_utils.h
---- xulrunner-6.0/mozilla-release/ipc/chromium/src/chrome/common/ipc_message_utils.h.secondary-ipc 2011-08-11 23:41:01.000000000 +0200
-+++ xulrunner-6.0/mozilla-release/ipc/chromium/src/chrome/common/ipc_message_utils.h 2011-08-16 10:05:26.326449206 +0200
-@@ -219,7 +219,8 @@ struct ParamTraits<unsigned long> {
- }
- };
-
--#if !(defined(OS_MACOSX) || defined(OS_WIN) || (defined(CHROMIUM_MOZILLA_BUILD) && defined(OS_LINUX) && defined(ARCH_CPU_64_BITS)))
-+// Although s390 is a 32-bit system it defines size_t as unsigned long
-+#if !(defined(OS_MACOSX) || defined(OS_WIN) || (defined(CHROMIUM_MOZILLA_BUILD) && defined(OS_LINUX) && (defined(ARCH_CPU_64_BITS) || defined(ARCH_CPU_S390))))
- // There size_t is a synonym for |unsigned long| ...
- template <>
- struct ParamTraits<size_t> {
diff --git a/xulrunner-9.0-secondary-ipc.patch b/xulrunner-9.0-secondary-ipc.patch
new file mode 100644
index 0000000..40ecfd5
--- /dev/null
+++ b/xulrunner-9.0-secondary-ipc.patch
@@ -0,0 +1,60 @@
+diff -up xulrunner-9.0/mozilla-beta/ipc/chromium/src/base/data_pack.cc.secondary-ipc xulrunner-9.0/mozilla-beta/ipc/chromium/src/base/data_pack.cc
+--- xulrunner-9.0/mozilla-beta/ipc/chromium/src/base/data_pack.cc.secondary-ipc 2011-12-07 07:27:43.000000000 +0100
++++ xulrunner-9.0/mozilla-beta/ipc/chromium/src/base/data_pack.cc 2011-12-09 14:35:50.397220865 +0100
+@@ -91,14 +91,7 @@ bool DataPack::Load(const FilePath& path
+ bool DataPack::Get(uint32_t resource_id, StringPiece* data) {
+ // It won't be hard to make this endian-agnostic, but it's not worth
+ // bothering to do right now.
+-#if defined(__BYTE_ORDER)
+- // Linux check
+- COMPILE_ASSERT(__BYTE_ORDER == __LITTLE_ENDIAN,
+- datapack_assumes_little_endian);
+-#elif defined(__BIG_ENDIAN__)
+- // Mac check
+- #error DataPack assumes little endian
+-#endif
++#warning DoTheRightThingMakingThisEndianAgnostic!
+
+ DataPackEntry* target = reinterpret_cast<DataPackEntry*>(
+ bsearch(&resource_id, mmap_->data() + kHeaderLength, resource_count_,
+diff -up xulrunner-9.0/mozilla-beta/ipc/chromium/src/build/build_config.h.secondary-ipc xulrunner-9.0/mozilla-beta/ipc/chromium/src/build/build_config.h
+--- xulrunner-9.0/mozilla-beta/ipc/chromium/src/build/build_config.h.secondary-ipc 2011-12-07 07:27:43.000000000 +0100
++++ xulrunner-9.0/mozilla-beta/ipc/chromium/src/build/build_config.h 2011-12-09 14:39:44.922231601 +0100
+@@ -59,11 +59,23 @@
+ #define ARCH_CPU_ARMEL 1
+ #define ARCH_CPU_32_BITS 1
+ #define WCHAR_T_IS_UNSIGNED 1
++#elif defined(__powerpc64__)
++#define ARCH_CPU_PPC64 1
++#define ARCH_CPU_64_BITS 1
+ #elif defined(__ppc__) || defined(__powerpc__)
+ #define ARCH_CPU_PPC 1
+ #define ARCH_CPU_32_BITS 1
+-#elif defined(__sparc64__)
++#elif defined(__s390x__)
++#define ARCH_CPU_S390X 1
++#define ARCH_CPU_64_BITS 1
++#elif defined(__s390__)
++#define ARCH_CPU_S390 1
++#define ARCH_CPU_32_BITS 1
++#elif defined(__sparc__) && !defined(__arch64)
+ #define ARCH_CPU_SPARC 1
++#define ARCH_CPU_32_BITS 1
++#elif defined(__sparc__) && defined(__arch64)
++#define ARCH_CPU_SPARC64 1
+ #define ARCH_CPU_64_BITS 1
+ #else
+ #error Please add support for your architecture in build/build_config.h
+diff -up xulrunner-9.0/mozilla-beta/ipc/chromium/src/chrome/common/ipc_message_utils.h.secondary-ipc xulrunner-9.0/mozilla-beta/ipc/chromium/src/chrome/common/ipc_message_utils.h
+--- xulrunner-9.0/mozilla-beta/ipc/chromium/src/chrome/common/ipc_message_utils.h.secondary-ipc 2011-12-07 07:27:43.000000000 +0100
++++ xulrunner-9.0/mozilla-beta/ipc/chromium/src/chrome/common/ipc_message_utils.h 2011-12-09 14:40:59.602679278 +0100
+@@ -195,7 +195,8 @@ struct ParamTraits<unsigned long long> {
+ };
+ #endif
+
+-#if !(defined(OS_MACOSX) || defined(OS_OPENBSD) || defined(OS_WIN) || (defined(OS_LINUX) && defined(ARCH_CPU_64_BITS)))
++// Although s390 is a 32-bit system it defines size_t as unsigned long
++#if !(defined(OS_MACOSX) || defined(OS_OPENBSD) || defined(OS_WIN) || (defined(OS_LINUX) && (defined(ARCH_CPU_64_BITS) || defined(ARCH_CPU_S390))))
+ // There size_t is a synonym for |unsigned long| ...
+ template <>
+ struct ParamTraits<size_t> {