summaryrefslogtreecommitdiffstats
path: root/mozilla-670719.patch
diff options
context:
space:
mode:
Diffstat (limited to 'mozilla-670719.patch')
-rw-r--r--mozilla-670719.patch53
1 files changed, 0 insertions, 53 deletions
diff --git a/mozilla-670719.patch b/mozilla-670719.patch
deleted file mode 100644
index afae907..0000000
--- a/mozilla-670719.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-# HG changeset patch
-# User Mike Hommey <mh+mozilla@glandium.org>
-# Date 1313846520 -7200
-# Node ID fdc3b63938f5a76d99c1e2bb12fd448465debc94
-# Parent 07a5a618ebe3f67b23100ceb1b51e92bb79be0cd
-Bug 670719 - Only add -DENABLE_JIT=1 to CXXFLAGS if any of trace/method/yarr jit is enabled.
-
-diff --git a/js/src/Makefile.in b/js/src/Makefile.in
---- a/js/src/Makefile.in
-+++ b/js/src/Makefile.in
-@@ -433,16 +433,19 @@ CPPSRCS += \
- YarrPattern.cpp \
- YarrSyntaxChecker.cpp \
- $(NULL)
- else
-
- ###############################################
- # BEGIN include sources for the Nitro assembler
- #
-+
-+ENABLE_YARR_JIT = 1
-+
- VPATH += $(srcdir)/assembler \
- $(srcdir)/assembler/wtf \
- $(srcdir)/assembler/jit \
- $(srcdir)/assembler/assembler \
- $(srcdir)/methodjit \
- $(srcdir)/yarr \
- $(NONE)
-
-@@ -1070,17 +1073,21 @@ endif
-
- ###############################################
- # BEGIN kludges for the Nitro assembler
- #
-
- # Needed to "configure" it correctly. Unfortunately these
- # flags wind up being applied to all code in js/src, not just
- # the code in js/src/assembler.
--CXXFLAGS += -DUSE_SYSTEM_MALLOC=1 -DENABLE_ASSEMBLER=1 -DENABLE_JIT=1
-+CXXFLAGS += -DUSE_SYSTEM_MALLOC=1 -DENABLE_ASSEMBLER=1
-+
-+ifneq (,$(ENABLE_YARR_JIT)$(ENABLE_TRACEJIT)$(ENABLE_METHODJIT))
-+CXXFLAGS += -DENABLE_JIT=1
-+endif
-
- INCLUDES += -I$(srcdir)/assembler -I$(srcdir)/yarr
-
- ifdef ENABLE_METHODJIT
- # Build a standalone test program that exercises the assembler
- # sources a bit.
- TESTMAIN_OBJS = \
- Assertions.$(OBJ_SUFFIX) \