summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-03-17 09:08:29 +0100
committerRemi Collet <fedora@famillecollet.com>2012-03-17 09:08:29 +0100
commit1a36362778a8e52e23d93057bcb62fdc4fac8196 (patch)
tree73d4b0e50705eba37ba6efb3f6f9895c079f951f
parent7a6102ea5f298063ab331ada83d537abbb5ab96b (diff)
Firefox 11.0
-rwxr-xr-xffxpi2
-rw-r--r--firefox-mozconfig5
-rw-r--r--firefox.spec100
-rw-r--r--mozilla-703633.patch29
-rw-r--r--mozilla-722127.patch74
5 files changed, 149 insertions, 61 deletions
diff --git a/ffxpi b/ffxpi
index 3ccae60..ee0b612 100755
--- a/ffxpi
+++ b/ffxpi
@@ -12,7 +12,7 @@ getxpi() {
else URL=ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/$1-candidates/$2/linux-i686/xpi/
fi
# 85 max extensions (21+20+20+20+4)
- for i in af ak ar as ast be bg bn-BD bn-IN br bs ca cs cy da de el en-GB en-ZA eo es-AR \
+ for i in af ak ar as ast be bg bn-BD bn-IN br bs ca cs csb cy da de el en-GB en-ZA eo es-AR \
es-CL es-ES es-MX et eu fa fi fr fy-NL ga-IE gd gl gu-IN he hi-IN hr hu hy-AM id is it \
ja ka kk kn ko ku lg lt lv mai mk ml mn mr nb-NO nl nn-NO nso oc or \
pa-IN pl pt-BR pt-PT rm ro ru si sk sl son sq sr sv-SE ta ta-LK te th tr uk \
diff --git a/firefox-mozconfig b/firefox-mozconfig
index fa293f6..4dc2638 100644
--- a/firefox-mozconfig
+++ b/firefox-mozconfig
@@ -2,15 +2,12 @@
ac_add_options --prefix="$PREFIX"
ac_add_options --libdir="$LIBDIR"
-ac_add_options --with-system-nspr
-ac_add_options --with-system-nss
ac_add_options --with-system-jpeg
ac_add_options --with-system-zlib
#ac_add_options --with-system-png
+ac_add_options --with-system-libvpx
ac_add_options --with-pthreads
ac_add_options --disable-tests
-ac_add_options --disable-debug
-ac_add_options --enable-optimize
ac_add_options --disable-installer
ac_add_options --enable-xinerama
ac_add_options --enable-default-toolkit=cairo-gtk2
diff --git a/firefox.spec b/firefox.spec
index 0610890..1634cbd 100644
--- a/firefox.spec
+++ b/firefox.spec
@@ -1,3 +1,14 @@
+# Use system nspr/nss?
+%if 0%{?fedora} < 15
+%define system_nss 0
+%define system_cairo 0
+%define system_vpx 0
+%else
+%define system_nss 1
+%define system_cairo 1
+%define system_vpx 1
+%endif
+
# Separated plugins are supported on x86(64) only
%ifarch %{ix86} x86_64
%define separated_plugins 1
@@ -5,19 +16,22 @@
%define separated_plugins 0
%endif
+# Build as a debug package?
+%define debug_build 0
+
%define homepage http://start.fedoraproject.org/
%define default_bookmarks_file %{_datadir}/bookmarks/default-bookmarks.html
%define firefox_app_id \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
-%global shortname firefox
-#global mycomment Beta 4
-%global firefox_dir_ver 10
-%global gecko_version 10.0.2
-%global gecko_release 1
-%global alpha_version 0
-%global beta_version 0
-%global rc_version 0
-%global datelang 20120218
+%global shortname firefox
+#global mycomment Beta 4
+%global firefox_dir_ver 11
+%global xulrunner_version 11.0
+%global xulrunner_release 1
+%global alpha_version 0
+%global beta_version 0
+%global rc_version 0
+%global datelang 20120317
%global mozappdir %{_libdir}/%{shortname}
%global langpackdir %{mozappdir}/langpacks
@@ -40,15 +54,15 @@
%global pre_name rc%{rc_version}
%endif
%if %{defined pre_version}
-%global gecko_verrel %{gecko_version}-%{gecko_release}%{pre_name}
+%global xulrunner_verrel %{xulrunner_version}-%{xulrunner_release}%{pre_name}
%global pre_tag .%{pre_version}
%else
-%global gecko_verrel %{gecko_version}-%{gecko_release}
+%global xulrunner_verrel %{xulrunner_version}-%{xulrunner_release}
%endif
Summary: Mozilla Firefox Web browser
Name: %{shortname}
-Version: 10.0.2
+Version: 11.0
Release: 1%{?dist}
URL: http://www.mozilla.org/projects/firefox/
License: MPLv1.1 or GPLv2+ or LGPLv2+
@@ -73,8 +87,7 @@ Patch14: firefox-5.0-asciidel.patch
Patch15: firefox-8.0-enable-addons.patch
# Upstream patches
-# fixes non functional web development tools, obsolete by version 11
-Patch100: mozilla-703633.patch
+Patch100: mozilla-722127.patch
%if %{official_branding}
# Required by Mozilla Corporation
@@ -90,12 +103,11 @@ Patch100: mozilla-703633.patch
BuildRequires: desktop-file-utils
BuildRequires: system-bookmarks
-BuildRequires: xulrunner%{firefox_dir_ver}-devel = %{version}
+BuildRequires: xulrunner%{firefox_dir_ver}-devel >= %{xulrunner_verrel}
# For WebM support
BuildRequires: yasm
-Requires: xulrunner%{firefox_dir_ver}%{?_isa} = %{version}
-Requires: gecko-libs%{?_isa} = %{gecko_verrel}
+Requires: xulrunner%{firefox_dir_ver}%{?_isa} >= %{xulrunner_verrel}
Requires: system-bookmarks
Obsoletes: mozilla <= 37:1.7.13
Provides: webclient
@@ -131,7 +143,7 @@ cd %{tarballdir}
%patch15 -p2 -b .addons
# Upstream patches
-%patch100 -p1 -b .703633
+%patch100 -p2 -b .722127
%if %{official_branding}
# Required by Mozilla Corporation
@@ -143,17 +155,14 @@ cd %{tarballdir}
%{__rm} -f .mozconfig
%{__cat} %{SOURCE10} \
-%if 0%{?fedora} < 16
- | grep -v enable-system-sqlite \
-%endif
-%if 0%{?fedora} < 15
- | grep -v with-system-nspr \
+%if ! %{system_cairo}
+ | grep -v enable-system-cairo \
%endif
-%if 0%{?fedora} < 15
- | grep -v with-system-nss \
+%ifarch %{ix86} x86_64
+ | grep -v disable-necko-wifi \
%endif
-%if 0%{?fedora} < 15
- | grep -v enable-system-cairo \
+%if ! %{system_vpx}
+ | grep -v with-system-libvpx \
%endif
%ifarch %{ix86} x86_64
| grep -v disable-necko-wifi \
@@ -169,6 +178,14 @@ cd %{tarballdir}
echo "ac_add_options --enable-system-lcms" >> .mozconfig
+%if %{?system_nss}
+echo "ac_add_options --with-system-nspr" >> .mozconfig
+echo "ac_add_options --with-system-nss" >> .mozconfig
+%else
+echo "ac_add_options --without-system-nspr" >> .mozconfig
+echo "ac_add_options --without-system-nss" >> .mozconfig
+%endif
+
# Set up SDK path
echo "ac_add_options --with-libxul-sdk=\
`pkg-config --variable=sdkdir libxul`" >> .mozconfig
@@ -181,6 +198,18 @@ echo "ac_add_options --disable-ipc" >> .mozconfig
echo "ac_add_options --disable-libjpeg-turbo" >> .mozconfig
%endif
+%ifarch %{arm}
+echo "ac_add_options --disable-elf-hack" >> .mozconfig
+%endif
+
+%if %{?debug_build}
+echo "ac_add_options --enable-debug" >> .mozconfig
+echo "ac_add_options --disable-optimize" >> .mozconfig
+%else
+echo "ac_add_options --disable-debug" >> .mozconfig
+echo "ac_add_options --enable-optimize" >> .mozconfig
+%endif
+
#---------------------------------------------------------------------
%build
@@ -193,6 +222,9 @@ cd %{tarballdir}
#
MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | \
%{__sed} -e 's/-Wall//' -e 's/-fexceptions/-fno-exceptions/g')
+%if %{?debug_build}
+MOZ_OPT_FLAGS=$(echo "$MOZ_OPT_FLAGS" | %{__sed} -e 's/-O2//')
+%endif
export CFLAGS=$MOZ_OPT_FLAGS
export CXXFLAGS=$MOZ_OPT_FLAGS
@@ -401,6 +433,20 @@ fi
#---------------------------------------------------------------------
%changelog
+* Sat Mar 17 2012 Remi Collet <RPMS@FamilleCollet.com> - 11.0-1
+- Update to 11.0, sync with rawhide
+
+* Thu Mar 15 2012 Martin Stransky <stransky@redhat.com> - 11.0-2
+- Switched dependency to xulrunner (rhbz#803471)
+
+* Tue Mar 13 2012 Martin Stransky <stransky@redhat.com> - 11.0-1
+- Update to 11.0
+- Fixed rhbz#800622 - make default home page of fedoraproject.org conditional
+- Fixed rhbz#801796 - enable debug build by some simple way
+
+* Mon Feb 27 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 10.0.1-2
+- Add ARM config options to fix compile
+
* Sat Feb 18 2012 Remi Collet <RPMS@FamilleCollet.com> - 10.0.2-1
- Update to 10.0.2
diff --git a/mozilla-703633.patch b/mozilla-703633.patch
deleted file mode 100644
index b2a9451..0000000
--- a/mozilla-703633.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-# HG changeset patch
-# User Mike Hommey <mh+mozilla@glandium.org>
-# Date 1321637776 -3600
-# Node ID a5c78674f5edf4c1cea091ae900e187f4f8ce6a9
-# Parent 4a16dc96aab3c56b1dda84e197e1e6c0db8fab6d
-Bug 703633 - TreePanel.jsm uses a resource:/// url that ought to be resource://gre/
-
-diff --git a/browser/devtools/highlighter/TreePanel.jsm b/browser/devtools/highlighter/TreePanel.jsm
---- a/browser/devtools/highlighter/TreePanel.jsm
-+++ b/browser/devtools/highlighter/TreePanel.jsm
-@@ -40,17 +40,17 @@
- * the terms of any one of the MPL, the GPL or the LGPL.
- *
- * ***** END LICENSE BLOCK ***** */
-
- const Cu = Components.utils;
-
- Cu.import("resource:///modules/domplate.jsm");
- Cu.import("resource:///modules/InsideOutBox.jsm");
--Cu.import("resource:///modules/Services.jsm");
-+Cu.import("resource://gre/modules/Services.jsm");
-
- var EXPORTED_SYMBOLS = ["TreePanel", "DOMHelpers"];
-
- const INSPECTOR_URI = "chrome://browser/content/inspector.html";
-
- /**
- * TreePanel
- * A container for the Inspector's HTML Tree Panel widget constructor function.
diff --git a/mozilla-722127.patch b/mozilla-722127.patch
new file mode 100644
index 0000000..f86fcae
--- /dev/null
+++ b/mozilla-722127.patch
@@ -0,0 +1,74 @@
+diff -up xulrunner-11.0/mozilla-beta/configure.in.vpx1.0.0 xulrunner-11.0/mozilla-beta/configure.in
+--- xulrunner-11.0/mozilla-beta/configure.in.vpx1.0.0 2012-03-09 01:39:31.000000000 +0100
++++ xulrunner-11.0/mozilla-beta/configure.in 2012-03-09 15:03:51.246031329 +0100
+@@ -5710,20 +5710,20 @@ if test -n "$MOZ_WEBM"; then
+ [MOZ_NATIVE_LIBVPX_DEC_TEST=1],
+ ([--with-system-libvpx requested but symbol vpx_codec_dec_init_ver not found]))
+ if test -n "$MOZ_NATIVE_LIBVPX_DEC_TEST" ; then
+- AC_MSG_CHECKING([for libvpx version >= v0.9.7])
+- dnl We need at least v0.9.7 to fix several crash bugs (for which we
+- dnl had local patches prior to v0.9.7).
++ AC_MSG_CHECKING([for libvpx version >= v1.0.0])
++ dnl We need at least v1.0.0 to fix several crash bugs (for which we
++ dnl had local patches prior to v1.0.0).
+ dnl
+ dnl This is a terrible test for the library version, but we don't
+ dnl have a good one. There is no version number in a public header,
+ dnl and testing the headers still doesn't guarantee we link against
+ dnl the right version. While we could call vpx_codec_version() at
+ dnl run-time, that would break cross-compiling. There are no
+- dnl additional exported symbols between the v0.9.7 release and the
+- dnl v0.9.6 one to check for.
++ dnl additional exported decoder symbols between the v1.0.0 release
++ dnl and the v0.9.7 one to check for.
+ AC_TRY_COMPILE([
+ #include <vpx/vpx_decoder.h>
+- #if !defined(VPX_CODEC_USE_INPUT_PARTITION)
++ #if !defined(VPX_CODEC_USE_INPUT_FRAGMENTS)
+ #error "test failed."
+ #endif
+ ],
+@@ -5734,7 +5734,7 @@ if test -n "$MOZ_WEBM"; then
+ MOZ_LIBVPX_INCLUDES="-I${LIBVPX_DIR}/include"
+ MOZ_LIBVPX_LIBS="-L${LIBVPX_DIR}/lib -lvpx"],
+ [AC_MSG_RESULT([no])
+- AC_MSG_ERROR([--with-system-libvpx requested but it is not v0.9.7 or later])])
++ AC_MSG_ERROR([--with-system-libvpx requested but it is not v1.0.0 or later])])
+ fi
+ CFLAGS=$_SAVE_CFLAGS
+ LDFLAGS=$_SAVE_LDFLAGS
+diff -up xulrunner-11.0/mozilla-beta/configure.vpx1.0.0 xulrunner-11.0/mozilla-beta/configure
+--- xulrunner-11.0/mozilla-beta/configure.vpx1.0.0 2012-03-09 01:58:50.000000000 +0100
++++ xulrunner-11.0/mozilla-beta/configure 2012-03-09 15:15:42.537585632 +0100
+@@ -17761,14 +17761,14 @@ else
+ fi
+
+ if test -n "$MOZ_NATIVE_LIBVPX_DEC_TEST" ; then
+- echo $ac_n "checking for libvpx version >= v0.9.7""... $ac_c" 1>&6
+-echo "configure:17766: checking for libvpx version >= v0.9.7" >&5
++ echo $ac_n "checking for libvpx version >= v1.0.0""... $ac_c" 1>&6
++echo "configure:17766: checking for libvpx version >= v1.0.0" >&5
+ cat > conftest.$ac_ext <<EOF
+ #line 17768 "configure"
+ #include "confdefs.h"
+
+ #include <vpx/vpx_decoder.h>
+- #if !defined(VPX_CODEC_USE_INPUT_PARTITION)
++ #if !defined(VPX_CODEC_USE_INPUT_FRAGMENTS)
+ #error "test failed."
+ #endif
+
+@@ -17791,7 +17791,7 @@ else
+ cat conftest.$ac_ext >&5
+ rm -rf conftest*
+ echo "$ac_t""no" 1>&6
+- { echo "configure: error: --with-system-libvpx requested but it is not v0.9.7 or later" 1>&2; exit 1; }
++ { echo "configure: error: --with-system-libvpx requested but it is not v1.0.0 or later" 1>&2; exit 1; }
+ fi
+ rm -f conftest*
+ fi
+@@ -25794,4 +25794,3 @@ if cmp -s config/autoconf.mk config/auto
+ else
+ rm -f config/autoconf.mk.orig 2> /dev/null
+ fi
+-