summaryrefslogtreecommitdiffstats
path: root/mozilla-722127.patch
diff options
context:
space:
mode:
Diffstat (limited to 'mozilla-722127.patch')
-rw-r--r--mozilla-722127.patch74
1 files changed, 74 insertions, 0 deletions
diff --git a/mozilla-722127.patch b/mozilla-722127.patch
new file mode 100644
index 0000000..f86fcae
--- /dev/null
+++ b/mozilla-722127.patch
@@ -0,0 +1,74 @@
+diff -up xulrunner-11.0/mozilla-beta/configure.in.vpx1.0.0 xulrunner-11.0/mozilla-beta/configure.in
+--- xulrunner-11.0/mozilla-beta/configure.in.vpx1.0.0 2012-03-09 01:39:31.000000000 +0100
++++ xulrunner-11.0/mozilla-beta/configure.in 2012-03-09 15:03:51.246031329 +0100
+@@ -5710,20 +5710,20 @@ if test -n "$MOZ_WEBM"; then
+ [MOZ_NATIVE_LIBVPX_DEC_TEST=1],
+ ([--with-system-libvpx requested but symbol vpx_codec_dec_init_ver not found]))
+ if test -n "$MOZ_NATIVE_LIBVPX_DEC_TEST" ; then
+- AC_MSG_CHECKING([for libvpx version >= v0.9.7])
+- dnl We need at least v0.9.7 to fix several crash bugs (for which we
+- dnl had local patches prior to v0.9.7).
++ AC_MSG_CHECKING([for libvpx version >= v1.0.0])
++ dnl We need at least v1.0.0 to fix several crash bugs (for which we
++ dnl had local patches prior to v1.0.0).
+ dnl
+ dnl This is a terrible test for the library version, but we don't
+ dnl have a good one. There is no version number in a public header,
+ dnl and testing the headers still doesn't guarantee we link against
+ dnl the right version. While we could call vpx_codec_version() at
+ dnl run-time, that would break cross-compiling. There are no
+- dnl additional exported symbols between the v0.9.7 release and the
+- dnl v0.9.6 one to check for.
++ dnl additional exported decoder symbols between the v1.0.0 release
++ dnl and the v0.9.7 one to check for.
+ AC_TRY_COMPILE([
+ #include <vpx/vpx_decoder.h>
+- #if !defined(VPX_CODEC_USE_INPUT_PARTITION)
++ #if !defined(VPX_CODEC_USE_INPUT_FRAGMENTS)
+ #error "test failed."
+ #endif
+ ],
+@@ -5734,7 +5734,7 @@ if test -n "$MOZ_WEBM"; then
+ MOZ_LIBVPX_INCLUDES="-I${LIBVPX_DIR}/include"
+ MOZ_LIBVPX_LIBS="-L${LIBVPX_DIR}/lib -lvpx"],
+ [AC_MSG_RESULT([no])
+- AC_MSG_ERROR([--with-system-libvpx requested but it is not v0.9.7 or later])])
++ AC_MSG_ERROR([--with-system-libvpx requested but it is not v1.0.0 or later])])
+ fi
+ CFLAGS=$_SAVE_CFLAGS
+ LDFLAGS=$_SAVE_LDFLAGS
+diff -up xulrunner-11.0/mozilla-beta/configure.vpx1.0.0 xulrunner-11.0/mozilla-beta/configure
+--- xulrunner-11.0/mozilla-beta/configure.vpx1.0.0 2012-03-09 01:58:50.000000000 +0100
++++ xulrunner-11.0/mozilla-beta/configure 2012-03-09 15:15:42.537585632 +0100
+@@ -17761,14 +17761,14 @@ else
+ fi
+
+ if test -n "$MOZ_NATIVE_LIBVPX_DEC_TEST" ; then
+- echo $ac_n "checking for libvpx version >= v0.9.7""... $ac_c" 1>&6
+-echo "configure:17766: checking for libvpx version >= v0.9.7" >&5
++ echo $ac_n "checking for libvpx version >= v1.0.0""... $ac_c" 1>&6
++echo "configure:17766: checking for libvpx version >= v1.0.0" >&5
+ cat > conftest.$ac_ext <<EOF
+ #line 17768 "configure"
+ #include "confdefs.h"
+
+ #include <vpx/vpx_decoder.h>
+- #if !defined(VPX_CODEC_USE_INPUT_PARTITION)
++ #if !defined(VPX_CODEC_USE_INPUT_FRAGMENTS)
+ #error "test failed."
+ #endif
+
+@@ -17791,7 +17791,7 @@ else
+ cat conftest.$ac_ext >&5
+ rm -rf conftest*
+ echo "$ac_t""no" 1>&6
+- { echo "configure: error: --with-system-libvpx requested but it is not v0.9.7 or later" 1>&2; exit 1; }
++ { echo "configure: error: --with-system-libvpx requested but it is not v1.0.0 or later" 1>&2; exit 1; }
+ fi
+ rm -f conftest*
+ fi
+@@ -25794,4 +25794,3 @@ if cmp -s config/autoconf.mk config/auto
+ else
+ rm -f config/autoconf.mk.orig 2> /dev/null
+ fi
+-