summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-28 10:33:16 +0200
committerRemi Collet <remi@php.net>2022-10-28 10:33:16 +0200
commit8645488e5224a6435faa3882bbceda8710105c6f (patch)
tree1e3bb68a1ac87a91bfdadee8c443d1eb7583cc64
parenta64a7256d15cdc5b9614113ce2deda5d2e4d8afb (diff)
switch from botan-2 to openssl on EL-8
-rw-r--r--rnp.spec24
1 files changed, 23 insertions, 1 deletions
diff --git a/rnp.spec b/rnp.spec
index 9704fa9..31a11f9 100644
--- a/rnp.spec
+++ b/rnp.spec
@@ -9,13 +9,21 @@
%bcond_without tests
+%if 0%{?rhel} == 8
+# use openssl by default as botan2 is too old
+%bcond_without openssl
+%else
+# use botan2 as openssl seems experimental/wip
+%bcond_with openssl
+%endif
+
%global libname librnp
%global soname 0
Name: rnp
Summary: OpenPGP (RFC4880) tools
Version: 0.16.2
-Release: 1%{?dist}
+Release: 2%{?dist}
License: BSD-2-Clause and BSD-3-Clause and Apache-2.0
URL: https://github.com/rnpgp/rnp
@@ -27,9 +35,15 @@ BuildRequires: gcc-c++
BuildRequires: pkg-config
BuildRequires: pkgconfig(zlib)
BuildRequires: pkgconfig(bzip2)
+%if %{with openssl}
+BuildRequires: openssl-devel >= 1.1.1
+BuildRequires: json-c-devel >= 0.11
+BuildRequires: gtest-devel
+%else
BuildRequires: pkgconfig(botan-2) >= 2.14
BuildRequires: cmake(json-c) >= 0.11
BuildRequires: cmake(GTest)
+%endif
BuildRequires: python3
BuildRequires: gnupg2
@@ -62,6 +76,11 @@ for %{libname}.
%build
%cmake . \
+%if %{with openssl}
+ -DCRYPTO_BACKEND:STRING=openssl \
+%else
+ -DCRYPTO_BACKEND:STRING=botan \
+%endif
-DDOWNLOAD_GTEST:BOOL=OFF \
-DDOWNLOAD_RUBYRNP:BOOL=OFF
@@ -95,5 +114,8 @@ for %{libname}.
%changelog
+* Fri Oct 28 2022 Remi Collet <remi@remirepo.net> - 0.16.2-2
+- switch from botan-2 to openssl on EL-8
+
* Thu Oct 27 2022 Remi Collet <remi@remirepo.net> - 0.16.2-1
- initial package