summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-27 15:14:41 +0200
committerRemi Collet <remi@php.net>2022-10-27 15:14:41 +0200
commita64a7256d15cdc5b9614113ce2deda5d2e4d8afb (patch)
tree8220b83edaa3cb92da2d1a84988f114df38b2928
initial package
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--rnp.spec99
3 files changed, 112 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/rnp.spec b/rnp.spec
new file mode 100644
index 0000000..9704fa9
--- /dev/null
+++ b/rnp.spec
@@ -0,0 +1,99 @@
+# remirepo spec file for rnp
+#
+# Copyright (c) 2022 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+%bcond_without tests
+
+%global libname librnp
+%global soname 0
+
+Name: rnp
+Summary: OpenPGP (RFC4880) tools
+Version: 0.16.2
+Release: 1%{?dist}
+License: BSD-2-Clause and BSD-3-Clause and Apache-2.0
+
+URL: https://github.com/rnpgp/rnp
+Source0: https://github.com/rnpgp/rnp/archive/refs/tags/v%{version}.tar.gz
+
+BuildRequires: cmake >= 3.14
+BuildRequires: gcc
+BuildRequires: gcc-c++
+BuildRequires: pkg-config
+BuildRequires: pkgconfig(zlib)
+BuildRequires: pkgconfig(bzip2)
+BuildRequires: pkgconfig(botan-2) >= 2.14
+BuildRequires: cmake(json-c) >= 0.11
+BuildRequires: cmake(GTest)
+BuildRequires: python3
+BuildRequires: gnupg2
+
+Requires: %{libname}%{?_isa} = %{version}-%{release}
+
+
+%description
+RNP is a set of OpenPGP (RFC4880) tools.
+
+%package -n %{libname}
+Summary: Library for all OpenPGP functions
+
+%description -n %{libname}
+%{libname} is the library used by RNP for all OpenPGP functions,
+useful for developers to build against, different from GPGME.
+
+
+%package -n %{libname}-devel
+Summary: Header files and development libraries for %{libname}
+Requires: %{libname}%{?_isa} = %{version}-%{release}
+
+%description -n %{libname}-devel
+This package contains the header files and development libraries
+for %{libname}.
+
+
+%prep
+%setup -q -n %{name}-%{version}
+
+
+%build
+%cmake . \
+ -DDOWNLOAD_GTEST:BOOL=OFF \
+ -DDOWNLOAD_RUBYRNP:BOOL=OFF
+
+%cmake_build
+
+
+%install
+%cmake_install
+
+
+%if %{with tests}
+%check
+%ctest
+%endif
+
+
+%files
+%{_bindir}/rnp
+%{_bindir}/rnpkeys
+
+%files -n %{libname}
+%license LICENSE*
+%{_libdir}/%{libname}.so.%{soname}*
+
+%files -n %{libname}-devel
+%doc CHANGELOG.md
+%{_includedir}/rnp
+%{_libdir}/%{libname}.so
+%{_libdir}/pkgconfig/%{libname}.pc
+%{_libdir}/cmake/rnp
+
+
+%changelog
+* Thu Oct 27 2022 Remi Collet <remi@remirepo.net> - 0.16.2-1
+- initial package