summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-07-27 14:53:40 +0200
committerRemi Collet <remi@remirepo.net>2021-07-27 14:53:40 +0200
commit7b59928129d230d7f017391b5497331a37adeea0 (patch)
tree860b567bbea3358e222225b552eca45e756fad9f
parentf5ed363412b8023653daf9481a87fa6eb4f47095 (diff)
add LIBMEMCACHED_AWESOME macro from
https://github.com/awesomized/libmemcached/pull/115
-rw-r--r--libmemcached-awesome-config.patch64
-rw-r--r--libmemcached-awesome-macro.patch21
-rw-r--r--libmemcached-awesome.spec14
3 files changed, 98 insertions, 1 deletions
diff --git a/libmemcached-awesome-config.patch b/libmemcached-awesome-config.patch
new file mode 100644
index 0000000..6ec63ec
--- /dev/null
+++ b/libmemcached-awesome-config.patch
@@ -0,0 +1,64 @@
+From 8b3a224e03457bfab11f0974114f28b2ba7a568f Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Mon, 26 Jul 2021 10:02:24 +0200
+Subject: [PATCH] Fix #116 add configure.h for libmemcachedprotocol
+
+---
+ .../libmemcachedprotocol-0.0/CMakeLists.txt | 1 +
+ .../libmemcachedprotocol-0.0/configure.h.in | 19 +++++++++++++++++++
+ include/libmemcachedprotocol-0.0/handler.h | 1 +
+ 3 files changed, 21 insertions(+)
+ create mode 100644 include/libmemcachedprotocol-0.0/configure.h.in
+
+diff --git a/include/libmemcachedprotocol-0.0/CMakeLists.txt b/include/libmemcachedprotocol-0.0/CMakeLists.txt
+index 6d4fb220..71b4f260 100644
+--- a/include/libmemcachedprotocol-0.0/CMakeLists.txt
++++ b/include/libmemcachedprotocol-0.0/CMakeLists.txt
+@@ -2,6 +2,7 @@
+ install_public_headers(
+ libmemcachedprotocol-0.0
+
++ @configure.h
+ binary.h
+ callback.h
+ handler.h
+diff --git a/include/libmemcachedprotocol-0.0/configure.h.in b/include/libmemcachedprotocol-0.0/configure.h.in
+new file mode 100644
+index 00000000..f4d77c28
+--- /dev/null
++++ b/include/libmemcachedprotocol-0.0/configure.h.in
+@@ -0,0 +1,19 @@
++/*
++ +--------------------------------------------------------------------+
++ | libmemcached-awesome - C/C++ Client Library for memcached |
++ +--------------------------------------------------------------------+
++ | Redistribution and use in source and binary forms, with or without |
++ | modification, are permitted under the terms of the BSD license. |
++ | You should have received a copy of the license in a bundled file |
++ | named LICENSE; in case you did not receive a copy you can review |
++ | the terms online at: https://opensource.org/licenses/BSD-3-Clause |
++ +--------------------------------------------------------------------+
++ | Copyright (c) 2006-2014 Brian Aker https://datadifferential.com/ |
++ | Copyright (c) 2020-2021 Michael Wallner https://awesome.co/ |
++ +--------------------------------------------------------------------+
++*/
++
++#pragma once
++
++#cmakedefine HAVE_SSIZE_T 1
++
+diff --git a/include/libmemcachedprotocol-0.0/handler.h b/include/libmemcachedprotocol-0.0/handler.h
+index 04e47acf..3b576d02 100644
+--- a/include/libmemcachedprotocol-0.0/handler.h
++++ b/include/libmemcachedprotocol-0.0/handler.h
+@@ -15,6 +15,7 @@
+
+ #pragma once
+
++#include "libmemcachedprotocol-0.0/configure.h"
+ #include <sys/types.h>
+ #ifndef HAVE_SSIZE_T
+ typedef long int ssize_t;
+--
+2.31.1
+
diff --git a/libmemcached-awesome-macro.patch b/libmemcached-awesome-macro.patch
new file mode 100644
index 0000000..3b599b9
--- /dev/null
+++ b/libmemcached-awesome-macro.patch
@@ -0,0 +1,21 @@
+From 6e732f43b86a64b49fbb02d2b5da1a1a1152ddb9 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Tue, 13 Jul 2021 18:19:21 +0200
+Subject: [PATCH] define LIBMEMCACHED_AWESOME
+
+---
+ include/libmemcached-1.0/configure.h.in | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/libmemcached-1.0/configure.h.in b/include/libmemcached-1.0/configure.h.in
+index 168bbcb7..bcb1109f 100644
+--- a/include/libmemcached-1.0/configure.h.in
++++ b/include/libmemcached-1.0/configure.h.in
+@@ -26,6 +26,7 @@
+ #cmakedefine HAVE_PID_T 1
+ #cmakedefine HAVE_SSIZE_T 1
+
++#define LIBMEMCACHED_AWESOME 1
+ #define LIBMEMCACHED_VERSION_STRING "@LIBMEMCACHED_VERSION@"
+ #define LIBMEMCACHED_VERSION_HEX @LIBMEMCACHED_VERSION_HEX@
+
diff --git a/libmemcached-awesome.spec b/libmemcached-awesome.spec
index 267482c..3aa8740 100644
--- a/libmemcached-awesome.spec
+++ b/libmemcached-awesome.spec
@@ -33,13 +33,15 @@ Name: %{projname}
Summary: Client library and command line tools for memcached server
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 4%{?dist}
+Release: 6%{?dist}
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
Patch0: %{projname}-catch.patch
Patch1: %{projname}-aes.patch
+Patch2: %{projname}-config.patch
+Patch3: %{projname}-macro.patch
%if 0%{?rhel} == 7
BuildRequires: cmake3 >= 3.9
@@ -140,6 +142,8 @@ memtouch Touches a key
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p1
%patch1 -p1
+%patch2 -p1
+%patch3 -p1
# drop test hanging in mock
# and requiring some memcached build options
@@ -262,6 +266,14 @@ make test
%changelog
+* Tue Jul 27 2021 Remi Collet <remi@remirepo.net> - 1.1.0-6
+- add LIBMEMCACHED_AWESOME macro from
+ https://github.com/awesomized/libmemcached/pull/115
+
+* Mon Jul 26 2021 Remi Collet <remi@remirepo.net> - 1.1.0-5
+- fix missing HAVE_SSIZE_T macro using patch from
+ https://github.com/awesomized/libmemcached/pull/117
+
* Tue Jul 13 2021 Remi Collet <remi@remirepo.net> - 1.1.0-4
- rename to remi-libmemcached-awesome when relocated in /opt/remi (EL7, EL8)