summaryrefslogtreecommitdiffstats
path: root/libmemcached-awesome-config.patch
diff options
context:
space:
mode:
Diffstat (limited to 'libmemcached-awesome-config.patch')
-rw-r--r--libmemcached-awesome-config.patch64
1 files changed, 64 insertions, 0 deletions
diff --git a/libmemcached-awesome-config.patch b/libmemcached-awesome-config.patch
new file mode 100644
index 0000000..6ec63ec
--- /dev/null
+++ b/libmemcached-awesome-config.patch
@@ -0,0 +1,64 @@
+From 8b3a224e03457bfab11f0974114f28b2ba7a568f Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Mon, 26 Jul 2021 10:02:24 +0200
+Subject: [PATCH] Fix #116 add configure.h for libmemcachedprotocol
+
+---
+ .../libmemcachedprotocol-0.0/CMakeLists.txt | 1 +
+ .../libmemcachedprotocol-0.0/configure.h.in | 19 +++++++++++++++++++
+ include/libmemcachedprotocol-0.0/handler.h | 1 +
+ 3 files changed, 21 insertions(+)
+ create mode 100644 include/libmemcachedprotocol-0.0/configure.h.in
+
+diff --git a/include/libmemcachedprotocol-0.0/CMakeLists.txt b/include/libmemcachedprotocol-0.0/CMakeLists.txt
+index 6d4fb220..71b4f260 100644
+--- a/include/libmemcachedprotocol-0.0/CMakeLists.txt
++++ b/include/libmemcachedprotocol-0.0/CMakeLists.txt
+@@ -2,6 +2,7 @@
+ install_public_headers(
+ libmemcachedprotocol-0.0
+
++ @configure.h
+ binary.h
+ callback.h
+ handler.h
+diff --git a/include/libmemcachedprotocol-0.0/configure.h.in b/include/libmemcachedprotocol-0.0/configure.h.in
+new file mode 100644
+index 00000000..f4d77c28
+--- /dev/null
++++ b/include/libmemcachedprotocol-0.0/configure.h.in
+@@ -0,0 +1,19 @@
++/*
++ +--------------------------------------------------------------------+
++ | libmemcached-awesome - C/C++ Client Library for memcached |
++ +--------------------------------------------------------------------+
++ | Redistribution and use in source and binary forms, with or without |
++ | modification, are permitted under the terms of the BSD license. |
++ | You should have received a copy of the license in a bundled file |
++ | named LICENSE; in case you did not receive a copy you can review |
++ | the terms online at: https://opensource.org/licenses/BSD-3-Clause |
++ +--------------------------------------------------------------------+
++ | Copyright (c) 2006-2014 Brian Aker https://datadifferential.com/ |
++ | Copyright (c) 2020-2021 Michael Wallner https://awesome.co/ |
++ +--------------------------------------------------------------------+
++*/
++
++#pragma once
++
++#cmakedefine HAVE_SSIZE_T 1
++
+diff --git a/include/libmemcachedprotocol-0.0/handler.h b/include/libmemcachedprotocol-0.0/handler.h
+index 04e47acf..3b576d02 100644
+--- a/include/libmemcachedprotocol-0.0/handler.h
++++ b/include/libmemcachedprotocol-0.0/handler.h
+@@ -15,6 +15,7 @@
+
+ #pragma once
+
++#include "libmemcachedprotocol-0.0/configure.h"
+ #include <sys/types.h>
+ #ifndef HAVE_SSIZE_T
+ typedef long int ssize_t;
+--
+2.31.1
+