summaryrefslogtreecommitdiffstats
path: root/glpi.spec
diff options
context:
space:
mode:
Diffstat (limited to 'glpi.spec')
-rw-r--r--glpi.spec29
1 files changed, 18 insertions, 11 deletions
diff --git a/glpi.spec b/glpi.spec
index 0b51e6a..5c308fd 100644
--- a/glpi.spec
+++ b/glpi.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
-%global gh_commit aff731b59aaa4e0c07c802b6ca30074b46dbf501
+%global gh_commit 84b68efa767f66f5d4bf90de8851751f9e8b8aeb
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20160923
%global gh_owner glpi-project
@@ -40,8 +40,8 @@
%endif
Name: %{gh_project}
-Version: 9.2.2
-Release: 2%{?dist}
+Version: 9.2.3
+Release: 1%{?dist}
Summary: Free IT asset management software
Summary(fr): Gestion Libre de Parc Informatique
@@ -82,7 +82,9 @@ BuildRequires: php-composer(sabre/vobject) < 5
BuildRequires: php-composer(sabre/vobject) >= 4.1
BuildRequires: php-composer(simplepie/simplepie) < 2
BuildRequires: php-composer(tecnickcom/tcpdf) < 7
-BuildRequires: php-composer(tecnickcom/tcpdf) >= 6.2.13
+BuildRequires: php-composer(tecnickcom/tcpdf) >= 6.2.16
+# Because 3 versions exists TODO: use range dependency
+BuildRequires: php-phpunit-diff >= 1.4
# remirepo:1
%if 0%{?fedora} >= 25 || 0%{?rhel} >= 8
BuildRequires: php-autoloader(zendframework/zend-cache) < 3
@@ -163,9 +165,9 @@ Requires: php-composer(sabre/vobject) < 5
Requires: php-composer(sabre/vobject) >= 4.1
Requires: php-composer(simplepie/simplepie) < 2
Requires: php-composer(simplepie/simplepie) >= 1.5
-# 6.2.13 to ensure we have the classmap autoloader
Requires: php-composer(tecnickcom/tcpdf) < 7
-Requires: php-composer(tecnickcom/tcpdf) >= 6.2.13
+Requires: php-composer(tecnickcom/tcpdf) >= 6.2.16
+Requires: php-phpunit-diff >= 1.4
# remirepo:1
%if 0%{?fedora} >= 25 || 0%{?rhel} >= 8
Requires: php-autoloader(zendframework/zend-cache) < 3
@@ -390,9 +392,6 @@ export GLPI_URI=http://127.0.0.1:8089
%{_bindir}/php -S 127.0.0.1:8089 tests/router.php &>web.log &
PHPPID=$!
-: Skip LDAP tests for now
-rm tests/units/AuthLdap*
-
: Running a MariaDB server
MYSQL_TEST_HOST=127.0.0.1
MYSQL_TEST_PORT=3308
@@ -430,8 +429,12 @@ cp %{SOURCE12} inc/downstream.php
: Run upstream test suite
php scripts/cliinstall.php --host=127.0.0.1:3308 --db=glpitest --user=root --tests --force --lang=en_GB || RET=1
-atoum --debug --use-dot-report --bootstrap-file tests/bootstrap.php --no-code-coverage --use-light-report --max-children-number 1 -d tests/units || RET=1
-atoum --debug --use-dot-report --bootstrap-file tests/bootstrap.php --no-code-coverage --use-light-report --max-children-number 1 -d tests/web || RET=1
+atoum --debug --use-dot-report --bootstrap-file tests/bootstrap.php --no-code-coverage \
+ -d tests/units || RET=1
+atoum --debug --use-dot-report --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 \
+ -d tests/functionnal || RET=1
+atoum --debug --use-dot-report --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 \
+ -d tests/web || RET=1
: Cleanup
if [ -s $MYSQL_PID_FILE ]; then
@@ -519,6 +522,10 @@ fi
%changelog
+* Fri Apr 27 2018 Remi Collet <remi@remirepo.net> - 9.2.3-1
+- update to 9.2.3
+- add dependency on sebastian/diff 1.4
+
* Fri Mar 16 2018 Remi Collet <remi@remirepo.net> - 9.2.2-2
- run test with --use-dot-report from atoum 3.3