summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json27
-rw-r--r--glpi-fedora-autoloader.php4
-rw-r--r--glpi.spec29
3 files changed, 37 insertions, 23 deletions
diff --git a/composer.json b/composer.json
index 99afa58..a0c67f4 100644
--- a/composer.json
+++ b/composer.json
@@ -24,22 +24,24 @@
"phpmailer/phpmailer": "~5.2",
"sabre/vobject": "~4.1",
"simplepie/simplepie": "^1.5",
- "tecnickcom/tcpdf": "~6.2",
+ "tecnickcom/tcpdf": "~6.2.16",
"zendframework/zend-cache": "^2.7",
"zendframework/zend-i18n": "^2.7",
"zendframework/zend-serializer": "^2.7",
"michelf/php-markdown": "^1.6",
"true/punycode": "^2.1",
- "paragonie/random_compat": "^2.0"
+ "paragonie/random_compat": "^2.0",
+ "sebastian/diff": "^1.4"
},
"require-dev": {
"guzzlehttp/guzzle": "~6",
- "glpi-project/coding-standard": "0.6",
+ "glpi-project/coding-standard": "^0.7.0",
"consolidation/robo": "^1.0",
"natxet/CssMin": "^3.0",
"patchwork/jsqueeze": "^2.0",
- "atoum/atoum": "^3.2",
- "atoum/telemetry-extension": "^1.0"
+ "atoum/atoum": "^3.3",
+ "atoum/telemetry-extension": "^1.0",
+ "fzaninotto/Faker": "^1.7"
},
"suggest": {
"ext-ldap": "Used ot provide LDAP authentication and synchronization",
@@ -52,13 +54,16 @@
}
},
"scripts": {
- "testdb": "vendor/bin/atoum --debug --force-terminal --configurations tests/telemetry.php --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 -d tests/database",
- "test": "vendor/bin/atoum --debug --force-terminal --configurations tests/telemetry.php --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 -d tests/units",
- "testweb": "vendor/bin/atoum --debug --force-terminal --configurations tests/telemetry.php --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 -d tests/web",
- "testldap": "vendor/bin/atoum --debug --force-terminal --configurations tests/telemetry.php --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 -d tests/LDAP",
- "cs": "vendor/bin/phpcs -p --standard=vendor/glpi-project/coding-standard/GlpiStandard/ --ignore=/vendor/,/plugins/,/files/,/lib/,/config/,/tests/config ./",
+ "testdb": "php -d memory_limit=512M vendor/bin/atoum --debug --force-terminal --use-dot-report --configurations tests/telemetry.php --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 -d tests/database",
+ "testfunc": "php -d memory_limit=512M vendor/bin/atoum --debug --force-terminal --use-dot-report --configurations tests/telemetry.php --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 -d tests/functionnal/",
+ "testunits": "php -d memory_limit=512M vendor/bin/atoum --debug --force-terminal --use-dot-report --configurations tests/telemetry.php --bootstrap-file tests/bootstrap.php --no-code-coverage -d tests/units",
+ "testweb": "php -d memory_limit=512M vendor/bin/atoum --debug --force-terminal --use-dot-report --configurations tests/telemetry.php --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 -d tests/web",
+ "testldap": "php -d memory_limit=512M vendor/bin/atoum --debug --force-terminal --use-dot-report --configurations tests/telemetry.php --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 -d tests/LDAP",
+ "csp": "vendor/bin/phpcs --parallel=500 -p --standard=vendor/glpi-project/coding-standard/GlpiStandard/ --ignore=/vendor/,/plugins/,/files/,/lib/,/config/,/tests/config,/.git ./",
+ "cs": "vendor/bin/phpcs -d memory_limit=512M -p --standard=vendor/glpi-project/coding-standard/GlpiStandard/ --ignore=/vendor/,/plugins/,/files/,/lib/,/config/,/tests/config,/css/tiny_mce,/.git ./",
"post-install-cmd": [
- "@php -r \"file_put_contents('.composer.hash', sha1_file('composer.lock'));\""
+ "@php -r \"file_put_contents('.composer.hash', sha1_file('composer.lock'));\"",
+ "patch -d vendor/zendframework/zend-cache/ -p1 < tools/zend-cache-php7.2.patch"
],
"post-update-cmd": "@php -r \"file_put_contents('.composer.hash', sha1_file('composer.lock'));\""
}
diff --git a/glpi-fedora-autoloader.php b/glpi-fedora-autoloader.php
index 49ea0de..6224a52 100644
--- a/glpi-fedora-autoloader.php
+++ b/glpi-fedora-autoloader.php
@@ -15,7 +15,7 @@ require_once "$vendor/Fedora/Autoloader/autoload.php";
"$vendor/Sabre/VObject4/autoload.php",
// "simplepie/simplepie": "^1.5",
"$vendor/php-simplepie/autoloader.php",
- // "tecnickcom/tcpdf": "~6.2",
+ // "tecnickcom/tcpdf": "~6.2.16",
"$vendor/tcpdf/autoload.php",
// "zendframework/zend-cache": "^2.7",
[
@@ -38,5 +38,7 @@ require_once "$vendor/Fedora/Autoloader/autoload.php";
"$vendor/TrueBV/autoload.php",
// "paragonie/random_compat": "^2.0"
"$vendor/random_compat/autoload.php",
+// "sebastian/diff": "^1.4"
+ "$vendor/SebastianBergmann/Diff/autoload.php",
]);
diff --git a/glpi.spec b/glpi.spec
index 0b51e6a..5c308fd 100644
--- a/glpi.spec
+++ b/glpi.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
-%global gh_commit aff731b59aaa4e0c07c802b6ca30074b46dbf501
+%global gh_commit 84b68efa767f66f5d4bf90de8851751f9e8b8aeb
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20160923
%global gh_owner glpi-project
@@ -40,8 +40,8 @@
%endif
Name: %{gh_project}
-Version: 9.2.2
-Release: 2%{?dist}
+Version: 9.2.3
+Release: 1%{?dist}
Summary: Free IT asset management software
Summary(fr): Gestion Libre de Parc Informatique
@@ -82,7 +82,9 @@ BuildRequires: php-composer(sabre/vobject) < 5
BuildRequires: php-composer(sabre/vobject) >= 4.1
BuildRequires: php-composer(simplepie/simplepie) < 2
BuildRequires: php-composer(tecnickcom/tcpdf) < 7
-BuildRequires: php-composer(tecnickcom/tcpdf) >= 6.2.13
+BuildRequires: php-composer(tecnickcom/tcpdf) >= 6.2.16
+# Because 3 versions exists TODO: use range dependency
+BuildRequires: php-phpunit-diff >= 1.4
# remirepo:1
%if 0%{?fedora} >= 25 || 0%{?rhel} >= 8
BuildRequires: php-autoloader(zendframework/zend-cache) < 3
@@ -163,9 +165,9 @@ Requires: php-composer(sabre/vobject) < 5
Requires: php-composer(sabre/vobject) >= 4.1
Requires: php-composer(simplepie/simplepie) < 2
Requires: php-composer(simplepie/simplepie) >= 1.5
-# 6.2.13 to ensure we have the classmap autoloader
Requires: php-composer(tecnickcom/tcpdf) < 7
-Requires: php-composer(tecnickcom/tcpdf) >= 6.2.13
+Requires: php-composer(tecnickcom/tcpdf) >= 6.2.16
+Requires: php-phpunit-diff >= 1.4
# remirepo:1
%if 0%{?fedora} >= 25 || 0%{?rhel} >= 8
Requires: php-autoloader(zendframework/zend-cache) < 3
@@ -390,9 +392,6 @@ export GLPI_URI=http://127.0.0.1:8089
%{_bindir}/php -S 127.0.0.1:8089 tests/router.php &>web.log &
PHPPID=$!
-: Skip LDAP tests for now
-rm tests/units/AuthLdap*
-
: Running a MariaDB server
MYSQL_TEST_HOST=127.0.0.1
MYSQL_TEST_PORT=3308
@@ -430,8 +429,12 @@ cp %{SOURCE12} inc/downstream.php
: Run upstream test suite
php scripts/cliinstall.php --host=127.0.0.1:3308 --db=glpitest --user=root --tests --force --lang=en_GB || RET=1
-atoum --debug --use-dot-report --bootstrap-file tests/bootstrap.php --no-code-coverage --use-light-report --max-children-number 1 -d tests/units || RET=1
-atoum --debug --use-dot-report --bootstrap-file tests/bootstrap.php --no-code-coverage --use-light-report --max-children-number 1 -d tests/web || RET=1
+atoum --debug --use-dot-report --bootstrap-file tests/bootstrap.php --no-code-coverage \
+ -d tests/units || RET=1
+atoum --debug --use-dot-report --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 \
+ -d tests/functionnal || RET=1
+atoum --debug --use-dot-report --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 \
+ -d tests/web || RET=1
: Cleanup
if [ -s $MYSQL_PID_FILE ]; then
@@ -519,6 +522,10 @@ fi
%changelog
+* Fri Apr 27 2018 Remi Collet <remi@remirepo.net> - 9.2.3-1
+- update to 9.2.3
+- add dependency on sebastian/diff 1.4
+
* Fri Mar 16 2018 Remi Collet <remi@remirepo.net> - 9.2.2-2
- run test with --use-dot-report from atoum 3.3